Introduction

This document describes the different steps to consider when porting an embedded application from Atmel® START to the MPLAB® Harmony 3 framework. It covers the following migration aspects:

- How to create a MPLAB Harmony 3 project under MPLAB X IDE and navigate through the MPLAB Harmony Configurator (MHC).
- How to identify different elements that compose a project under Atmel START.
- How to port the system/driver/middleware configuration using MPLAB Harmony Configurator.
- Important aspects to consider when porting the project application layer.

To illustrate these aspects, this document references the SAM D21 IO1 Xplained demo example available on Atmel START. Prior starting the migration process, ensure that the following prerequisites are met:

- Internet connection with access to https://start.atmel.com
- Latest version of MPLAB X IDE https://www.microchip.com/mplab/mplab-x-ide
- Latest version of MPLAB Harmony 3 https://github.com/Microchip-MPLAB-Harmony
- SAM D21 Xplained Pro board (optional)
- I/O1 Xplained Pro board (optional)
# Table of Contents

Introduction .................................................................................................................................................. 1

1. Creating MPLAB Harmony 3 Project Under MPLAB X IDE ................................................................. 3

2. Identifying the Resources Used in the Atmel START Project ............................................................ 8

3. Porting Driver Configuration from Atmel START ............................................................................ 13

4. Porting the System PINMUX Configuration from Atmel START ...................................................... 19

5. Porting the System Clock Configuration from Atmel START ............................................................ 26

6. Porting and Adapting Middleware ..................................................................................................... 35

7. Porting the Application Source Code ................................................................................................. 38

The Microchip Website ............................................................................................................................. 41

Product Change Notification Service ....................................................................................................... 41

Customer Support .................................................................................................................................. 41

Microchip Devices Code Protection Feature ........................................................................................... 41

Legal Notice ............................................................................................................................................. 41

Trademarks ............................................................................................................................................... 42

Quality Management System .................................................................................................................. 42

Worldwide Sales and Service .................................................................................................................... 43
1. Creating MPLAB Harmony 3 Project Under MPLAB X IDE

The first step in this process is creating a MPLAB Harmony 3 project under MPLAB X IDE. This new project will enable access to the MPLAB Harmony 3 Configurator (MHC), and access the list of software modules, such as peripheral libraries, services and middleware, which are available for the target SAM device.

![MPLAB Harmony 3 Configurator Available Components](image)

Figure 1-1. MPLAB Harmony 3 Configurator Available Components

To create a project for the SAM D21J18A device, follow these steps:

1. Launch MPLAB X IDE.
2. In MPLAB X IDE, select File > New Project (or click the New Project icon).
3. In the New Project window, under Steps, select Choose Project, and then under Choose Project section, select these options: for Categories select Microchip Embedded, and for Projects select 32-bit MPLAB Harmony 3 Project.

**Note:** If the option 32-Bit MPLAB Harmony 3 Project is not available, users need to install the MPLAB Harmony 3 Configurator plug-in by selecting Tools > Plugins > Available Plugins before continuing with this demonstration. MPLAB Harmony 3 Configurator overview is available for download at [https://microchipdeveloper.com/harmony3:mhc-overview](https://microchipdeveloper.com/harmony3:mhc-overview).
4. Click **Next**.

5. Select Framework Selection, and under Manage Framework section, enter Framework Path (Path to the folder in which the MPLAB Harmony 3 packages are downloaded). For this demonstration, the MPLAB Harmony 3 packages are already downloaded at D:\microchip\github\h3.

6. Click **Next**.

7. Select Project Settings, and under Name and Location section enter MPLAB Harmony 3 new project details:
   - **Location**: Indicates the path to the root folder of the new project. All project files will be placed inside this folder.
   - **Folder**: Indicates the name of the MPLAB X IDE folder.
   - **Name**: Enter name of the project. This name will be shown in the MPLAB X IDE.
   - **Path**: It is read-only box. It will update as and when users make changes to other entries.
8. Click **Next**.
9. Select Configuration Settings, and then enter details as given below:
   - Name: Enter the configuration name.
   - Target Device: Choose a device name.
10. Click **Finish**.

The new MPLAB Harmony 3 project will be launched.

**Note:** After clicking the Finish button, if MHC does not launch, the user can launch it by selecting Tools > Embedded > MPLAB® Harmony 3 Configurator from the menu bar of the MPLAB X IDE.
The software modules associated with the project configuration are seen by selecting Tools > Embedded > MPLAB Harmony 3 Configurator.

The associated MPLAB Harmony 3 Configurator list will be displayed as shown in the figure below.
Figure 1-8. MPLAB Harmony 3 Configurator - Available Component List
2. Identifying the Resources Used in the Atmel START Project

Before porting the application, users need to identify the software modules that compose the application. As both Atmel START and MPLAB Harmony 3 frameworks provide a graphical configuration interface, hence it is simple to identify the different drivers and middleware modules that are used by the application and compare them to the available MPLAB Harmony 3 modules.

**Figure 2-1. Atmel START Graphical Configuration Interface**

Note: Some applications include additional software functions or middleware that are not part of Atmel START. Therefore, it is important to review the full application flowchart or project architecture to identify them.

Follow these steps while using the SAM D21 I/O1 example from Atmel START as a reference.

1. In Atmel Studio 7, open the Atmel START project to be ported by selecting *Project > Re-Configure Atmel Start Project.*
Figure 2-3. Reconfiguring Atmel START Project

Note: The project can also be opened by loading its .atstart/.atzip file at https://start.atmel.com.

Atmel START main window showing Load Project tab is displayed.

Figure 2-4. Load Project From a File Under Atmel START

2. When project is loaded, click on the Dashboard tab and identify the Atmel START drivers and its configuration.
3. Check the application code and application flowchart to identify whether any additional services and middleware are required. The figure below illustrates the SAM D21 I/O1 flowchart.

Figure 2-6. Additional Service Middleware Identification Using a Flowchart

4. If MPLAB Harmony Configurator is not opened, from MPLAB X IDE open the MPLAB Harmony 3 Configurator by selecting Tools > Embedded > MPLAB Harmony 3 Configurator.
Figure 2-7. Accessing MPLAB Harmony 3 Configurator

5. Search for software module availability in Harmony 3 Configurator, and then drag and drop it into the Project Graph window.

Figure 2-8. Identifying Software Module in MHC

The table below provides the drivers and middleware used for this demonstration.
### Table 2-1. Drivers and Middleware

<table>
<thead>
<tr>
<th></th>
<th>ATMEL START Module</th>
<th>Harmony 3 Module</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drivers</td>
<td>IO1_LIGHT_SENS</td>
<td>ADC</td>
</tr>
<tr>
<td></td>
<td>I²C</td>
<td>SERCOM2</td>
</tr>
<tr>
<td></td>
<td>EDBG_COM</td>
<td>SERCOM3</td>
</tr>
<tr>
<td></td>
<td>Systick (implicit)</td>
<td>SYSTEM &gt; SYSTICK</td>
</tr>
<tr>
<td>Middleware</td>
<td>AT30SE75X</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>STDIO Redirect</td>
<td>STDIO</td>
</tr>
</tbody>
</table>

**Note:** Specific development is required for AT30SE75X. Other drivers, system services, and middleware are available under MPLAB Harmony 3.
3. Porting Driver Configuration from Atmel START

To port a driver from Atmel Studio to MPLAB Harmony 3 is a straightforward operation as it relies on the comparison of Atmel START and MPLAB Harmony Configurator Graphical interfaces.

Figure 3-1. Atmel START to MPLAB X Driver Support

Follow these steps for the SAM D21 I/O1 Xplained demonstration:

1. Add peripheral library (drivers) to the MPLAB Harmony 3 project by dragging them from the Available Component list to the Project Graph section.

   Figure 3-2. Add Peripheral Driver from the Available Component List

2. Configure all the MPLAB Harmony 3 peripheral libraries according to their equivalent driver in Atmel START.
   
   **Note:** Specific Atmel START driver configurations can be seen by clicking individually on each of the driver component in the application dashboard interface.
Figure 3-3. Access Driver Configuration in Atmel START

- ADC peripheral Library (IO1_LIGHT_SENS) configuration.
Figure 3-4. Port ADC Driver Configuration

- SERCOM3 peripheral Library (EDBG_COM) configuration
Figure 3-5. Port SERCOM3 Driver Configuration

- SERCOM2 peripheral Library (I²C) configuration
After generating the project source code from the MHC interface by clicking or selecting **MHC > Generate Code**, the peripheral libraries (PLIBs) configuration can be found in the following project directories:
The API function definition used by the application can be found in the peripheral library header files.

Figure 3-9. Peripheral Libraries API Location
4. Porting the System PINMUX Configuration from Atmel START

Porting an application PINMUX configuration from Atmel Studio to MPLAB Harmony 3 is a straightforward operation as it relies on comparison as each framework graphical interface offers similar capabilities.

Figure 4-1. Atmel START and MHC Pin Configuration Interface Comparison

Follow these steps for the SAM D21 IO1 Xplained demonstration:

1. In Atmel START, click on the PINMUX tab and identify which I/O pins are configured and used in the application.
Figure 4-2. Identify I/O Pins Configuration Under Atmel START

Note: The configuration of each pin is available by clicking on it in the PINMUX configurator table.

Figure 4-3. Identify I/O Pins Configuration Under Atmel START (Continued)

2. In MPLAB X IDE, select MHC > Tools > Pin Configuration to open the project pin configurator interface.
Figure 4-4. Accessing MHC Under MPLAB X

Note: The following tab in the MHC interface enables the customization of the application pin configuration.

Figure 4-5. Accessing Pin Configuration Windows Under the MHC

3. Port the I/O pin configuration from Atmel Studio to the MHC Pin Setting tab.
   - SERCOM 2 I/O settings
Figure 4-6. SERCOM 2 I/O Settings

Pin 17 (PA08) is used as SDA with I2C.

Tip: Use ctrl or shift to select more than one pin.

- SERCOM 3 I/Os settings
Figure 4-7. SERCOM 3 I/O settings

- ADC I/Os settings
4. Verify that the MHC pin diagram is aligned with the initial Atmel START project pin diagram.

After regenerating the project source from the MHC interface by clicking , the port initialization routine executed during program initialization can be found in the following project files. This initialization routine is automatically generated by the MHC according to the user configuration entered in the graphical interface.
Figure 4-10. MHC Generated Pin Configuration

Note: During application run-time, the PORT configuration can be changed by calling APIs from the MPLAB Harmony 3 PORT PLIB.
5. **Porting the System Clock Configuration from Atmel START**

The porting of an application clock configuration from Atmel Studio to MPLAB Harmony 3 is a straightforward operation as it relies on the comparison of both framework graphical interfaces which offer similar capabilities.

**Figure 5-1. Atmel START and MHC Clock Configuration Interface Comparison**

1. In Atmel START, click the **PINMUX** tab and identify different clock elements used in the application and their settings.
Figure 5-2. Identify Project Clock Configuration Under Atmel START

**Note:** Additional information on the settings for a specific clock element can be retrieved by clicking on the associated blue gear wheel button.

Figure 5-3. Access Clock Element Settings Under Atmel START

2. To open the project pin configurator interface, in MPLAB X IDE, select MHC > Tools > Clock Configuration.
3. Port each clock component configuration from Atmel START to the MHC Clock view.
   - 8 MHz Internal Oscillator (OSC8M)
Figure 5-5. 8MHz Internal Oscillator Configuration Port

- GCLK Generator 0
Figure 5-6. GCLK Generator 0 Configuration Port

- GCLK Generator 1
Figure 5-7. GCLK Generator 1 Configuration Port

- ADC Peripheral clock
Figure 5-8. ADC Peripheral Clock Configuration Port

- SERCOM2 Peripheral clock
Figure 5-9. SERCOM2 Peripheral Configuration Port

- SERCOM3 Peripheral clocks
Figure 5-10. SERCOM3 Peripheral Configuration Port
Porting and Adapting Middleware

The complexity behind the porting of middleware depends on its availability in the MPLAB Harmony 3 framework. The following two approaches can be used for porting middleware:

1. If middleware is available under MPLAB Harmony 3, include the middleware in the MHC project graph and link it to the associated driver. MPLAB Harmony 3 will be automatically generate a Hardware Abstraction Layer customized for this driver and middleware combination.

   Figure 6-1. STDIO Middleware or Service Integration Under MHC

2. If the middleware is not available under Harmony 3, the user must include the source of the middleware in the new project, then locate and modify the Hardware Abstraction Layer to call the APIs provided in the Peripheral Library.

The following steps illustrate the process to be followed for the SAM D21 I/O1 demonstration.

By analyzing the structure of the application (Step 1), using both the Atmel START Dashboard and the application source code, the following middlewares are used in the Atmel START source application:

- AT30TSE75X : temperature sensor
- STDIO redirection (implicitly added)
The AT30TSE is currently not available under MPLAB X IDE, therefore a manual source port must be created. This step will be covered in step seven when porting the application source code.

1. In MPLAB X IDE, add the STDIO middleware to the project using the MHC Project Graph window then link the STDIO middleware to the SERCOM3 driver.

After regenerating the project source from the MHC interface by clicking , the STDIO redirection HAL will be generated according to the graphical configuration. The `getc` and `putc` functions will be redirected to the SERCOM3 APIs.
Figure 6-4. MHC Generated STDIO Redirection

```c
#include "definitions.h"

volatile int c = 6;
while(SERCOM3_USART_Read((void*)&c, 1) != 55)
  return c;

void _mon_puts(char c)
{
  size = 0;
  do
    size = SERCOM3_USART_Write((void*)&c, 1);
    while (size != 0);
}
```
7. Porting the Application Source Code

After drivers, system, and middleware layers are ported to the MPLAB Harmony 3 project, all available peripheral libraries and middleware APIs required to port the application are available in the project directory.

Figure 7-1. MPLAB Harmony 3 Drivers and Middleware APIs Location

Porting the application layer requires the review of the Atmel START main application routine and associated application layer related functions, and modifying them to make use of the MPLAB Harmony 3 APIs instead of the Atmel START ones.

The following figure illustrates the effort to port the application layer of the SAM D21 IO1 Xplained demo example to MPLAB Harmony 3.
The result of the SAM D21 I/O1 Xplained demo application layer porting is shown below:

```c
#include <stddef.h>                     // Defines NULL
#include <stdbool.h>                    // Defines true
#include <stdlib.h>                     // Defines EXIT_FAILURE
#include "definitions.h"                // SYS function prototypes

#define AT30TSE_SENSOR_ADDRESS 0x4F
#define STR_SIZE 50

uint16_t adc_read_channel(void);
bool temperature_sensor_init(void);
float temperature_sensor_read(void);

uint16_t adc_read_channel(void)
{
    /*- Start ADC channel */
    ADC_ConversionStart();
    /*- Wait until result is ready */
    while(ADC_ConversionStatusGet() != true);
    return ADC_ConversionResultGet();
}

bool temperature_sensor_init(void)
{
    bool res;
    uint8_t buffer[3];
    /*- Configure the AT30TSE sensor */
    buffer[0] = 1;        // Select Configuration register
    buffer[1] = (2 << 5); // Set resolution to 11-bit
    buffer[2] = 0;
    res = SERCOM2_I2C_Write(AT30TSE_SENSOR_ADDRESS,buffer,3);
    return res;
}
```
```c
float temperature_sensor_read(void)
{
    uint8_t txbuffer[2];
    uint8_t rxbuffer[2];
    uint16_t data;
    int8_t sign = 1;

    /* - Read the 16-bit temperature register. */
    txbuffer[0] = 0x0; // Select Temperature register
    SERCOM2_I2C_WriteRead(AT30TSE_SENSOR_ADDRESS,txbuffer,1,rxbuffer,2);
    /* - Convert Rx buffer content into temperature */
    data = (rxbuffer[0] << 8) | rxbuffer[1];
    sign -= (bool)(data & (1 << 15)) << 1;
    data &= ~(1 << 15);
    data = data >> (7 - 2);

    return (float)data * sign * (0.5 / (1 << 2));
}

int main ( void )
{
    uint16_t light_val;
    uint16_t temp_result;

    /*- Initialize all modules */
    SYS_Initialize (NULL);
    SYSTICK_TimerStart();
    /*- Enable ADC */
    ADC_Enable();
    /*- Initialize I/O1 temperature sensor */
    temperature_sensor_init();
    while ( true )
    {
        /*- Wait 1 second */
        SYSTICK_DelayMs(1000);
        /*- Read light level */
        light_val = adc_read_channel();
        /*- Read temperature */
        temp_result = temperature_sensor_read();
        /*- Display Light and temperature information on Terminal */
        printf("Temperature: %d Celsius, light sensor: 0x%lx\n", temp_result, light_val);
    }
    /*- Execution should not come here during normal operation */
    return ( EXIT_FAILURE );
}
```
The Microchip Website

Microchip provides online support via our website at http://www.microchip.com/. This website is used to make files and information easily available to customers. Some of the content available includes:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip design partner program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will receive email notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, go to http://www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Embedded Solutions Engineer (ESE)
- Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: http://www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with
your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime, BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox, KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST, MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer, QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon, TempTracker, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control, HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra, TimeProvider, Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.

© 2019, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

ISBN: 978-1-5224-5403-8

Quality Management System

For information regarding Microchip’s Quality Management Systems, please visit http://www.microchip.com/quality.
### Worldwide Sales and Service

<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Corporate Office</strong></td>
<td><strong>Australia - Sydney</strong></td>
<td><strong>India - Bangalore</strong></td>
<td><strong>Austria - Wels</strong></td>
</tr>
<tr>
<td>2355 West Chandler Blvd.</td>
<td>Tel: 61-2-9868-6733</td>
<td>Tel: 91-80-3090-4444</td>
<td>Tel: 43-7242-2244-39</td>
</tr>
<tr>
<td>Chandler, AZ 85224-6199</td>
<td>China - Beijing</td>
<td>India - New Delhi</td>
<td>Fax: 43-7242-2244-393</td>
</tr>
<tr>
<td>Tel: 480-792-7200</td>
<td>Tel: 86-10-8569-7000</td>
<td>India - Pune</td>
<td><strong>Denmark - Copenhagen</strong></td>
</tr>
<tr>
<td>Fax: 480-792-7277</td>
<td>China - Chengdu</td>
<td>Tel: 91-11-4160-8631</td>
<td>Tel: 45-4450-2828</td>
</tr>
<tr>
<td>Technical Support:</td>
<td>Tel: 86-28-8665-5511</td>
<td>Japan - Osaka</td>
<td>Fax: 45-4485-2829</td>
</tr>
<tr>
<td><a href="http://www.microchip.com/support">http://www.microchip.com/support</a></td>
<td>China - Chongqing</td>
<td>Japan - Tokyo</td>
<td>Finland - Espoo</td>
</tr>
<tr>
<td>Web Address:</td>
<td>Tel: 86-23-8980-9588</td>
<td>Tel: 81-6-6152-7160</td>
<td>Tel: 358-9-4520-820</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-769-8702-9880</td>
<td>Tel: 82-53-744-4301</td>
<td>Tel: 33-1-69-53-63-20</td>
</tr>
<tr>
<td></td>
<td>China - Guangzhou</td>
<td>Korea - Seoul</td>
<td>Fax: 33-1-69-30-90-79</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-20-8755-8029</td>
<td></td>
<td>Germany - Garching</td>
</tr>
<tr>
<td></td>
<td>China - Hangzhou</td>
<td></td>
<td>Tel: 49-8931-9700</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-571-8792-8115</td>
<td></td>
<td>Germany - Haan</td>
</tr>
<tr>
<td></td>
<td>China - Hong Kong SAR</td>
<td>Malaysia - Kuala Lumpur</td>
<td>Tel: 49-2129-3766400</td>
</tr>
<tr>
<td></td>
<td>Tel: 852-2943-5100</td>
<td>Malaysia - Penang</td>
<td>Germany - Hellbronn</td>
</tr>
<tr>
<td></td>
<td>China - Nanjing</td>
<td>Tel: 60-4-227-8870</td>
<td>Tel: 49-7131-72400</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-25-8473-2460</td>
<td>Philippines - Manila</td>
<td>Germany - Karlsruhe</td>
</tr>
<tr>
<td></td>
<td>China - Qingdao</td>
<td>Tel: 63-2-634-9065</td>
<td>Tel: 49-721-625370</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-532-8502-7355</td>
<td>Singapore</td>
<td>Germany - Munich</td>
</tr>
<tr>
<td></td>
<td>China - Shanghai</td>
<td>Tel: 65-6334-8870</td>
<td>Tel: 49-89-627-144-0</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-21-3326-8000</td>
<td>Taiwan - Hsin Chu</td>
<td>Fax: 49-89-627-144-44</td>
</tr>
<tr>
<td></td>
<td>China - Shenyang</td>
<td>Tel: 886-3-577-8366</td>
<td>Germany - Rosenheim</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-24-2334-2829</td>
<td>Taiwan - Kaohsiung</td>
<td>Tel: 49-8031-354-560</td>
</tr>
<tr>
<td></td>
<td>China - Shenzhen</td>
<td>Tel: 886-7-213-7830</td>
<td>Israel - Ra’anana</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-755-8864-2200</td>
<td>Taiwan - Taipei</td>
<td>Tel: 972-9-744-7705</td>
</tr>
<tr>
<td></td>
<td>China - Suzhou</td>
<td>Tel: 886-2-2508-8600</td>
<td>Italy - Milan</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-186-6233-1526</td>
<td>Thailand - Bangkok</td>
<td>Tel: 39-0331-742611</td>
</tr>
<tr>
<td></td>
<td>China - Wuhan</td>
<td>Tel: 66-2-694-1351</td>
<td>Fax: 39-0331-466781</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-27-5980-5300</td>
<td>Vietnam - Ho Chi Minh</td>
<td>Italy - Padova</td>
</tr>
<tr>
<td></td>
<td>China - Xian</td>
<td>Tel: 84-28-5448-2100</td>
<td>Tel: 39-049-7625286</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-29-8833-7252</td>
<td></td>
<td>Netherlands - Drunen</td>
</tr>
<tr>
<td></td>
<td>China - Xiamen</td>
<td></td>
<td>Tel: 31-416-690399</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-592-2388138</td>
<td></td>
<td>Fax: 31-416-690340</td>
</tr>
<tr>
<td></td>
<td>China - Zhuhai</td>
<td></td>
<td><strong>Norway - Trondheim</strong></td>
</tr>
<tr>
<td></td>
<td>Tel: 86-755-3210040</td>
<td></td>
<td>Tel: 47-72864388</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Poland - Warsaw</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 48-22-3325737</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Romania - Bucharest</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 40-21-407-87-50</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Spain - Madrid</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 34-91-708-08-90</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fax: 34-91-708-08-91</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Sweden - Gothenberg</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 46-31-704-60-40</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Sweden - Stockholm</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 46-8-5090-4654</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>UK - Wokingham</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 44-118-921-5800</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fax: 44-118-921-5820</td>
</tr>
</tbody>
</table>