MPLAB® IPE
(Integrated Programming Environment)
User’s Guide
Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip's Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip's code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, AnyRate, AVR, AVR logo, AVR Freaks, BeaconThings, BitCloud, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, Heldo, JukeBlox, KEEL0G, KEEL0G logo, Kleer, LANCHECK, LINK MD, maxSylus, maxTouch, MediaLB, megaAVR, MOST, MOST logo, MLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, Prochip Designer, QTouch, RightTouch, SAM-BA, SpyNIC, SST, SST Logo, SuperFlash, tinyAVR, UNI/O, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

ClockWorks, The Embedded Control Solutions Company, EtherSynch, Hyper Speed Control, HyperLight Load, IntelliMOS, mTouch, Precision Edge, and Quiet-Wire are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

Silicon Storage Technology is a registered trademark of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.

© 2013-2018, Microchip Technology Incorporated, All Rights Reserved.

ISBN: 978-1-5224-3238-8
# Table of Contents

**Preface** .......................................................................................................................................................... 5

**Chapter 1. IPE Application Overview**

  1.1 IPE Defined ........................................................................................................................................... 9
  1.2 Software Installation Requirements ................................................................................................. 9
  1.3 Programming Tools Supported ....................................................................................................... 10
  1.4 IPE Modes ........................................................................................................................................... 10

**Chapter 2. General Setup**

  2.1 Introduction ......................................................................................................................................... 13
  2.2 Launching the MPLAB IPE Application ............................................................................................ 13
  2.3 Setting Up the Programmer ............................................................................................................... 14
  2.4 Advanced Mode Login ....................................................................................................................... 16
  2.5 Advanced Mode Settings ...................................................................................................................... 17

**Chapter 3. MPLAB IPE Reference**

  3.1 IPE Main Window ............................................................................................................................... 29
  3.2 File Menu ........................................................................................................................................... 31
  3.3 Settings Menu .................................................................................................................................... 32
  3.4 View Menu ........................................................................................................................................... 34
  3.5 Tools Menu ......................................................................................................................................... 36
  3.6 Window Menu ...................................................................................................................................... 36
  3.7 Help Menu ........................................................................................................................................... 36

**Appendix A. Revision History**

**Support** ..................................................................................................................................................... 39

**Index** .......................................................................................................................................................... 41

**Worldwide Sales and Service** .................................................................................................................. 45
Preface

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level
of the document.

For the most up-to-date information on development tools, see the MPLAB® X IDE online help.
Select the Help menu, and then Topics to open a list of available online help files.

INTRODUCTION

This chapter contains general information that will be useful to know before using the
MPLAB® Integrated Programming Environment (IPE) is installed. This document is
compatible with the version of the IPE installed with MPLAB X IDE v4.20 or greater.
Items discussed in this chapter include:

• Document Layout
• Conventions Used in this Guide
• Recommended Reading

DOCUMENT LAYOUT

This document describes how to use the MPLAB IPE programming tool to program
devices. The document is organized as follows:

• Chapter 1. IPE Application Overview – Defines the IPE, provides software
installation requirements and upgrade procedures, lists the supported tools, and
provides a feature matrix.
• Chapter 2. General Setup – Discusses launching and setting up the application,
and provides Advanced Mode login and options information.
• Chapter 3. MPLAB IPE Reference – Provides reference information for the
menu items.
CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

<table>
<thead>
<tr>
<th>DOCUMENTATION CONVENTIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Arial font:</td>
</tr>
<tr>
<td>Italic characters</td>
</tr>
<tr>
<td>Emphasized text</td>
</tr>
<tr>
<td>Initial caps</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Quotes</td>
</tr>
<tr>
<td>Underlined, italic text with right angle bracket</td>
</tr>
<tr>
<td>Bold characters</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>N'Rnnnn</td>
</tr>
<tr>
<td>Text in angle brackets &lt; &gt;</td>
</tr>
<tr>
<td>Courier New font:</td>
</tr>
<tr>
<td>Plain Courier New</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Italic Courier New</td>
</tr>
<tr>
<td>Square brackets [ ]</td>
</tr>
<tr>
<td>Curly brackets and pipe character: {</td>
</tr>
<tr>
<td>Ellipses...</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
RECOMMENDED READING

This user's guide describes how to use Microchip MPLAB IPE. Other useful documents are listed below. The following Microchip documents are available and recommended as supplemental reference resources.

Multi-Tool Design Advisory (DS51764)

Please read this first! This document contains important information about operational issues that should be considered when using the MPLAB IPE with your target design.

MPLAB X IDE Online Help

This is an essential document to be used with any Microchip hardware tool.

This is an extensive help file for the MPLAB X IDE. It includes an overview of embedded systems, installation requirements, tutorials, details on creating new projects, setting build properties, debugging code, setting configuration bits, setting breakpoints, programming a device, etc. This help file is generally more up-to-date than the printable PDF of the user's guide (DS50002027) available as a free download at http://www.microchip.com/mplabx/.

Release Notes for MPLAB IPE

For the latest information on using the MPLAB IPE, read the notes under “Release Notes and Support Documentation” on the MPLAB X IDE Start Page. The release notes contain updated information and known issues that may not be included in this guide.

MPLAB IPE Online Help File

A comprehensive help file for the MPLAB IPE is included with MPLAB X IDE. This help file may be more up-to-date than the printed documentation.

Processor Extension Pak and Header Specification (DS50001292)

This booklet describes how to install and use headers. Headers are used to better debug selected devices, without the loss of pins or resources. See also the PEP and Header online Help file.

Transition Socket Specification (DS51194)

Consult this document for information on transition sockets available for use with headers.

SQTP File Format Specification (DS50002539)

This document shows how a Serial Quick Turn Programming (SQTP℠) file is produced and used by MPLAB® IPE Integrated Programming Environment. Engineers can use this information to generate their own SQTP file.
Chapter 1. IPE Application Overview

1.1 IPE DEFINED

The MPLAB® Integrated Programming Environment (IPE) is a software application that provides a simple interface to quickly access key programmer features. The IPE provides a production user interface for use on the manufacturing floor.

The MPLAB IPE (now based on NetBeans) uses the MPLAB X IDE v4.20 or greater framework, Microchip Debugger (MDB) database, hardware tool interfaces and respective drivers to provide programming capabilities for all Microchip programmers.

The MPLAB IPE is compatible with any of these platforms:

- Microsoft Windows® 7 or later
- Linux®
- macOS™

1.2 SOFTWARE INSTALLATION REQUIREMENTS

The MPLAB IPE application must be installed on your PC. It is available during the MPLAB X IDE installation process if the check box is selected (see Figure 1-1). You do not need to install the MPLAB X IDE in order to use the IPE application. However, you may want to refer to the online help for the MPLAB X IDE for additional information.

FIGURE 1-1: SELECT PROGRAMS DIALOG

Once you’ve installed the software, the IPE application can be accessed through the MPLAB IPE icon on your desktop or startup menu.
1.3 PROGRAMMING TOOLS SUPPORTED

The following programming tools work with the IPE:

- MPLAB ICD 4 In-Circuit Debugger – recommended for production programming
- MPLAB ICD 3 In-Circuit Debugger – recommended for production programming
- MPLAB PICKit™ 4 In-Circuit Debugger – recommended for production programming
- MPLAB PICKit™ 3 Debugger/Programmer – for development programming only
- MPLAB PM3 Programmer – recommended for production programming
- MPLAB REAL ICE™ Emulator – recommended for production programming
- Licensed PKOB Starter Kits – recommended for development programming only

1.4 IPE MODES

1.4.1 Modes

The IPE application operates in two modes:

- Production Mode – in which you can perform production programming operations. By default, the IPE is in Production Mode when it is launched. The Production Mode capabilities are set from the Advanced Mode menu discussed in Section 2.5.6 “Production” of this document.
- Advanced Mode – a feature-rich GUI interface in which you can view and change the settings for programming operations and set up a production user interface for use on the manufacturing floor. See Section 2.3 “Setting Up the Programmer” for information to enable Advanced Mode.

1.4.2 Feature Matrix

The following matrix shows the default features that are accessible in Production Mode. However, in Advanced Mode, the default behavior of Production Mode can be changed and features can be added or removed as per the authorized personnel’s discretion.

**TABLE 1-1: FEATURE MATRIX**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Production Defaults</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Hex file</td>
<td>Loads the Hex file</td>
<td>On</td>
</tr>
<tr>
<td>Import Environment</td>
<td>Loads the Environment file</td>
<td>Off</td>
</tr>
<tr>
<td>Import SQTP file</td>
<td>Loads the pre-built SQTP file</td>
<td>Off</td>
</tr>
<tr>
<td>Export Hex file</td>
<td>Saves the all memory contents into a hex file</td>
<td>Off</td>
</tr>
<tr>
<td>Program</td>
<td>Connects to hardware tool and performs program operation</td>
<td>On</td>
</tr>
<tr>
<td>Erase</td>
<td>Erases the device</td>
<td>On</td>
</tr>
<tr>
<td>Verify</td>
<td>Verifies the device against the memory contents of IPE</td>
<td>On</td>
</tr>
<tr>
<td>Blank Check</td>
<td>Checks that the device is blank</td>
<td>On</td>
</tr>
<tr>
<td>Read</td>
<td>Reads the device and fills the read content in memory</td>
<td>On</td>
</tr>
<tr>
<td><strong>Memory View</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Program Memory</td>
<td>Displays the program memory contents</td>
<td>Off</td>
</tr>
<tr>
<td>Auxiliary Memory</td>
<td>Displays the auxiliary memory contents</td>
<td>Off</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
<td>Production Defaults</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>Config Memory</td>
<td>Displays the configuration memory contents</td>
<td>Off</td>
</tr>
<tr>
<td>Flash Data</td>
<td>Displays the Flash data memory contents</td>
<td>Off</td>
</tr>
<tr>
<td>User IDs</td>
<td>Displays the User ID memory contents</td>
<td>Off</td>
</tr>
<tr>
<td>EEPROM</td>
<td>Displays the data memory contents</td>
<td>Off</td>
</tr>
<tr>
<td><strong>Memory Edit</strong></td>
<td><strong>Program Memory</strong></td>
<td>Program memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>Auxiliary Memory</strong></td>
<td>Auxiliary memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>Flash Data Memory</strong></td>
<td>Flash data memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>EEPROM</strong></td>
<td>Data memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>User IDs</strong></td>
<td>User ID memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>Boot Memory</strong></td>
<td>Boot memory contents can be edited</td>
</tr>
<tr>
<td></td>
<td><strong>Config Memory</strong></td>
<td>Configuration memory contents can be edited</td>
</tr>
<tr>
<td>Save Environment</td>
<td>Creates or overwrites the environment</td>
<td>Off</td>
</tr>
<tr>
<td>View Memory Settings</td>
<td>Views the memory ranges</td>
<td>Off</td>
</tr>
<tr>
<td>Edit Memory Settings</td>
<td>Changes the memory ranges</td>
<td>Off</td>
</tr>
<tr>
<td>View Voltage Settings</td>
<td>Views the voltage values</td>
<td>Off</td>
</tr>
<tr>
<td>Edit Voltage Settings</td>
<td>Changes the voltage values</td>
<td>Off</td>
</tr>
<tr>
<td>Create SQTP</td>
<td>Generates the SQTP file</td>
<td>Off</td>
</tr>
<tr>
<td>Manual Download Firmware</td>
<td>To select and download the firmware into the Hardware tool</td>
<td>On</td>
</tr>
<tr>
<td>Auto Download Firmware</td>
<td>When a tool is connected, the latest firmware (available in the system) will be downloaded</td>
<td>On</td>
</tr>
<tr>
<td>Erase All Before Program</td>
<td>Erases the device before programming</td>
<td>Off</td>
</tr>
</tbody>
</table>
Chapter 2. General Setup

2.1 INTRODUCTION

Getting started using the MPLAB® IPE is discussed.

- Launching the MPLAB IPE Application
- Setting Up the Programmer
- Advanced Mode Login
- Advanced Mode Settings

2.2 LAUNCHING THE MPLAB IPE APPLICATION

After installing the software, double-click the MPLAB IPE application icon located on the desktop. The MPLAB IPE main window opens. If you need to have multiple instances of the IPE available, refer to the MPLAB X IDE help. Open MPLAB X IDE, go to Help>Tool Help Contents>MPLAB X IDE Help and navigate to the “Before You Begin” section, then “Launch Multiple Instances of the IDE.” Follow the instructions and apply to the IPE.

FIGURE 2-1: MPLAB IPE MAIN WINDOW
2.3 SETTING UP THE PROGRAMMER

For programming devices, you can use any of the supported tools (see Section 1.3 “Programming Tools Supported”). Refer to the online help of the selected tool (e.g., MPLAB ICD 4, PICkit 4, etc.) for information on programming a device.

1. Using the Family drop-down menu, select the family of the device you wish to program, then use the Device drop-down menu to select the device. Or use the Device drop-down menu to directly select the device.

   **Note:** Selecting the Recently Used option from the Family menu lists the latest 10 devices used in the Device menu.

2. Click **Apply** to configure the IPE to the current device (e.g., Target Memory Views, checksum).

3. Connect the development tool to the PC and attach the appropriate target board, device and power. Refer to the tool’s online help for additional instructions and information on connecting to target boards, etc.

4. Use the Tool drop-down menu to select the tool you want to use. If more than one development tool is connected to the PC, select the one you wish to use.

   **FIGURE 2-2: SELECT TOOL**

5. Click the **Connect** button (next to the Tool name) to establish a connection between the IPE and the tool.
6. When the tool is connected, any messages or errors related to this tool will be displayed in the Output window, see Figure 2-3.

FIGURE 2-3: OUTPUT WINDOW

7. After the tool is successfully connected, proceed to Chapter 3. “MPLAB IPE Reference” to program the device with the IPE.
2.4 ADVANCED MODE LOGIN

2.4.1 Logging In

Typically, someone has been authorized to establish the settings that production will use for the device and tool. To input those settings, log into the Advanced mode.

Select Settings>Advanced Mode to open the Advanced Mode login dialog. The password is case sensitive. Type in the default password microchip and click the Login button.

FIGURE 2-4: ADVANCED MODE LOGIN

2.4.2 Changing the Password

To change the password after the initial log on, click the Change Password button. If you forget the new password, you must uninstall the IPE, delete the ipe.key file (located in the IPE install directory) to remove any settings made previously in IPE, then reinstall the IPE to begin with the default password microchip.

2.4.3 Staying Logged In

To start up the MPLAB IPE directly in Advanced mode without entering the password again, type the password, check the “Keep me logged in” check box (see Figure 2-4), then click the Login button. A new installation or first time usage will launch the MPLAB IPE in basic mode. Once the “Keep me logged in” check box is selected, subsequent launchings will open in Advanced mode.

To cancel the automatic Advanced mode login, click the Logout button (see Figure 2-5) on the Advanced Settings dialog.

FIGURE 2-5: CANCEL KEEP ME LOGGED IN
2.5  ADVANCED MODE SETTINGS

Advanced mode settings must be set by someone authorized to do so. Some settings that are selected in these dialogs will allow a production specialist to view and control certain commands from the IPE Menu bar, Settings menu.

2.5.1  Operate

After validating the password to log in to the Advanced Mode, the dialog opens in the Operate view. This display is similar to the main display, with the addition of option buttons located along the left side of the window. The dialog shows the device and tool that has been selected (see Section 2.3 “Setting Up the Programmer”).

FIGURE 2-6: ADVANCED MODE, OPERATE DIALOG
2.5.2 Power

The Power option is available only when a tool is connected. From the Advanced Mode dialog, click **Power** to display the available settings.

**TABLE 2-1: POWER SETTINGS**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Voltage options</strong></td>
<td>Voltage options will vary for different device families. All of the settings and parameters are similar to MPLAB X IDE.</td>
</tr>
<tr>
<td>VDD</td>
<td>This voltage is used by the programmer to verify memory. The value should be the maximum voltage for the designated circuit. The default is the device's maximum voltage value.</td>
</tr>
<tr>
<td>VPP</td>
<td>This is the voltage used to bring the device into a programming mode. Although this is dependent on the device's programming specification, it can be changed.</td>
</tr>
<tr>
<td>VDD Nom</td>
<td>The default value depends on the device. For example, PIC32 has 3.3V as default VDD Nom.</td>
</tr>
<tr>
<td>VDD APP</td>
<td>This is the voltage used by the programmer to verify Flash memory. The default is the device's nominal voltage value.</td>
</tr>
<tr>
<td>Reset Voltages</td>
<td>Returns voltages to their default settings.</td>
</tr>
<tr>
<td><strong>ICSP™ Options</strong></td>
<td></td>
</tr>
<tr>
<td>Use Low Voltage Program mode entry</td>
<td>The tool allows low voltage programming (LVP) with certain PICXXFXXX Flash devices. The Flash device selected must be capable of low voltage and programming must be performed in ICSP mode.</td>
</tr>
<tr>
<td>Power Target circuit from Tool</td>
<td>This setting enables the connected tool to power the target.</td>
</tr>
<tr>
<td>Use High Voltage Program mode entry</td>
<td>This setting enables high voltage to be used on a Master Clear Reset (MCLR).</td>
</tr>
</tbody>
</table>

2.5.3 Memory

From the Advanced Mode dialog, click **Memory** to display the available settings for the device and tool you selected. You can control the memory address and other parameters related to a programming operation. Some of the options in this window are also available on the main screen, for viewing and to provide easy access to these settings.

**Note:** The memory settings for the MPLAB PM3 Programmer may be different in versions of MPLAB IPE prior to v3.60.

**TABLE 2-2: MEMORY SETTINGS**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Tool to select memories and ranges</td>
<td>When the check box is selected, the programmer tool sets the memory types and ranges. If selected, the Program Memory fields are disabled.</td>
</tr>
<tr>
<td><strong>Manual Select</strong></td>
<td></td>
</tr>
<tr>
<td>Program Memory</td>
<td>Allows the tool to program the program memory.</td>
</tr>
<tr>
<td>Auxiliary Memory</td>
<td>Allows the tool to program the auxiliary memory.</td>
</tr>
<tr>
<td>Flash Data</td>
<td>Allows the tool to program the Flash data.</td>
</tr>
<tr>
<td>TABLE 2-2: MEMORY SETTINGS (CONTINUED)</td>
<td></td>
</tr>
<tr>
<td>---------------------------------------</td>
<td></td>
</tr>
<tr>
<td>EEPROM</td>
<td>Allows the tool to program the EEPROM.</td>
</tr>
<tr>
<td>User IDs</td>
<td>Allows the tool to program the User IDs.</td>
</tr>
<tr>
<td>Boot Flash</td>
<td>Allows the tool to program the Boot Flash.</td>
</tr>
<tr>
<td>Configuration Memory</td>
<td>Allows the tool to program the configuration memory.</td>
</tr>
</tbody>
</table>

**Program Memory Range** - define the address range to be used for programming the program memory.

| Enter Range: | The address range in Hex of the program space that will be programmed. |
| Reset        | Returns addresses to default settings. |

**Preserve Memory** - define the addresses to be preserved when programming memory.

| Preserve EEPROM on Program² | When the check box is selected, the device will not be programmed with any new data that is present in the memory (shown in the EEPROM window). The data in the EEPROM memory area on the device will not be erased. |
| Enter Range:               | The address range in Hex of the program space that will be preserved. |

| Preserve Flash on Program², ³ | When the check box is selected, the program memory range specified in the following Program Memory (Start and End Address) fields will not be programmed with any new data. |
| Enter Range:                 | The address range in Hex of the program space that will be preserved. |

| Preserve Auxiliary Memory     | When the check box is selected, the auxiliary memory will not be programmed with any new data that is present in the auxiliary memory. |
| Preserve ID Memory³           | When the check box is selected, the ID memory will not be programmed with any new data that is present in the ID memory. Only available if device has user ID memory. |

**Note 1:** The MPLAB PM3 programmer does not support the Preserve Memory options in the environment .pm3 files.

2: If you wish to use any of the Preserve Memory options, first ensure that your code is not code-protected. For memory to be preserved, the programmer reads the section it needs to save, performs a bulk erase of the device, reprograms the device and then rewrites the area that is preserved with what was saved. Therefore, this area cannot be code protected.

3: PIC32M devices do not support preserving User ID or Boot Memory.
2.5.4 Environment

Environments allow you to save settings, so that all of the same settings can be reloaded in another programming session. Environments are supported, under all tools, as either .pen files or .pm3 files.

Note: MPLAB PM3 programmer does not support the Preserve Memory options in the environment .pm3 files.

From the Advanced Mode dialog, click Environment to display the available settings.

<table>
<thead>
<tr>
<th>Create Environment Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting</td>
</tr>
<tr>
<td>Environment Information</td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>.pm3 file</td>
</tr>
<tr>
<td>.pen file</td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Misc Files</td>
</tr>
<tr>
<td>SQTP File</td>
</tr>
<tr>
<td>Save to PM3 Card</td>
</tr>
<tr>
<td>Save to PC</td>
</tr>
<tr>
<td>Copy</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Browse Environments Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse on:</td>
</tr>
<tr>
<td>PC</td>
</tr>
<tr>
<td>MPLAB PM3 Card</td>
</tr>
<tr>
<td>Environment Information</td>
</tr>
</tbody>
</table>
2.5.5 SQTP

SQTP (serial quick turn programming) is used to program a unique serial number into each device. This number can be used as an entry code, password or ID number. From the Advanced Mode dialog, click SQTP to display the available settings.

If using SQTP with MPLAB PM3, see Section 2.5.5.1 "Using SQTP with MPLAB PM3" for additional information. If using PIC32 devices, see Section 2.5.5.2 "Using SQTP with PIC32 Devices" for information on the import methods. For information about how the SQTP files are produced, refer to the SQTP File Format Specification (DS50002539).

**TABLE 2-4: SQTP SETTINGS**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Generation Method:</strong></td>
<td></td>
</tr>
<tr>
<td>Random</td>
<td>Select this option to generate unique, random numbers for each part. Also enter the start address, number of bytes and number of parts in the corresponding fields.</td>
</tr>
<tr>
<td>Pseudo-Random Seed Value (Hex):</td>
<td>Select this option to generate a pseudo-random set of non-repeating numbers based on the Hex value you enter into the Seed Value field. Also enter the start address, number of bytes and number of parts in the corresponding fields.</td>
</tr>
<tr>
<td>Sequential Start Value (Hex):</td>
<td>Select this option to generate sequential numbers based on the starting value specified and incrementing each number by the amount specified. Also enter the start address, number of bytes and number of parts in the corresponding fields.</td>
</tr>
<tr>
<td><strong>Configuration:</strong></td>
<td></td>
</tr>
<tr>
<td>Start Address (Hex)</td>
<td>Enter the starting address (in Hex) for the serial number.</td>
</tr>
<tr>
<td>Number of Bytes (Dec)</td>
<td>Enter the size of the serial number (in decimal). Make sure a large enough serial number is specified for the number of parts planned to program using this file.</td>
</tr>
<tr>
<td>Number of parts (Dec)</td>
<td>Enter the number of parts to be programmed using this file.</td>
</tr>
<tr>
<td><strong>Location:</strong></td>
<td></td>
</tr>
<tr>
<td>Program Memory</td>
<td>Select this option to load the SQTP number in program memory.</td>
</tr>
<tr>
<td>EEPROM</td>
<td>Select this option to load the SQTP number in EEPROM.</td>
</tr>
<tr>
<td>Auxiliary Memory</td>
<td>Select this option to load the SQTP number in auxiliary memory.</td>
</tr>
<tr>
<td>User ID Memory</td>
<td>Select this option to load the SQTP number in user ID memory.</td>
</tr>
<tr>
<td>Boot Memory</td>
<td>Select this option to load the SQTP number in boot memory.</td>
</tr>
<tr>
<td>Flash Data</td>
<td>Select this option to load the SQTP number in Flash memory.</td>
</tr>
<tr>
<td><strong>Access Method:</strong></td>
<td></td>
</tr>
<tr>
<td>RETLW</td>
<td>Select this option to use a series of RETLW (Return Literal W) instructions with the serial number bytes as the literal data.</td>
</tr>
<tr>
<td>Raw Data</td>
<td>Select this option to use the raw data.</td>
</tr>
<tr>
<td>Format for PSV</td>
<td>If the Raw Data option is selected, selecting Format for PSV formats SQTP data to make it compatible with PSV (Program Space Visibility).</td>
</tr>
<tr>
<td>Generate</td>
<td>Click Generate to create the SQTP (.num) file.</td>
</tr>
</tbody>
</table>
2.5.5.1 USING SQTP WITH MPLAB PM3

SQTP files for Flash Data memory that were generated prior to MPLAB IPE v2.20 will work with MPLAB PM3 firmware up to v3.00. SQTP file generation for Flash Data memory has been modified to the 32-bit byte order (12345678) and the firmware is updated accordingly. A new SQTP file must be regenerated to work with MPLAB IPE v3.00 and higher.

2.5.5.2 USING SQTP WITH PIC32 DEVICES

For PIC32 devices only, starting with MPLAB IPE v3.15, a dialog box, similar to the one below, is provided to choose either 32-bit byte order (12345678) or 16-bit byte order (56781234) when loading an SQTP file.

FIGURE 2-7: IMPORT SQTP FILE DIALOG
2.5.6 Production

From the Advanced Mode dialog, click **Production** to display the available settings.

The Production Settings dialog enables authorized personnel to select the options that are available during production programming. The options that are selected in the Production Settings determine which commands will be available under the File, View, and Settings menus in Production Mode.

Select the appropriate settings for your production programming project by checking or unchecking the settings. Selecting a check box in the Production Settings dialog causes a check mark to display in front of that option under the IPE Settings menu.

A check mark indicates that an option has been set in the Advanced Mode. If the item is available and has a check mark, then the production specialist can control this item by toggling it on or off.

**TABLE 2-5: PRODUCTION SETTINGS**

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Production Mode Settings</td>
<td></td>
</tr>
<tr>
<td>Allow Export Hex</td>
<td>This setting enables a production specialist to export Hex files. If this option is selected, it displays under the *File&gt;*Export menu.</td>
</tr>
<tr>
<td>Allow Import Hex file</td>
<td>Enables a production specialist to import Hex files. If this option is selected, it displays under the *File&gt;*Import menu. <strong>Note:</strong> If using a Hex file in the IPE and the file is modified using Notepad, MPLAB X IDE, etc., outside of the IPE, a message displays: “File modified. The loaded hex file has been modified externally. Would you like to reload hex file?”</td>
</tr>
<tr>
<td>Allow Import Environment</td>
<td>This setting enables a production specialist to import environments. If this option is selected, it displays under the *File&gt;*Import menu.</td>
</tr>
<tr>
<td>Allow Import SQTP file</td>
<td>This setting enables a production specialist to import SQTP files. If this option is selected, it displays under the *File&gt;*Import menu.</td>
</tr>
<tr>
<td>Generate Reports</td>
<td>This setting enables reports to be generated. If Generate Reports is checked, click <strong>Browse</strong> to set the location where the reports will be placed.</td>
</tr>
<tr>
<td>Limit the Program Count to</td>
<td>If selected, this option limits the pass, fail, and total counts to the value that is entered into the associated field. This actually halts further programming operations from occurring. To clear the counts on the main window, click <strong>Reset Counters</strong>.</td>
</tr>
<tr>
<td>Allow “Verify Device ID before Program” under Settings menu</td>
<td>This setting activates this option in the Settings menu and enables a production specialist to control this option. This setting is valid only for tools that are capable of performing this function, e.g., MPLAB PM3.</td>
</tr>
<tr>
<td>Allow “Auto Download Firmware” under Settings menu</td>
<td>If this option is selected, it displays in the Settings menu and can be controlled by a production specialist. If it is not selected, the IPE automatically downloads the latest firmware for the tool, if needed.</td>
</tr>
<tr>
<td>Allow “Erase All before Program” under Settings menu</td>
<td>If this option is selected, it displays in the Settings menu and can be controlled by a production specialist. If it is not selected, the production specialist cannot control this option from the Settings menu.</td>
</tr>
<tr>
<td>PRODUCTION SETTINGS (CONTINUED)</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Allow “Communication” under Settings menu</strong></td>
<td></td>
</tr>
<tr>
<td>If selected, this option is enabled (<a href="#">Section 3.7 “Help Menu”</a>) and can be controlled by a production specialist. If using the MPLAB PM3 programmer COM port (RS-232), you must select this option in order to set the appropriate COM port.</td>
<td></td>
</tr>
<tr>
<td><strong>Remove Read button from main window</strong></td>
<td></td>
</tr>
<tr>
<td>If this option is selected, the Read button is removed from the main window.</td>
<td></td>
</tr>
<tr>
<td><strong>Audible notification on successful program completion</strong></td>
<td></td>
</tr>
<tr>
<td>If selected, this option generates a sound when programming completes successfully.</td>
<td></td>
</tr>
<tr>
<td><strong>Allow memory editing and filling</strong></td>
<td></td>
</tr>
<tr>
<td>Enables memory editing and filling of Execution Memory, Configuration Bits, User ID Memory or Device ID Memory. If enabled, this option is accessed in Production Mode from the <strong>Window&gt;Target Memory Views</strong> option.</td>
<td></td>
</tr>
<tr>
<td><strong>Display EEPROM checksum in the output window</strong></td>
<td></td>
</tr>
<tr>
<td>If selected, the EEPROM checksum is displayed in the output window. EEPROM checksum is the checksum of the EEPROM Memory in the MCUs (PIC18F1220, for example) and not the memory from the exclusive devices such as 11AA/LCxxx, 24AA/LC/FCxxx.</td>
<td></td>
</tr>
<tr>
<td><strong>Display imported hex checksum with CP=OFF</strong></td>
<td></td>
</tr>
<tr>
<td>If selected, the non-code protected checksum is displayed in the Results area.</td>
<td></td>
</tr>
<tr>
<td><strong>Enable programming operations only if hex file is loaded</strong></td>
<td></td>
</tr>
<tr>
<td>a) If Hex file is not loaded: All the programming buttons (Program, Read, Erase, Verify, Blank Check) will be disabled.</td>
<td></td>
</tr>
<tr>
<td>b) If Hex file is loaded, all the programming buttons will be enabled.</td>
<td></td>
</tr>
</tbody>
</table>

**Allow Memory View**

<table>
<thead>
<tr>
<th>Program Memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>If this option is selected, program memory can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window.</td>
</tr>
<tr>
<td><strong>Auxiliary Memory</strong></td>
</tr>
<tr>
<td>If this option is selected, auxiliary memory can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window.</td>
</tr>
<tr>
<td><strong>User IDs</strong></td>
</tr>
<tr>
<td>If this option is selected, user IDs can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window. This is only applicable if user IDs are supported by the tool.</td>
</tr>
<tr>
<td><strong>Config Memory</strong></td>
</tr>
<tr>
<td>If this option is selected, configuration memory can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window.</td>
</tr>
<tr>
<td><strong>Flash Data</strong></td>
</tr>
<tr>
<td>If this option is selected, Flash memory can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window.</td>
</tr>
<tr>
<td><strong>EEPROM</strong></td>
</tr>
<tr>
<td>If this option is selected, EEPROM memory can be displayed in the <strong>Windows&gt;Target Memory Views</strong> on the main window.</td>
</tr>
</tbody>
</table>
2.5.7 Settings

From the Advanced Mode dialog, click **Settings** to display the available options. If you are connected to an MPLAB ICD 4 or PICkit 4 In-Circuit Debugger, there are additional options.

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PICkit 3 Programming Speed</td>
<td>The Programming Speed slider is enabled only if an enhanced mid-range device (PIC16F family) is connected. Use the slider to adjust the programming speed (see Figure 2-8). This option can be used to help troubleshoot problems by slowing the speed to allow sufficient time for signal levels. The PICkit 3 slider will slow down ICSP programming which may help communication problems created by heavy loading on the ICSP lines. It is suggested that these lines are clear of any components. The programming speed control may help to program boards that already have existing components on these lines.</td>
</tr>
<tr>
<td>PICkit 3 Programmer To Go</td>
<td>Opens the PICkit 3 <strong>Programmer To Go</strong> dialog (see Figure 2-9) showing the settings that will be applied the next time the Programmer-To-Go feature is used. Enter an Image Name that will be used for the image on the PICkit 3. Click <strong>Programmer To Go</strong> to activate. Refer to the PICkit 3 In-Circuit Debugger/Programmer User’s Guide, DS52116, for information on the Programmer-To-Go feature. This feature may not be supported on all devices. <strong>Note:</strong> Programmer To Go does not support the Preserve Memories options.</td>
</tr>
</tbody>
</table>

**Special Memory Regions**

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program Calibration Memory</td>
<td>Enables programming of registers used to hold calibration values for a device.</td>
</tr>
<tr>
<td>Program/Read User OTP</td>
<td>Enables programming or reading of a serial user ID that is OTP (one time programmable). Once programmed, it cannot be changed.</td>
</tr>
</tbody>
</table>

**Secure Segments**

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segments to Program</td>
<td>Available only for devices with CodeGuard, e.g., dsPIC33FJ12GP202, etc. Supported by REAL ICE, MPLAB ICD 3 and PICkit 3. Select the segments to program: • Full Chip Programming • Boot, Secure and General Segments • Secure and General Segments • General Segment Only</td>
</tr>
</tbody>
</table>

**SQTP**

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable operations if SQTP values are exhausted</td>
<td>Selecting the check box prohibits further programming if all SQTP values from the specified .num file have been exhausted.</td>
</tr>
<tr>
<td>Display the next SQTP sequence in the output window</td>
<td>Select this check box to display the next SQTP sequence in the output window.</td>
</tr>
</tbody>
</table>

**Programming Method**

This option allows you to choose the Test mode entry method for devices. This feature is supported by the tools which can power the target (except for PM3). This setting refers to the order in which the VPP and VDD voltages will be applied when programming/reading the target device.
### FIGURE 2-8: PICkit 3 PROGRAMMING SPEED OPTION

![PICkit 3 Programming Speed](image)

### TABLE 2-6: GENERAL SETTINGS (CONTINUED)

<table>
<thead>
<tr>
<th>Settings</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply VPP before VDD (Recommended)</td>
<td>This is the default setting.</td>
</tr>
<tr>
<td>Apply VDD before VPP</td>
<td>Caution is recommended when using this setting as it may have adverse side effects. This option is available only when powering the device from the debug tool.</td>
</tr>
</tbody>
</table>

### Diagnostics

<table>
<thead>
<tr>
<th>Logging Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFF: No logging</td>
<td>Set the message logging level.</td>
</tr>
<tr>
<td>SEVERE: Log severe (error) messages only.</td>
<td></td>
</tr>
<tr>
<td>WARNING: Log warning messages only.</td>
<td></td>
</tr>
<tr>
<td>INFO: Log informational messages only.</td>
<td></td>
</tr>
<tr>
<td>CONFIG: Log configuration information only.</td>
<td></td>
</tr>
<tr>
<td>FINE: Log some module-to-module communication.</td>
<td></td>
</tr>
<tr>
<td>FINER: Log more module-to-module communication.</td>
<td></td>
</tr>
<tr>
<td>FINEST: Log all module-to-module communication.</td>
<td></td>
</tr>
</tbody>
</table>

| Log File                       | Path and name of log file.                                                  |

### ICD 4/PicKit 4

<table>
<thead>
<tr>
<th>LED Brightness setting</th>
<th>Select the level of brightness from 1 (darkest) to 10 (brightest); the default is 5.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program Speed</td>
<td>Select either Low, Normal or High; the default is Normal.</td>
</tr>
<tr>
<td>PGC Configuration</td>
<td>Select either none, pull up or pull down. The default is pull down.</td>
</tr>
<tr>
<td>PGC resistor value (Kohms)</td>
<td>Type in a resistor value from 0-50. The default value is 4.7 Kohms.</td>
</tr>
<tr>
<td>PGD Configuration</td>
<td>Select either none, pull up or pull down. The default is pull down.</td>
</tr>
<tr>
<td>PGD resistor value (Kohms)</td>
<td>Type in a resistor value from 0-50. The default value is 4.7 Kohms.</td>
</tr>
</tbody>
</table>
2.5.8 Logout

After the settings are selected, click **Logout** to save your settings, exit the Advanced Mode, and return to the main window.
3.1 IPE MAIN WINDOW

The following figure shows the main window of the IPE. The IPE Menu bar contains the following menus, with commands:

- File Menu
- Settings Menu
- View Menu
- Tools Menu
- Window Menu
- Help Menu

Commands are available or not depending on the settings selected in Advanced Mode.

FIGURE 3-1: IPE MAIN WINDOW
### TABLE 3-1: IPE MAIN WINDOW FIELDS

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Device and Tool</strong></td>
<td></td>
</tr>
<tr>
<td>• Family</td>
<td>Filters devices by family or recently used.</td>
</tr>
<tr>
<td>• Device</td>
<td>Specifies the device; click <strong>Apply</strong> to select.</td>
</tr>
<tr>
<td>• Tool</td>
<td>Specifies the tool; click <strong>Connect</strong> or <strong>Disconnect</strong> as appropriate.</td>
</tr>
<tr>
<td><strong>Results</strong></td>
<td></td>
</tr>
<tr>
<td>• CP=OFF Checksum</td>
<td>Displays only if enabled in Advanced Mode. The imported hex checksum is</td>
</tr>
<tr>
<td></td>
<td>handled as if code protect is off for the device with current memory</td>
</tr>
<tr>
<td></td>
<td>contents; value can be copied using CTRL+C.</td>
</tr>
<tr>
<td>• Checksum</td>
<td>Checksum value for the device with current memory contents; value can be</td>
</tr>
<tr>
<td></td>
<td>copied using CTRL+C.</td>
</tr>
<tr>
<td>• Pass Count</td>
<td>Details the number of programming operations that passed.</td>
</tr>
<tr>
<td>• Fail Count</td>
<td>Details the number of programming operations that failed.</td>
</tr>
<tr>
<td>• Total Count</td>
<td>The total number of programming operations.</td>
</tr>
<tr>
<td><strong>Command Buttons:</strong></td>
<td></td>
</tr>
<tr>
<td>• Program</td>
<td>Programs the device.</td>
</tr>
<tr>
<td>• Erase</td>
<td>Erases the device.</td>
</tr>
<tr>
<td>• Read</td>
<td>Reads the device.</td>
</tr>
<tr>
<td>• Verify</td>
<td>Performs a verify operation on the device.</td>
</tr>
<tr>
<td>• Blank Check</td>
<td>Checks whether the device is blank.</td>
</tr>
<tr>
<td><strong>Other</strong></td>
<td></td>
</tr>
<tr>
<td>Hex File</td>
<td>The Hex file location, <strong>Browse</strong> to locate the file.</td>
</tr>
<tr>
<td>SQTP</td>
<td>The SQTP file location, <strong>Browse</strong> to locate the file.</td>
</tr>
<tr>
<td>Output Tab</td>
<td>Display of output data. Right-click in the Output window to access</td>
</tr>
<tr>
<td></td>
<td>additional options.</td>
</tr>
<tr>
<td>Tool Tab</td>
<td>Display of specific tool data, i.e., PM3, ICD 4, PICkit 4.</td>
</tr>
</tbody>
</table>
3.2 FILE MENU

On the IPE Menu bar, the File menu provides three commands:

- Import
- Export
- Exit

3.2.1 File>Import

The Import menu item allows you to import files into the IPE.

File->Import->Hex – select to import the hexadecimal file (*.hex).

File->Import->Environment – select to import (load) the environment (*.pen or .pm3 file).

File->Import->SQTP – select to load the SQTP file (*.num file).

3.2.2 File>Export

The Export menu item allows you to export data from IPE to storage media. By default, these commands are not available in Production Mode. However, in Advanced Mode, an authorized user can change the default states of this feature for the Production Mode.

File->Export->Hex – this command allows you to export all the memory contents into Intel® Hex file format.

3.2.3 File>Exit

This command closes the IPE application.

Note: If using a Hex file in the IPE and the file is modified using Notepad, MPLAB X IDE, etc., outside the IPE, the following message displays:
3.3 SETTINGS MENU

3.3.1 Understanding the Settings Menu Commands

The Settings menu on the IPE Menu bar (see Table 3-2) contains commands available for production personnel. Many of these commands are made available through the Advanced Mode, Production Mode dialog.

Menu commands are shown as active (black) or unavailable (grayed out).

Active commands with a check mark indicate that the production personnel can control these settings.

Active commands without a check mark indicate that only authorized personnel can access them.

Unavailable commands with or without a check mark indicate that production personnel cannot control these settings.

TABLE 3-2: SETTINGS MENU COMMANDS

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Mode</td>
<td>This command opens the Advanced Mode login dialog. Once the login is validated, additional settings can be set by authorized personnel. Refer to “Setting Up the Programmer” and “Advanced Mode Settings” for more information.</td>
</tr>
<tr>
<td>Verify Device ID Before Program</td>
<td>This command is only appropriate when using devices that have device IDs.</td>
</tr>
<tr>
<td>Erase All Before Program</td>
<td>This command is used to control whether or not the contents of the device will be erased before it is programmed. It is not applicable to One-Time-Programmable (OTP). When the command is enabled (check box is selected), the device is erased before it is programmed. If it is disabled (unchecked), the device will not be erased before it is programmed.</td>
</tr>
<tr>
<td>Auto Download Firmware*</td>
<td>If this command is selected, the application verifies that the firmware is the latest available; and if needed, downloads the newer firmware automatically.</td>
</tr>
</tbody>
</table>
| Manual Download Firmware*| This command enables manual download of firmware. The Firmware Browser dialog opens and locates directory containing the latest PM3.jar firmware file.  
  click on the Firmware File, then click the OK button to download the firmware. |
| Save Firmware into SD Card | This command downloads the operating system firmware into an SD Card that has been inserted into the MPLAB PM3 programmer (see Section 3.3.2 “Save Firmware into PM3 SD Card”). |
| Hold on Reset            | This command prevents the code from running after programming.                                                                                   |
| Release from Reset       | This command removes the Reset and allows the code to run.                                                                                      |
| PM3 Communication        | This command is only used with the MPLAB PM3 programmer. This command opens the PM3 Communication Setting dialog. Use this dialog to set communications for COM or USB ports. See Section 3.3.3 “PM3 Communication Setting Dialog” for more information. |

* The download of firmware will not occur until the connect/disconnect button is clicked or a programming operation is performed.
3.3.2  Save Firmware into PM3 SD Card

In production houses, there may be a need to program several different device family architectures without having access to a computer.

Between MPLAB IPE v3.25 and v3.40, the PM3 operating system was split into two parts based on the device architecture (32-bit vs all other devices). In MPLAB IPE v3.40, the PM3 operating system and database are split into three parts based on the architectures for 8-, 16- and 32-bit devices.

MPLAB IPE v3.40 or greater enables you to save the three PM3 operating system firmwares supporting each of the device family architectures into a PM3 SD card.

Once all the PM3 operating system firmwares are downloaded, when a PM3 environment is selected in Stand-Alone mode, the MPLAB PM3 programmer will load the correct operating system and database for the device from the PM3 SD card.

This feature is available only in the MPLAB IPE v3.40 or greater, not in the MPLAB X IDE.

To save all three operating systems into the PM3 SD card:
1. Insert any supported SD card into PM3 SD card slot.
2. Open MPLAB IPE v3.40 or greater and connect the MPLAB PM3 programmer to the computer.
3. Select Settings>Save firmware into SD Card. The output window in the MPLAB IPE displays messages when the operating systems and databases for the 8-bit, 16-bit and 32-bit MCUs are successfully saved onto the SD card.

Points To Be Considered

• Please ensure the PM3 operating system firmware version, stored on the SD card, matches the operating system firmware version on the MPLAB PM3 programmer. A mismatch may occur if an upgrade of the PM3 operating system was performed but the SD card firmware was not updated. Use the MPLAB IPE v3.40 or greater to select the Settings>Save firmware into SD Card option to load the PM3 SD card with the desired PM3 operating system firmware version.

• Any firmware versions of v3.40 or greater are not compatible with earlier versions of MPLAB IPE. It is highly recommended that the MPLAB PM3 use the firmware packaged within the same MPLAB IPE version.

<table>
<thead>
<tr>
<th>Version</th>
<th>Support</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prior to MPLAB IPE v3.25</td>
<td>One operating system supported.</td>
</tr>
<tr>
<td>MPLAB IPE v3.25-3.35</td>
<td>Two operating systems supported (32-bit and all other devices).</td>
</tr>
<tr>
<td>MPLAB IPE v3.40 or greater</td>
<td>Three operating systems supported (8-, 16-, 32-bit devices).</td>
</tr>
</tbody>
</table>
### 3.3.3 PM3 Communication Setting Dialog

The PM3 Communication Setting dialog is available under the IPE Menu bar, Settings menu only when the associated check box for Allow “Communication” under Settings menu is selected in the Advanced Mode, Production Mode dialog.

The MPLAB PM3 must be connected to the PC, using the appropriate cable, prior to using the PM3 Communication Setting dialog.

This dialog enables selecting the communication port for the MPLAB PM3 programmer through the IPE.

To use the RS-232 port on the MPLAB PM3, select the **COM Port** option and use the drop list to select the available port. Click the refresh button if necessary to view available ports. Click the **Test** button to check communication between the IPE and the MPLAB PM3.

To use USB for the communication port, select the **USB Port** option.

### Setting up the COM Port Manually

On some systems, you may need to set up the communications port manually.

On Windows, from the **Start** menu, select **Control Panel**, then **System and Security**. Under the **System** settings, click **Device Manager**. Expand the Ports drop-down list and double-click on the port you are trying to use. Click the **Port Settings** tab and select the following:

- **Bits per second**: 57600 (baud rate)
- **Data bits**: 8
- **Parity**: None
- **Stop bits**: 1
- **Flow control**: Hardware

Click **Advanced**. Uncheck the Use FIFO buffers check box.

Reboot the PC to implement the change.

### 3.4 VIEW MENU

The viewable memory types are determined by the Production settings that are selected in the Advanced Mode. The View menu commands are described below:

- **Clear All Memory**
- **Memory Settings**
- **Power Settings**
- **Transfer from PM3**
- **Transfer to PM3**
- **Read Device ID**
- **View PM3 Socket Info**

#### 3.4.1 Clear All Memory

Clears all of the memory views.

#### 3.4.2 Memory Settings

Displays the current memory settings (see Figure 3-2 for an example). The Memory Settings are view-only and cannot be changed from this window.
3.4.3 Power Settings
Displays the current power settings (see example in Figure 3-3).

3.4.4 Transfer from PM3
When selected, this option transfers the image from the connected MPLAB PM3 Programmer. The status displays in the Output window.

3.4.5 Transfer to PM3
When selected, this option transfers the image to the connected MPLAB PM3 Programmer. The status displays in the Output window.

3.4.6 Read Device ID
Displays the device ID of the selected device in the Output window.

3.4.7 View PM3 Socket Info
Displays the PM3 socket information in the Output window.
3.5 TOOLS MENU

The Tools menu provides access to Plugins. Select Plugins to display the Plugins Manager. For details, see the NetBeans help topic: Managing Plugins in the IDE. If MPLAB X IDE is installed, see the MPLAB X IDE Help file, Additional Tasks, Add PlugIn Tools.

3.6 WINDOW MENU

3.6.1 Output

This option opens the Output window at the bottom of the display. Right-click the tab title to display window options, such as Close, Float, Move, etc. Right-click in the body of the window to display Output window content options, such as Find, Wrap text, etc. (see Figure below).

FIGURE 3-4: OUTPUT WINDOW RIGHT-CLICK MENUS

3.6.2 Target Memory Views

This option is available only if Production Settings are set in Advanced Mode to view the different types of memory. Some of the possible memory views include Execution Memory, Configuration Bits, User ID Memory, Device ID Memory, etc.

3.6.3 Reset Windows

Selecting this option will reset all the program windows to the default settings.

3.7 HELP MENU

The Help menu provides access to the following online information:
- Read Me Docs - MPLAB IPE Readme and Programmer Command-line Readme.
- Help Contents - displays the master set of all installed documentation.
- Tool Help Contents - lists help for several Microchip tools.
- About - displays information specific to the current version of MPLAB IPE.
Appendix A. Revision History

Revision A (December 2013)
This is the initial release of this document.

Revision B (August 2015)
Modified Section 1.2 “Software Installation Requirements”. The IPE is now a separate installation than the MPLAB X IDE.
Modified the description of Production Mode.
In Chapter 2. “General Setup”:
• Added information on new features: Recently Used option in the Family list of devices and Creating Desktop Shortcuts.
• Added information on Preserve Memory options.
• Added notes regarding MPLAB PM3 programmer environment files.
• Added a note in the description of the Allow Import Hex file option in Table 2-5.
• Added information regarding using the MPLAB PM3 programmer with the option Allow “Communication” under Settings menu in Table 2-5.
• Added Special Memory Regions information to Table 2-6.
In Chapter 3. “MPLAB IPE Reference”:
• Added a note regarding the File>Import>Hex option.

Revision C (March 2017)
• Added Note with location of Readme file for MPLAB IPE in Section 1.2 “Software Installation Requirements”.
• Added Section 2.4.3 “Staying Logged In”.
• Updated memory range descriptions in Table 2-2.
• Updated environment settings options in Table 2-3.
• Revised Section 2.5.5 “SQTP” and added sections for using SQTP with MPLAB PM3 and with PIC32 devices.
• Added new SQTP setting in Table 2-6.
• Updated Table 3-1 to add more field descriptions to the main IPE window.
• Added new Read Device ID option to the View menu in Section 3.4 “View Menu”.
• Added new settings menu command in Table 3-2 for saving firmware into SD card and added a revised Section 3.3.2 “Save Firmware into PM3 SD Card”.

Revision D (June 2018)
• In the Preface, added compatibility note that this document reflects the changes as of MPLAB X IDE v4.20 or greater.
• Multiple updates throughout to reflect changes made to the program for the NetBeans platform. Added Tools and Windows menus, updated graphics, text, and menu options.
Support

INTRODUCTION

Please refer to the items discussed here for support issues.

- Warranty Registration
- The Microchip Web Site
- myMicrochip Personalized Notification Service
- Customer Support

WARRANTY REGISTRATION

If your development tool package includes a Warranty Registration Card, please complete the card and mail it in promptly. Sending in your Warranty Registration Card entitles you to receive new product updates. Interim software releases are available at the Microchip web site.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at http://www.microchip.com. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip consultant program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

myMICROCHIP PERSONALIZED NOTIFICATION SERVICE

Microchip’s personal notification service helps keep customers current on their Microchip products of interest. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool.

Please visit http://www.microchip.com/pcn to begin the registration process and select your preferences to receive personalized notifications. A FAQ and registration details are available on the page, which can be opened by selecting the link above.
When you are selecting your preferences, choosing “Development Systems” will populate the list with available development tools. The main categories of tools are listed below:

- **Compilers** – The latest information on Microchip C compilers, assemblers, linkers and other language tools. These include all MPLAB C compilers; all MPLAB assemblers (including MPASM™ assembler); all MPLAB linkers (including MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object librarian).

- **Emulators** – The latest information on Microchip in-circuit emulators. These include the MPLAB REAL ICE in-circuit emulators.

- **In-Circuit Debuggers** – The latest information on Microchip in-circuit debuggers. These include the MPLAB ICD 3 and MPLAB ICD 4 in-circuit debuggers and PICkit™ 3 and MPLAB PICkit 4 in-circuit debuggers.

- **MPLAB® X IDE** – The latest information on Microchip MPLAB X IDE, the multi-platform (Windows®, macOS™, Linux®) Integrated Development Environment for development systems tools.

- **Programmers** – The latest information on Microchip programmers. These include the device (production) programmers MPLAB REAL ICE in-circuit emulator, MPLAB ICD 4 in-circuit debugger, MPLAB PICkit 4 in-circuit debugger, MPLAB PM3 and development (non-production) programmer and PICkit 3.

- **Starter/Demo Boards** – These include MPLAB Starter Kit boards, PICDEM demo boards, and various other evaluation boards.

**CUSTOMER SUPPORT**

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Field Application Engineer (FAE)
- Technical Support

Customers should contact their distributor, representative or field application engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document. See our web site for a complete, up-to-date listing of sales offices.

Technical support is available through the web site at [http://support.microchip.com](http://support.microchip.com).

Documentation errors or comments may be emailed to docerrors@microchip.com.
## Index

### A
- Access Method ................................................. 21
- Advanced Mode ................................................. 16, 17, 32
- Allow "Auto Download Firmware"......................... 23
- Allow "Communication" ....................................... 24
- Allow "Erase All before Program"............................ 23
- Allow "Verify Device ID before Program" .................. 23
- Allow Export Hex ................................................. 23
- Allow Import Environment .................................... 23
- Allow Import Hex File ......................................... 23
- Allow Import SQTP File ....................................... 23
- Allow Memory Editing and Filling ......................... 24
- Allow Memory View ............................................. 24
- Apply Vdd Before Vpp .......................................... 26
- Apply Vpp Before Vdd .......................................... 26
- Audible Notification ........................................... 24
- Auto Download Firmware ...................................... 11, 32
- Auxiliary Memory .............................................. 10

### B
- Blank Check ...................................................... 10
- Browse Environments Tab ..................................... 20

### C
- Change Password ................................................ 16
- Change the Password ......................................... 16
- Clear All Memory ............................................... 34
- COM Port  
    - Manual Settings ............................................ 34
- Config Memory .................................................. 11
- Configuration .................................................... 21
- Create Environment Tab ...................................... 20
- Create SQTP .................................................... 11
- Customer Support ............................................. 40

### D
- Default Password ............................................... 16
- Diagnostics ....................................................... 26
- Disable Operations ............................................ 25
- Display EEPROM checksum in output window .......... 24
- Display hex checksum with CP=OFF ....................... 24
- Display SQTP sequence ....................................... 25
- Documentation  
    - Layout ....................................................... 5

### E
- Edit Memory Settings ......................................... 11
- Edit Voltage Settings ........................................ 11
- EEPROM .......................................................... 11
- Enable programming if hex file loaded .................. 24
- Environment .................................................... 20
- Environment Settings ........................................ 20

### F
- Erase .............................................................. 10
- Erase All Before Program .................................. 11, 32
- Exit .................................................................... 31
- Export ............................................................. 31
- Export Hex File ................................................ 10

### G
- General Settings  
    - Apply Vdd Before Vpp ....................................... 26
    - Apply Vpp Before Vdd ....................................... 26
    - Diagnostics .................................................... 26
    - Disable Operations ......................................... 25
    - Display SQTP sequence .................................... 25
    - ICD 4 ............................................................ 26
    - Log File ....................................................... 26
    - Logging Level ................................................ 26
    - PICKit 3 Programmer To Go ............................... 25
    - PICKit 3 Programming Speed .............................. 25
    - PICKit 4 ........................................................ 26
    - Program Calibration Memory .............................. 25
    - Program User OTP .......................................... 25
    - Programming Method ...................................... 25
    - Secure Segments ............................................ 25
    - Segments to Program ...................................... 25
    - Special Memory Regions ................................... 25
    - SQTP ............................................................ 25
    - Generate ....................................................... 21
    - Generate Reports .......................................... 23
    - Generation Method ........................................ 21

### H
- Header Board  
    - Specification ............................................... 7
    - Hold on Reset ................................................ 32

### I
- ICD 4 .............................................................. 26
- Import ............................................................. 31
- Import Environment .......................................... 10
- Import Hex File ................................................ 10
- Import SQTP File .............................................. 10
- Internet Address, Microchip ................................. 39
<table>
<thead>
<tr>
<th>Index</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transfer from PM3</td>
<td>35</td>
</tr>
<tr>
<td>Transfer to PM3</td>
<td>35</td>
</tr>
<tr>
<td>Transition Socket</td>
<td></td>
</tr>
<tr>
<td>Specification</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>U</td>
<td></td>
</tr>
<tr>
<td>User IDs</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>V</td>
<td></td>
</tr>
<tr>
<td>Verify</td>
<td>10</td>
</tr>
<tr>
<td>Verify Device ID Before Program</td>
<td>32</td>
</tr>
<tr>
<td>View Memory Settings</td>
<td>11</td>
</tr>
<tr>
<td>View Menu</td>
<td>34</td>
</tr>
<tr>
<td>Clear All Memory</td>
<td>34</td>
</tr>
<tr>
<td>Memory Settings</td>
<td>34</td>
</tr>
<tr>
<td>PM3 Socket Info</td>
<td>35</td>
</tr>
<tr>
<td>Power Settings</td>
<td>35</td>
</tr>
<tr>
<td>Read Device ID</td>
<td>35</td>
</tr>
<tr>
<td>Transfer from PM3</td>
<td>35</td>
</tr>
<tr>
<td>Transfer to PM3</td>
<td>35</td>
</tr>
<tr>
<td>View Voltage Settings</td>
<td>11</td>
</tr>
<tr>
<td>W</td>
<td></td>
</tr>
<tr>
<td>Web Site, Microchip</td>
<td>39</td>
</tr>
<tr>
<td>Window Menu</td>
<td>36</td>
</tr>
<tr>
<td>Output</td>
<td>36</td>
</tr>
<tr>
<td>Reset Windows</td>
<td>36</td>
</tr>
</tbody>
</table>
Worldwide Sales and Service

AMERICAS
Corporate Office
2355 West Chandler Blvd.
Chandler, AZ 85224-6199
Tel: 480-792-7200
Fax: 480-792-7277
Technical Support:
http://www.microchip.com/support
Web Address:
www.microchip.com

Atlanta
Duluth, GA
Tel: 678-957-9614
Fax: 678-957-1455

Austin, TX
Tel: 512-257-3370

Boston
Westborough, MA
Tel: 774-760-0087
Fax: 774-760-0088

Chicago
Itasca, IL
Tel: 630-285-0071
Fax: 630-285-0075

Dallas
Addison, TX
Tel: 972-818-7423
Fax: 972-818-2924

Detroit
Novi, MI
Tel: 248-848-4000

Houston, TX
Tel: 281-894-5983

Indianapolis
Noblesville, IN
Tel: 317-773-8323
Fax: 317-773-5453
Tel: 317-536-2380

Los Angeles
Mission Viejo, CA
Tel: 949-462-9523
Fax: 949-462-9608
Tel: 951-273-7800

Raleigh, NC
Tel: 919-844-7510

New York, NY
Tel: 631-435-6000

San Jose, CA
Tel: 408-735-9110
Tel: 408-436-4270

Canada - Toronto
Tel: 905-695-1980
Fax: 905-695-2078

ASIA/PACIFIC

Asia Pacific Office
Suites 3707-14, 37th Floor
Tower 6, The Gateway
Harbour City, Kowloon

Hong Kong
Tel: 852-2943-5100
Fax: 852-2401-3431

Australia - Sydney
Tel: 61-2-9868-6733
Fax: 61-2-9868-6755

China - Beijing
Tel: 86-10-8569-7000
Fax: 86-10-8528-2104

China - Chengdu
Tel: 86-28-8665-5111
Fax: 86-28-8665-7889

China - Chongqing
Tel: 86-23-8960-9588
Fax: 86-23-8980-9500

China - Dongguan
Tel: 86-769-8702-9880

China - Guangzhou
Tel: 86-20-8755-8029

China - Hangzhou
Tel: 86-571-8792-8115
Fax: 86-571-8792-8116

China - Hong Kong SAR
Tel: 852-2943-5100
Fax: 852-2401-3431

China - Nanjing
Tel: 86-25-8473-2460
Fax: 86-25-8473-2470

China - Qingdao
Tel: 86-532-8502-7355
Fax: 86-532-8502-7205

China - Shanghai
Tel: 86-21-3326-8000
Fax: 86-21-3326-8021

China - Shenyang
Tel: 86-24-2334-2829
Fax: 86-24-2334-2393

China - Shenzhen
Tel: 86-755-8664-2200
Fax: 86-755-8203-1760

China - Wuhan
Tel: 86-27-5980-5300
Fax: 86-27-5980-5118

China - Xian
Tel: 86-29-8833-7252
Fax: 86-29-8833-7256

ASIA/PACIFIC

China - Xiamen
Tel: 86-592-2388138
Fax: 86-592-2388130

China - Zhuhai
Tel: 86-756-3210040
Fax: 86-756-3210049

India - Bangalore
Tel: 91-80-3090-4444
Fax: 91-80-3090-4123

India - New Delhi
Tel: 91-11-4160-8631
Fax: 91-11-4160-8632

India - Pune
Tel: 91-20-3019-1500

Japan - Osaka
Tel: 81-6-6152-7160
Fax: 81-6-6152-9310

Japan - Tokyo
Tel: 81-3-6880-3770
Fax: 81-3-6880-3771

Korea - Daegu
Tel: 82-53-447-4301
Fax: 82-53-447-4302

Korea - Seoul
Tel: 82-2-554-7200
Fax: 82-2-558-5932 or 82-2-558-5934

Malaysia - Kuala Lumpur
Tel: 60-3-6201-9857
Fax: 60-3-6201-9859

Malaysia - Penang
Tel: 60-4-227-8870
Fax: 60-4-227-4068

Philippines - Manila
Tel: 63-2-634-9065
Fax: 63-2-634-9069

Singapore
Tel: 65-6334-8870
Fax: 65-6334-8850

Taiwan - Hsin Chu
Tel: 886-3-5778-366
Fax: 886-3-5770-955

Taiwan - Kaohsiung
Tel: 886-7-213-7830

Taiwan - Taipei
Tel: 886-2-2508-8600
Fax: 886-2-2508-0102

Thailand - Bangkok
Tel: 66-2-694-1351
Fax: 66-2-694-1350

EUROPE

Austria - Wels
Tel: 43-7242-2244-39
Fax: 43-7242-2244-393

Denmark - Copenhagen
Tel: 45-4450-2828
Fax: 45-4485-2829

Finland - Espoo
Tel: 358-9-4520-820
Fax: 358-9-4520-819

France - Paris
Tel: 33-1-69-53-63-20
Fax: 33-1-69-30-90-79

France - Saint Cloud
Tel: 33-1-30-60-70-00

Germany - Garching
Tel: 49-8931-9700

Germany - Haan
Tel: 49-2129-3766400

Germany - Heilbronn
Tel: 49-7131-67-3636

Germany - Karlsruhe
Tel: 49-721-625370

Germany - Munich
Tel: 49-89-627-144-0
Fax: 49-89-627-144-44

Germany - Rosenheim
Tel: 49-8031-354-560

Israel - R'anaana
Tel: 972-9-744-7705

Italy - Milan
Tel: 39-0331-742611
Fax: 39-0331-466781

Italy - Padova
Tel: 39-049-7625286

Netherlands - Drenen
Tel: 31-416-690399
Fax: 31-416-690340

Norway - Trondheim
Tel: 47-7289-7561

Poland - Warsaw
Tel: 48-22-3325737

Romania - Bucharest
Tel: 40-21-407-87-50

Spain - Madrid
Tel: 34-91-708-08-90
Fax: 34-91-708-08-91

Sweden - Gothenberg
Tel: 46-31-704-60-40

Sweden - Stockholm
Tel: 46-8-5090-4654

UK - Wokingham
Tel: 44-118-921-5800
Fax: 44-118-921-5820