Creating a "Hello World" Application on SAM Microcontrollers Using MPLAB Harmony v3 with MPLAB Harmony Configurator (MHC)

Introduction

MPLAB® Harmony v3 is a software development framework consisting of compatible and interoperable modules that include peripheral libraries (PLIBs), drivers, system services, middleware and third-party libraries. The MPLAB Harmony Configurator (MHC) is a GUI-based tool that provides an easy way to enable and configure various MPLAB Harmony modules. The MHC is a plug-in to the MPLAB X Integrated Development Environment (IDE).

This document explains how to create a simple application on an Arm® Cortex®-based SAM Microcontroller (MCU) using the MHC with MPLAB Harmony v3 modules. This application sends a “Hello World!” string to a console running on a computer. For this demonstration, the following MPLAB Harmony v3 modules are used and configured using the MHC:

- Clock PLIB using the Clock Manager to configure the microcontroller clock.
- PORT PLIB using the Pin Manager to configure the microcontroller I/Os.
- Serial Communication (SERCOM) USART PLIB to configure USART peripheral as serial port.
Table of Contents

Introduction.....................................................................................................................................................1
1. Creating “Hello World” Application.......................................................................................................... 3
2. Resources............................................................................................................................................. 18
3. Revision History.................................................................................................................................... 19
The Microchip Website.................................................................................................................................20
Product Change Notification Service............................................................................................................20
Customer Support........................................................................................................................................ 20
Microchip Devices Code Protection Feature.................................................................................................20
Legal Notice................................................................................................................................................. 20
Trademarks.................................................................................................................................................. 21
Quality Management System..........................................................................................................................21
Worldwide Sales and Service.........................................................................................................................22
1. Creating “Hello World” Application

This document describes how to create a "Hello World" application on SAM devices using the MPLAB Harmony v3 MHC tool. It also covers the process that involves few steps as shown below. The following software and hardware tools are used for this demonstration:

- MPLAB X IDE v5.25
- MHC v3 MPLAB Plug-in v3.3.0.1
- XC32 v2.20
- MPLAB Harmony v3 repositories:
  - csp v3.4.0
  - mhc v3.3.1
  - dev Packs v3.4.0
- SAMD21 Xplained Pro board

Note: Updated versions of the above listed tools can also be used to create the applications, users are not restricted to use the older versions.

Step 1: To create an MPLAB Harmony v3-based project, follow these steps:

1. Launch MPLAB X IDE.
2. In MPLAB X IDE, select File > New Project (or click the New Project icon).
3. In the New Project window, select Microchip Embedded in the Categories pane and select 32-bit MPLAB Harmony 3 Project in the Projects pane.

   Note: If the option 32-Bit MPLAB Harmony v3 Project is not available, install the MPLAB Harmony v3 Configurator plug-in from Tools > Plugins > Available Plugins before continuing with this demonstration. The MPLAB Harmony v3 Configurator overview is available for download at https://microchipdeveloper.com/harmony3:mhc-overview.

Figure 1-1. Creating an MPLAB Harmony v3-Based Project - Choose Project
4. Click **Next**.
5. Under the **Manage Framework** section, enter the **Framework Path** (Path to the folder in which the MPLAB Harmony v3 packages are downloaded). For this demonstration, the MPLAB Harmony v3 packages are downloaded in the following location: `D:\microchip\github\h3`.

**Figure 1-2. Creating MPLAB Harmony v3-Based Project - Framework Selection**

Note: For this demonstration application, the following MPLAB Harmony v3 packages are required: mhc, dev_packs, and csp. The MPLAB Harmony 3 Content Manager tool simplifies the downloading of the MPLAB Harmony v3 packages. If these packages are not downloaded, then the user can use the MPLAB Harmony 3 Content Manager tool to download them onto their computer.

6. Click **Next**.
7. Under the **Name and Location** section, enter the following details:
   - Location: Indicates the path to the root folder of the new project. All project files will be placed in this folder. The project location can be any valid path, for example: `D:\microchip\github\h3\tech_brief`.
   - Folder: Indicates the name of the MPLAB X IDE folder. Enter `hello_world` to create a `hello_world.X` folder.
   - Name: Enter name of the project as `hello_world_sam_d21_xpro`. This name will be displayed in the MPLAB X IDE.
   - Path: The path information will be updated as and when users make changes to other fields.
Figure 1-3. Creating an MPLAB Harmony v3-Based Project - Project Settings

Note: Click the Show Visual Help button to open a contextual help window for a detailed description of various fields in the Project Settings.

8. Click Next.

9. Under the Configuration Settings section, enter the details as given below:
   - Name: Enter the configuration name as **sam_d21_xpro**.
   - Target Device: Choose ATSAMD21J18A.
Figure 1-4. Creating an MPLAB Harmony v3-Based Project - Configuration Settings

Note: Click the Show Visual Help button to open a contextual help window for a detailed description of various fields in the Configuration Settings.

10. Click Finish to launch the MHC.

Note: After clicking the Finish button, if MHC does not launch, users can launch it by selecting Tools > Embedded > MPLAB® Harmony 3 Configurator from the MPLAB X IDE.

11. Before launching the MHC, the Configuration Database Setup window will be displayed, where the Device Family Pack (DFP) and Cortex Microcontroller Software Interface Standard (CMSIS) path can be changed, if required. For this demonstration, the default settings are used.

Figure 1-5. Configuration Database Setup

12. Click Launch.

13. The MHC plug-in will open in a new window. The image below highlights different section available in the MHC.
Note: For this demonstration, Stand-alone mode is used for the MHC Window Manager by changing the settings in the MPLAB X IDE, by selecting > Tools > Options > Plugins > MPLAB Harmony Configurator 3 > Window Manager. If the Native Netbeans mode of the MHC is required, users can set it as default mode by configuring it.

14. For additional information on MHC and how to create the MPLAB Harmony v3 project, visit: https://microchipdeveloper.com/harmony3:mhc-overview.

Step 2: To add and configure the MPLAB Harmony components using the MHC, follow these steps:

1. From Tools, select Clock Configuration to launch the Clock Easy View.

The Clock Easy View window will be displayed inside the MHC Window.

2. In the Clock Easy View window, scroll to the right and verify that the Main Clock is set to 48 MHz.
3. To add and configure the USART Peripheral Library follow these steps:
   - Under Available Components, expand Peripherals and then expand the options available for SERCOM.
   - Double-click on the SERCOM3 to add it to the project

4. Select the SERCOM3 Peripheral Library in the Project Graph, and in the Configuration Options window, configure it as follows:
   - SERCOM Operation mode is set for USART with Internal Clock (default setting).
   - Clear Receive Enable, as the string will only be transmitted in this example.
   - Set the Baud Rate to 9600.
   - For Transmit Pinout choose SERCOM PAD[0] (default setting).
− By default, the Receive Pinout is SERCOM PAD[0]. If the Receive Pinout feature is disabled, it will not affect the operation.

Figure 1-10. MHC SERCOM Configuration

5. Configure the USART pin in the Pin Settings: In the MHC, select Tools > Pin Configuration to open the Pin Settings window.

Figure 1-11. MHC Pin Configuration

6. The MHC Pin Settings window will open and display these options: Pin Diagram, Pin Table, and Pin Settings.
Note: According to the schematic of the SAMD21 Xplained Pro board, the on-board Embedded Debugger (EDBG) can be used as Virtual Com Port to have serial communication between the SAMD21 device and a connected computer console. Therefore, the PA22 (Pin #43) of the SAMD21 must be configured as USART_TX (SERCOM3_PAD0).

7. Click the Pin Settings tab and configure the PA22 pin as SERCOM3_PAD0.

8. The same pin (PA22) can be configured by clicking the Pin Table tab.
Figure 1-14. SERCOM Pin Table

Note:
1. The USART_TX function (Transmit Pinout) is by default configured to be on SERCOM3 PAD0, for additional information, refer to MHC SERCOM Configuration.
2. In the SERCOM3 USART configuration, the USART is enabled only for transmit functionality. Therefore, the USART receive pin is not configured.

Step 3: To generate the code, follow these steps:
1. In MHC click on the Save MHC State icon to save the MHC state before generating the code.
2. Save the configuration in its default location, when prompted.
3. Click on the generate code icon to generate the code.
4. The Modified Configuration window is prompted, click **Save** to save the configuration.

   **Figure 1-17. Saving Configuration**

   ![Modified Configuration Window]

5. In the Generate Project window, click **Generate** to generate the code.
6. The above step triggers these actions in MHC:
   - Generate the code as per the configurations done.
   - Place the generated code and required MPLAB Harmony framework files in the MPLAB Harmony project directory, in this case: D:\microchip\github\h3\tech_brief\firmware\src.
   - Add all generated codes and MPLAB Harmony framework files into the MPLAB Harmony project, as shown in the following figure.
7. The generated code descriptions are as follows:
   - definitions.h: Includes all the header files required for the project.
   - initialization.c: Initializes all the MPLAB Harmony modules used in the application.
   - interrupts.c: Contains the mapping of all the interrupt vectors on the selected device.
   - main.c: A function call to initialize the system present in this file. The user needs to develop their application in this file.
   - peripheral: All peripheral source codes are added in this folder.

**Note:** The MPLAB Harmony project will be shown in another window as this project is in Standalone mode.

**Note:** The MHC provides an option to change the generated file name, and if this option is not used, by default, the file name main.c is generated.
Step 4: To develop and run an application, follow these steps:

1. Developing an application: For this demo application, add the highlighted codes (as shown in image below) in the main.c file. This will send the “Hello World!” string to the console running on the PC. The following code is provided for convenience:

```c
uint8_t buffer[] = "Hello World!\n\n";
SERCOM3_USART_Write(&buffer[0], sizeof(buffer));
```

2. Selecting Hardware Tool and Compiler: In the MPLAB X IDE Project Properties window perform these actions:
   3. Under Categories section, select Conf: (sam_d21_xpro), and in the Configuration section, select the hardware tool and compiler toolchain.

   ```c
   int main ( void )
   { /* Initialize all modules */
    SYS_Initialize ( NULL );
     
     /* Define the string to be printed */
     uint8_t buffer[] = "Hello World!\n\n";
     
     /* Application logic */
     SERCOM3_USART_Write(&buffer[0], sizeof(buffer));
     
     while ( true )
     { /* Maintain state machines of all polled MPLAB Harmony modules. */
       SYS_Tasks ( );
     }
     /* Execution should not come here during normal operation */
     return ( EXIT_FAILURE );
   }
   ```
4. Click OK.

5. Connecting Hardware: Connect a micro-USB cable between the DEBUG USB on the board and the PC. This enables the programming of the microcontroller and provide a serial connection with the console device (computer).

Figure 1-23. Hardware Connection

6. Setting up the Serial Console: Open a terminal application, such as Tera Term on the PC and perform the serial port setup. Below is the default setup details for Tera Term.
7. Programming and Running the Application: Build and program the SAMD21 Xplained Pro kit by using the MPLAB X IDE.

Figure 1-25. Make and Program

8. Observing the Output: Observe the “Hello World!” string on the console. If the desired output is not found on the console, press the Reset button on the Xplained Pro board to reset the device, and ensure that the UART message is communicated.

Figure 1-26. Observing Output
2. **Resources**

- For additional information on MPLAB Harmony v3, refer to the Microchip web site:
  https://www.microchip.com/mplab/mplab-harmony
  https://microchipdeveloper.com/harmony3:start
- Detailed documentation on various MPLAB Harmony v3 components can be found in the documentation folder of the corresponding repository.
- SAM D21 Xplained Pro kit details can be found here:
3. Revision History

Revision B - 02/2020
Typographical updates.
Updated all references for MPLAB Harmony to display MPLAB Harmony v3.

Revision A - 12/2019
This is the initial released version of this document.
The Microchip Website

Microchip provides online support via our website at http://www.microchip.com/. This website is used to make files and information easily available to customers. Some of the content available includes:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip design partner program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will receive email notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, go to http://www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Embedded Solutions Engineer (ESE)
- Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: http://www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with
your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BestTime, BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JuiceBox, KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST, MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer, QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon, TempTracker, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control, HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra, TimeProvider, Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of Microchip Technology Inc. in other countries.

GestiC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.

© 2019, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

Quality Management System

For information regarding Microchip’s Quality Management Systems, please visit http://www.microchip.com/quality.
Worldwide Sales and Service

<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Office</td>
<td>Australia - Sydney</td>
<td>Tel: 61-2-9868-6733</td>
<td>India - Bangalore</td>
</tr>
<tr>
<td>2355 West Chandler Blvd.</td>
<td>China - Beijing</td>
<td>Tel: 86-10-8569-7000</td>
<td>India - New Delhi</td>
</tr>
<tr>
<td>Chandler, AZ 85224-6199</td>
<td>China - Chengdu</td>
<td>Tel: 86-28-8665-5511</td>
<td>India - Pune</td>
</tr>
<tr>
<td>Tel: 480-792-7200</td>
<td>China - Chongqing</td>
<td>Tel: 86-23-8980-9588</td>
<td>Japan - Osaka</td>
</tr>
<tr>
<td>Fax: 480-792-7277</td>
<td>China - Dongguan</td>
<td>Tel: 86-769-8702-9880</td>
<td>Japan - Tokyo</td>
</tr>
<tr>
<td>Technical Support:</td>
<td>China - Guangzhou</td>
<td>Tel: 86-20-8755-8029</td>
<td>Korea - Daegu</td>
</tr>
<tr>
<td><a href="http://www.microchip.com/support">http://www.microchip.com/support</a></td>
<td>China - Hangzhou</td>
<td>Tel: 86-571-8792-8115</td>
<td>Korea - Seoul</td>
</tr>
<tr>
<td>Web Address:</td>
<td>China - Hong Kong SAR</td>
<td>Tel: 852-2943-5100</td>
<td>Malaysia - Kuala Lumpur</td>
</tr>
<tr>
<td><a href="http://www.microchip.com">http://www.microchip.com</a></td>
<td>China - Nanjing</td>
<td>Tel: 86-25-8473-2460</td>
<td>Malaysia - Penang</td>
</tr>
<tr>
<td>Atlanta</td>
<td>China - Qingdao</td>
<td>Tel: 86-532-8502-7355</td>
<td>Philippines - Manila</td>
</tr>
<tr>
<td>Duluth, GA</td>
<td>China - Shanghai</td>
<td>Tel: 86-21-3326-8000</td>
<td>Singapore</td>
</tr>
<tr>
<td>Tel: 678-957-6914</td>
<td>China - Shenyang</td>
<td>Tel: 86-24-2334-2829</td>
<td>Taiwan - Hsin Chu</td>
</tr>
<tr>
<td>Fax: 678-957-1455</td>
<td>China - Shenzhen</td>
<td>Tel: 86-755-8864-2200</td>
<td>Taiwan - Kaohsiung</td>
</tr>
<tr>
<td>Austin, TX</td>
<td>China - Suzhou</td>
<td>Tel: 86-186-6233-1526</td>
<td>Taiwan - Taipei</td>
</tr>
<tr>
<td>Tel: 512-257-3370</td>
<td>China - Wuhan</td>
<td>Tel: 86-27-5980-5300</td>
<td>Thailand - Bangkok</td>
</tr>
<tr>
<td>Boston</td>
<td>China - Xian</td>
<td>Tel: 86-29-8833-7252</td>
<td>Vietnam - Ho Chi Minh</td>
</tr>
<tr>
<td>Westbrook, MA</td>
<td>China - Xiamen</td>
<td>Tel: 86-592-2388138</td>
<td></td>
</tr>
<tr>
<td>Tel: 774-760-0087</td>
<td>China - Zhuhai</td>
<td>Tel: 86-756-3210040</td>
<td></td>
</tr>
<tr>
<td>Fax: 774-760-0088</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chicago</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Itasca, IL</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 630-285-0071</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax: 630-285-0075</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dallas</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Addison, TX</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 972-818-7423</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax: 972-818-2924</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Detroit</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Novi, MI</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 248-848-4000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Houston, TX</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 281-894-5983</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Indianapolis</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Noblesville, IN</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 317-773-8323</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax: 317-773-5453</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 317-536-2380</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Los Angeles</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mission Viejo, CA</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 949-462-9523</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax: 949-462-9608</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 951-273-7800</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Raleigh, NC</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 919-844-7510</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>New York, NY</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 631-435-6000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>San Jose, CA</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 408-735-9110</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 408-436-4270</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Canada - Toronto</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tel: 905-695-1980</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax: 905-695-2078</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>