Creating a Hello World Application on PIC32 Microcontrollers Using the MPLAB Harmony v3’s MPLAB Harmony Configurator (MHC)

Introduction

MPLAB® Harmony v3 is a software framework consisting of compatible and interoperable modules that include peripheral libraries (PLIBs), drivers, system services, middleware and third-party libraries. The MPLAB Harmony Configurator (MHC) is a GUI-based tool that provides an easy way to enable and configure various MPLAB Harmony modules. The MHC is a plug-in for the MPLAB X Integrated Development Environment (IDE).

This document describes how to create an application on a 32-bit PIC32 microcontroller (MCU) using MHC with MPLAB Harmony v3 modules. This application sends a “Hello World!” string to a console running on a computer. For this demonstration, the following MPLAB Harmony v3 modules are used and configured using the MHC:

- Clock PLIB using the Clock manager to configure the microcontroller clock
- GPIO PLIB using the Pin manager to configure the microcontroller I/Os
- UART PLIB to configure UART peripheral as serial port
1. Creating a "Hello World" Application

This document describes how to create a "Hello World" application on PIC32 devices using the MPLAB Harmony v3 MHC tool. It also covers the process which is shown in the following sections. The following software and hardware tools are used for this demonstration:

- MPLABX IDE v5.30
- MHC 3 MPLAB Plug-in v3.4.0
- XC32 v2.30
- MPLAB Harmony v3 repositories:
  - csp v3.5.2
  - mhc v3.3.3
  - dev_packs v3.5.0
- Curiosity PIC32MZ EF 2.0 Development Board

**Note:** Updated versions of the above listed tools can also be used to create the applications, and users are not restricted to use the older versions.

1.1 Creating an MPLAB Harmony v3-based Project

To create an MPLAB Harmony v3-based project, follow these steps:

1. Launch MPLAB X IDE.
2. In MPLAB X IDE, select File > New Project (or click the New Project icon).
3. In the New Project dialog window, select Microchip Embedded in the Categories pane, and select 32-bit MPLAB Harmony 3 Project in the Projects pane.

   **Note:** If the option 32-bit MPLAB Harmony v3 project is not available, install the MPLAB Harmony v3 Configurator plug-in from Tools > Plugins > Available Plugins before continuing with this demonstration.

   **Note:** For more information, visit MPLAB® Harmony v3 Configurator Overview.
4. Click Next.

5. Under Framework Selection, in the Manage Framework section, enter the Framework Path (Path to the folder in which the MPLAB Harmony v3 packages are downloaded). For this demonstration, the MPLAB Harmony v3 packages are downloaded in the following location: D:\microchip\github\h3.
Note: For this demonstration application, the following MPLAB Harmony v3 packages are required: mhc, dev_packs, and csp.
The MPLAB Harmony 3 Content Manager tool simplifies the downloading of the MPLAB Harmony v3 packages. If these packages are not downloaded, then the user can use the MPLAB Harmony v3 Content Manager tool to download them onto a computer.

6. Click Next.
7. Under Project Settings, in the Name and Location section, enter these details:
   - Location: Indicates the path to the root folder of the new project. All project files will be placed inside this folder. The project location can be any valid path, for example: D:\microchip\github\h3\tech_brief.
   - Folder: Indicates the name of the MPLAB X IDE folder. Enter hello_world to create a hello_world.X folder.
   - Name: Enter name of the project as hello_world_pic32mz_ef_curiosity2. This name will be displayed in the MPLAB X IDE.
   - Path: The path information will be updated when users make changes to other fields
8. Click **Next**.

9. Under the **Configuration Settings** section, enter the details as follows:
   - **Name:** Enter the configuration name as \texttt{pic32mz Ef_curi0sity2}
   - **Target Device:** Choose \texttt{PIC32MZ2048EFM144}
Figure 1-4. Creating an MPLAB Harmony v3-Based Project - Configuration Settings

Note: Clicking the Show Visual Help button will open a contextual help window for a detailed description of various fields in the Project Settings.

10. Click Finish to launch the MHC.

Note: After clicking the Finish button, if the MHC does not launch, users can launch it by selecting Tools > Embedded > MPLAB® Harmony 3 Configurator from the MPLAB X IDE.

11. Before launching the MHC, the Configuration Database Setup dialogue will be displayed, where the Device Family Pack (DFP) path can be changed, if required. For this demonstration, the default settings are used.

Note: Click Launch.

12. The MHC plug-in will open in a new window. The following figure highlights the different sections available in the MHC.

Figure 1-5. Configuration Database Setup
1.2 Adding and configuring the MPLAB Harmony components

To add and configure the MPLAB Harmony components using the MHC, follow these steps:

1. From **Tools**, select **Clock Configuration** to launch the Clock Easy View.

   *Figure 1-7. MPLAB Harmony Configurator Tools*

   The Clock Easy View window will be displayed inside the MHC Window.

2. In the Clock Easy View window, scroll to the right and verify that the SYSCLK is set to 200 MHz.
3. To add and configure the UART Peripheral Library follow these steps:
   - Under **Available Components**, expand **Peripherals** and then expand the options available for the **UART**.
   - Double-click on **UART6** to add it to the project graph.
4. Select the UART6 Peripheral Library in the Project Graph, and in the Configuration Options window. Configure it as follows:
   - Verify that the default baud rate is set to **115,200**
5. Configure the UART pins in the Pin Settings window. In the MHC, select Tools > Pin Configuration to open the Pin Settings window.

Figure 1-11. MHC Pin Configuration

6. The MHC Pin Settings window will open and display these options: Pin Diagram, Pin Table, and Pin Settings.

Figure 1-12. MHC Pin Settings

Note: According to schematic of the Curiosity PIC32MZ EF 2.0 Development Board, the PICkit™ On Board 4 (PKOB4) can be used as Virtual Com Port to have serial communication between PIC32MZ EF device and connected computer console. For that, RF2 (Pin #79) of the PIC32MZ EF must be configured as U6TX.
7. Click the **Pin Settings** tab and configure the RF2 pin as U6TX.

   **Figure 1-13. UART Pin Settings**

8. The same pin (RF2) can be configured by clicking the **Pin Table** tab.

   **Figure 1-14. UART Pin Table**

   **Note:** The demonstration will use the UART PLIB for printing messages on the serial terminal. Therefore, in the UART6 configuration, only the transmit pin is configured and the receive pin is not configured.

### 1.3 Generating the Code

To generate the code, use the following steps:

1. In the MHC, click on the **Save MHC State** icon to save the MHC state before generating the code.

   **Figure 1-15. Save MHC State**

2. Save the configuration in its default location, when prompted.
3. Click on the **Generate Code** icon to generate the code.

   **Figure 1-17. MHC Generate Code**

4. The Modified Configuration dialogue is prompted, click **Save** to save the configuration.

   **Figure 1-18. Saving Configuration**

5. In the Generate Project window, click **Generate** to generate the code.
6. The previous step triggers these actions in the MHC:
   - Generates the code per the user configurations
   - Place the generated code and required Harmony framework files in the MPLAB Harmony project directory, in this case: D:\microchip\github\h3\tech_brief\firmware\src
   - Add all generated codes and MPLAB Harmony framework files into the MPLAB Harmony project, as shown in the following figure.
Note: The MPLAB Harmony project will be shown in another window as this project is in Standalone mode.

7. The generated code descriptions are as follows:
   - `definitions.h`: Includes all the header file definitions needed for the project
   - `initialization.c`: Initializes all the Harmony modules which are used in the application
   - `interrupts.c`: Contains the mapping of all the interrupt vectors on the selected device
   - `main.c`: A function call to initialize the system is present in this file. The user needs to develop their application in this file.
   - `peripheral`: All peripheral source codes are added in this folder

Note: The MHC provides an option to change the generated file name, and if this option is not used, by default, the file name `main.c` is generated.
1.4 Developing and Running an Application

To develop and run an application, follow these steps:

1. Developing an Application: For this demonstration application, add the highlighted codes (as shown below) in the main.c file. This will send the “Hello World!” string to the console running on the PC.

The following code is provided for convenience:

```c
uint8_t buffer[] = "Hello World!\r\n";

UART6_Write(&buffer[0], sizeof(buffer));
```
2. Selecting Hardware Tool and Compiler:
   – In the MPLAB X IDE Project Properties window perform these actions.
   – Under Categories section, select the configuration, pic32mz_ef_curiosity2, and in the Configuration section, select the hardware tool and compiler toolchain.

```c
uint8_t buffer[] = "Hello World!\r\n";
// Section: Main Entry Point
// *
// Execution should not come here during normal operation */
return (EXIT_FAILURE);
```
3. Click **Apply**, and then click **OK**.
4. Connecting Hardware: Connect a micro-USB cable between the DEBUG USB on the board and the PC. This enables the programming of the microcontroller and provides a serial connection with the console device (computer).

**Figure 1-24. Hardware Connection**

5. Setting up the Serial Console: Open a terminal application, such as Tera Term on the PC and perform the serial port setup. The following figure shows the setup details for Tera Term.
Figure 1-25. Serial Port Setup

6. Programming and Running the Application: Build and program the Curiosity PIC32MZ EF 2.0 Development Board by using the MPLAB X IDE (Click on **Make and Program** in the MPLAX IDE Tool bar).

Figure 1-26. Make and Program

7. Observing the Output: Observe the “Hello World!” string on the console. If the desired output is not found on the console, press the **Reset** button on the Curiosity Development board to reset the device, and ensure that the UART message is communicated.

Figure 1-27. Observing Output
2. **References**

- For additional information on MPLAB Harmony v3, go to the Microchip web site: [https://www.microchip.com/mplab/mplab-harmony](https://www.microchip.com/mplab/mplab-harmony)
  
  And
  

- Detailed documentation on various MPLAB Harmony v3 components can be found in the "doc" folder of the corresponding repository

- Curiosity PIC32MZ EF 2.0 Development Board details can be found here: [https://www.microchip.com/DevelopmentTools/ProductDetails/DM320209](https://www.microchip.com/DevelopmentTools/ProductDetails/DM320209)
The Microchip Website

Microchip provides online support via our website at http://www.microchip.com/. This website is used to make files and information easily available to customers. Some of the content available includes:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip design partner program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will receive email notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, go to http://www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Embedded Solutions Engineer (ESE)
- Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: http://www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with
your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime, BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox, KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo, MOST, MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip Designer, QTouc, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer, Tachyon, TempTracker, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed Control, HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC, ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra, TimeProvider, Vite, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.

© 2020, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.
ISBN: 978-1-5224-6036-7

Quality Management System

For information regarding Microchip’s Quality Management Systems, please visit http://www.microchip.com/quality.
### AMERICAS

**Corporate Office**  
2355 West Chandler Blvd.  
Chandler, AZ 85224-6199  
Tel: 480-792-7200  
Fax: 480-792-7277  
Technical Support: [http://www.microchip.com/support](http://www.microchip.com/support)  
Web Address: [http://www.microchip.com](http://www.microchip.com)

**Atlanta**  
Duluth, GA  
Tel: 678-957-9614  
Fax: 678-957-1455

**Austin, TX**  
Tel: 512-257-3370

**Boston**  
Westborough, MA  
Tel: 774-760-0087  
Fax: 774-760-0088

**Chicago**  
Itasca, IL  
Tel: 630-285-0071  
Fax: 630-285-0075

**Dallas**  
Addison, TX  
Tel: 972-818-7423  
Fax: 972-818-2924

**Detroit**  
Novi, MI  
Tel: 248-848-4000

**Houston, TX**  
Tel: 281-894-5983

**Indianapolis**  
 Noblesville, IN  
Tel: 317-773-8323  
Fax: 317-773-5453  
Tel: 317-536-2380

**Los Angeles**  
Mission Viejo, CA  
Tel: 949-462-9523  
Fax: 949-462-9608  
Tel: 951-273-7800

**Raleigh, NC**  
Tel: 919-844-7510

**New York, NY**  
Tel: 631-435-6000

**San Jose, CA**  
Tel: 408-735-9110  
Tel: 408-436-4270

**Canada - Toronto**  
Tel: 905-695-1980  
Fax: 905-695-2078

**Australia - Sydney**  
Tel: 61-2-9868-6733

**China - Beijing**  
Tel: 86-10-8569-7000

**China - Chengdu**  
Tel: 86-28-8665-5511

**China - Chongqing**  
Tel: 86-23-8980-9588

**China - Dongguan**  
Tel: 86-769-8702-9880

**China - Guangzhou**  
Tel: 86-20-8755-8029

**China - Hangzhou**  
Tel: 86-571-8792-8115

**China - Hong Kong SAR**  
Tel: 852-2943-5100

**China - Nanjing**  
Tel: 86-25-8473-2460

**China - Qingdao**  
Tel: 86-532-8502-7355

**China - Shanghai**  
Tel: 86-21-3326-8000

**China - Shenzhen**  
Tel: 86-755-8864-2200

**China - Suzhou**  
Tel: 86-186-6233-1526

**China - Wuhan**  
Tel: 86-27-5980-5300

**China - Xi'an**  
Tel: 86-29-8833-7252

**China - Xiamen**  
Tel: 86-592-2388138

**China - Zhuhai**  
Tel: 86-756-3210040

**India - Bangalore**  
Tel: 91-80-3090-4444

**India - New Delhi**  
Tel: 91-11-4160-8631

**India - Pune**  
Tel: 91-20-4121-0141

**Japan - Osaka**  
Tel: 81-6-6152-7160

**Japan - Tokyo**  
Tel: 81-3-6880-3770

**Korea - Daegu**  
Tel: 82-53-744-4301

**Korea - Seoul**  
Tel: 82-2-554-7200

**Malaysia - Kuala Lumpur**  
Tel: 60-3-7651-7906

**Malaysia - Penang**  
Tel: 60-4-227-8870

**Philippines - Manila**  
Tel: 63-2-634-9065

**Singapore**  
Tel: 65-6334-8870

**Taiwan - Hsin Chu**  
Tel: 886-3-577-8366

**Taiwan - Kaohsiung**  
Tel: 886-7-213-7830

**Taiwan - Taipei**  
Tel: 886-2-2508-8600

**Thailand - Bangkok**  
Tel: 66-2-694-1351

**Vietnam - Ho Chi Minh**  
Tel: 84-28-5448-2100

**Europe**

**Austria - Wels**  
Tel: 43-7242-2244-39  
Fax: 43-7242-2244-393

**Denmark - Copenhagen**  
Tel: 45-4450-2828  
Fax: 45-4485-2829

**Finland - Espoo**  
Tel: 358-9-4520-820

**France - Paris**  
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-30-90-79

**Germany - Garching**  
Tel: 49-8931-9700

**Germany - Haan**  
Tel: 49-2129-376400

**Germany - Heilbronn**  
Tel: 49-7131-72400

**Germany - Karlsruhe**  
Tel: 49-721-625370

**Germany - Munich**  
Tel: 49-89-627-144-0  
Fax: 49-89-627-144-44

**Germany - Rosenheim**  
Tel: 49-8031-354-560

**Israel - Ra'anana**  
Tel: 972-9-744-7705

**Italy - Milan**  
Tel: 39-0331-742611  
Fax: 39-0331-466781

**Italy - Padova**  
Tel: 39-049-7625286

**Netherlands - Drunen**  
Tel: 31-416-690399  
Fax: 31-416-690340

**Norway - Trondheim**  
Tel: 47-72864388

**Poland - Warsaw**  
Tel: 48-22-3325737

**Romania - Bucharest**  
Tel: 40-21-407-87-50

**Spain - Madrid**  
Tel: 34-91-708-08-90  
Fax: 34-91-708-08-91

**Sweden - Gothenburg**  
Tel: 46-31-704-60-40

**Sweden - Stockholm**  
Tel: 46-8-5090-4654

**UK - Wokingham**  
Tel: 44-118-921-5800  
Fax: 44-118-921-5820