Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip's code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights.

Trademarks
The Microchip name and logo, the Microchip logo, Accuron, dsPIC, KeeLog, microID, MPLAB, PIC, PICmicro, PICSTART, PRO MATE, PowerSmart, rfPIC and SmartShunt are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.
AmpLab, FilterLab, Migratable Memory, MXDEV, MXLAB, SEEVAL, SmartSensor and The Embedded Control Solutions Company are registered trademarks of Microchip Technology Incorporated in the U.S.A.
Analog-for-the-Digital Age, Application Maestro, CodeGuard, dsPICDEM, dsPICDEM.net, dsPICworks, ECAN, ECONOMONITOR, FanSense, FlexROM, fuzzyLAB, In-Circuit Serial Programming, ICSPI, ICEPIC, Linear Active Thermistor, Mindi, MIW, MPASM, MPLIB, MPLINK, PICkit, PICDEM, PICDEM.net, PICLAB, PICtail, PowerCal, PowerInfo, PowerMate, PowerTool, REAL ICE, rfLAB, rfPICDEM, Select Mode, Smart Serial, SmartTel, Total Endurance, UNI/O, WiperLock and ZENA are trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.
SOQT is a service mark of Microchip Technology Incorporated in the U.S.A.
All other trademarks mentioned herein are property of their respective companies.
© 2006, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.
Printed on recycled paper.

Microchip received ISO/TS-16949:2002 certification for its worldwide headquarters, design and wafer fabrication facilities in Chandler and Tempe, Arizona, Gresham, Oregon and Mountain View, California. The Company’s quality system processes and procedures are for its PIC® 8-bit MCUs, dsPIC® code hopping devices, Serial EEPROMs, microperipherals, nonvolatile memory and analog products. In addition, Microchip’s quality system for the design and manufacture of development systems is ISO 9001:2000 certified.
# Table of Contents

Preface ....................................................................................................................... 1

Chapter 1. Introduction
  1.1 Overview ........................................................................................................ 7
  1.2 dsPICDEM™ SMPS Buck Development Board Kit ........................................ 8
  1.3 dsPICDEM™ SMPS Buck Development Board Features .............................. 8

Chapter 2. Hardware Overview
  2.1 Connectors ................................................................................................... 11
  2.2 User Interface Hardware .............................................................................. 14
  2.3 Program or Debug Selection Switch (SW2) ................................................. 17

Chapter 3. Using the dsPIC30F2020 Device
  3.1 Tutorial Overview ......................................................................................... 19
  3.2 Creating the Project ...................................................................................... 19
  3.3 Building the Code ......................................................................................... 26
  3.4 Programming the Chip ................................................................................. 28
  3.5 Debugging the Code .................................................................................... 33

Chapter 4. Demonstration Program Operation
  4.1 Demonstration Program ............................................................................... 37
  4.2 Demonstration Code .................................................................................... 39
  4.3 Other Code Examples .................................................................................. 40

Appendix A. Schematic and Layouts

Index ............................................................................................................................. 45

Worldwide Sales and Service .................................................................................... 46
Preface

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and documentation are constantly evolving to meet customer needs, so some actual dialogs and/or tool descriptions may differ from those in this document. Please refer to our web site (www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each page, in front of the page number. The numbering convention for the DS number is “DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. Select the Help menu, and then Topics to open a list of available on-line help files.

This document contains general information that is useful to know before using the dsPICDEM™ SMPS Buck Development Board.

Items discussed in this preface include:

• About this Guide
• Conventions Used in this Guide
• Warranty Registration
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

ABOUT THIS GUIDE

This document describes how to use the dsPICDEM™ SMPS Buck Development Board development tool. The manual layout is as follows:

• Chapter 1. “Introduction” – This chapter introduces the dsPICDEM™ SMPS Buck Development Board and provides a brief descriptions of the hardware.
• Chapter 2. “Hardware Overview” – This chapter describes the dsPICDEM™ SMPS Buck Development Board hardware.
• Chapter 3. “Using the dsPIC30F2020 Device” – This chapter goes through a basic step by step process for getting your dsPICDEM™ SMPS Buck Development Board up and running with the MPLAB® In-Circuit Debugger 2 (ICD 2) using a dsPIC30F2020 device.
• Chapter 4. “Demonstration Program Operation” – This chapter describes the operation of the dsPICDEM™ SMPS Buck Development Board.
• Appendix A. “Schematic and Layouts” – This section illustrates the dsPICDEM™ SMPS Buck Development Board layout and provides hardware schematic diagrams.
CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

## DOCUMENTATION CONVENTIONS

<table>
<thead>
<tr>
<th>Description</th>
<th>Represents</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Arial font:</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Italic characters</td>
<td>Referenced books</td>
<td><em>MPLAB® IDE User’s Guide</em></td>
</tr>
<tr>
<td>Emphasized text</td>
<td>Is the <em>only</em> compiler...</td>
<td></td>
</tr>
<tr>
<td>Initial caps</td>
<td>A window</td>
<td><em>save project before build</em></td>
</tr>
<tr>
<td>A dialog</td>
<td>the Output window</td>
<td></td>
</tr>
<tr>
<td>A menu selection</td>
<td>select Enable Programmer</td>
<td></td>
</tr>
<tr>
<td>Quotes</td>
<td>A field name in a window or dialog</td>
<td></td>
</tr>
<tr>
<td>Underlined, italic text with right angle bracket</td>
<td>A menu path</td>
<td><em>File&gt;Save</em></td>
</tr>
<tr>
<td>Bold characters</td>
<td>A dialog button</td>
<td><em>Click OK</em></td>
</tr>
<tr>
<td>A tab</td>
<td>Click the <em>Power</em> tab</td>
<td></td>
</tr>
<tr>
<td>N’Rnmmm</td>
<td>A number in verilog format, where N is the total number of digits, R is the radix and n is a digit.</td>
<td>4'b0010, 2'hF1</td>
</tr>
<tr>
<td>Text in angle brackets &lt; &gt;</td>
<td>A key on the keyboard</td>
<td>Press &lt;Enter&gt;, &lt;F1&gt;</td>
</tr>
<tr>
<td><strong>Courier New font:</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plain Courier New</td>
<td>Sample source code</td>
<td>#define START</td>
</tr>
<tr>
<td>Filenames</td>
<td>autoexec.bat</td>
<td></td>
</tr>
<tr>
<td>File paths</td>
<td>c:\mcc18\h</td>
<td></td>
</tr>
<tr>
<td>Keywords</td>
<td>_asm, _endasm, static</td>
<td></td>
</tr>
<tr>
<td>Command-line options</td>
<td>-Opa+, -Opa-</td>
<td></td>
</tr>
<tr>
<td>Bit values</td>
<td>0, 1</td>
<td></td>
</tr>
<tr>
<td>Constants</td>
<td>0xFF, ‘A’</td>
<td></td>
</tr>
<tr>
<td>Italic Courier New</td>
<td>A variable argument</td>
<td>file.o, where file can be any valid filename</td>
</tr>
<tr>
<td>Square brackets []</td>
<td>Optional arguments</td>
<td>mcc18 [options] file [options]</td>
</tr>
<tr>
<td>Curly brackets and pipe character:{</td>
<td>} Choice of mutually exclusive arguments; an OR selection</td>
<td>errorlevel {0</td>
</tr>
<tr>
<td>Ellipses...</td>
<td>Replaces repeated text</td>
<td>var_name [, var_name...]</td>
</tr>
<tr>
<td></td>
<td>Represents code supplied by user</td>
<td>void main (void) { ... }</td>
</tr>
</tbody>
</table>
WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. Sending in the Warranty Registration Card entitles users to receive new product updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user's guide describes how to use the dsPICDEM™ SMPS Buck Development Board. Other useful documents are listed below. The following Microchip documents are available and recommended as supplemental reference resources.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in the Readmes subdirectory of the MPLAB IDE installation directory. The Readme files contain update information and known issues that may not be included in this user's guide.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user's guides and hardware support documents, latest software releases and archived software
• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip consultant program member listing
• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives
DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, access the Microchip web site at www.microchip.com, click on Customer Change Notification and follow the registration instructions.

The Development Systems product group categories are:

- **Compilers** – The latest information on Microchip C compilers and other language tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; and MPLIB™ and MPLAB LIB30 object librarians.

- **Emulators** – The latest information on Microchip in-circuit emulators. This includes the MPLAB ICE 2000 and MPLAB ICE 4000.

- **In-Circuit Debuggers** – The latest information on the Microchip in-circuit debugger, MPLAB ICD 2.

- **MPLAB® IDE** – The latest information on Microchip MPLAB IDE, the Windows® Integrated Development Environment for development systems tools. This list is focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager and general editing and debugging features.

- **Programmers** – The latest information on Microchip programmers. These include the MPLAB PM3 and PRO MATE® II device programmers and the PICSTART® Plus and PICkit™ 1 development programmers.
CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support

Customers should contact their distributor, representative or field application engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com
DOCUMENT REVISION HISTORY

Revision A (October 2006)

• Initial Release of this Document.
Chapter 1. Introduction

Modern power supplies are becoming smaller, more efficient, more flexible and less costly. These desirable enhancements have come about as digital signal controllers have been incorporated into Switched Mode Power Supply (SMPS) designs. Buck converters are used when the desired output voltage is smaller than the input voltage. This chapter introduces and provides an overview of the dsPICDEM™ SMPS Buck Development Board. Topics covered include:

• Overview
• dsPICDEM™ SMPS Buck Development Board Kit
• dsPICDEM™ SMPS Buck Development Board Features

1.1 OVERVIEW

Figure 1-1 is a block diagram of the dsPICDEM™ SMPS Buck Development Board, A dsPIC30F2020 DSC controls two independent DC/DC synchronous buck converters, providing closed-loop Proportional, Integral, Derivative (PID) control in software to maintain desired output voltage levels. The dsPIC® DSC device provides the necessary memory and peripherals for A/D conversion, PWM generation and general purpose I/O, precluding the need to perform these functions in external circuitry.

FIGURE 1-1: SYNCHRONOUS BUCK CONVERTER BLOCK DIAGRAM
dsPIC DSC SMPS devices are specifically designed to provide low-cost, efficient control of a wide range of power supply topologies. Their specialized peripherals facilitate closed-loop feedback control of switched mode power supplies while also providing communications for remote monitoring and supervisory control.

The dsPICDEM™ SMPS Buck Development Board aids in rapid development of multiple buck converters using dsPIC30F1010/2020 Digital Signal Controllers. The dsPIC30F1010/2020 devices offer these features and capabilities:

- Integrated program and data memory on a single chip
- Ultra fast interrupt response time and hardware interrupt priority logic
- 2000 ksps, on-chip ADC with four dedicated sample/hold circuits for multiple loop control
- Four independent, high-resolution PWM generators specially designed to support different power topology
- Four analog comparators for system protection
- On-chip system communications (I²C/SPI/UART)
- On-chip RC oscillator for lower system cost
- High-current sink/source I/O pins: 25 mA/25mA
- 30 MIPS performance CPU

1.2 dsPICDEM™ SMPS BUCK DEVELOPMENT BOARD KIT

The dsPICDEM™ SMPS Buck Development Board kit contains these items:

- dsPICDEM™ SMPS Buck Development Board
- dsPICDEM™ SMPS Buck Development Board CD containing example code and relevant documentation

1.3 dsPICDEM™ SMPS BUCK DEVELOPMENT BOARD FEATURES

The dsPICDEM™ SMPS Buck Development Board incorporates these features:

1.3.1 Power Stages

- Two synchronous buck converter power stages
- Voltage/current measurement for digital control of buck converters
- In-rush current limiting
- Switchable 5Ω/5W resistive load on VOUT1
- Buck Converter 1 output (VOUT1) on J1 connector for external loading
- Buck Converter 2 output (VOUT2) on J2 connector for external loading

1.3.2 Input/Output Controls

- Three 5 kΩ Potentiometers (R29, R30 and R35)
- Two push button switches (S2 and S4)
- Master Clear push button switch (S3)
- LED indicator (LED3)
1.3.3 Development Board Power

- Auxiliary power input (P1 and P2) – 7V to 15V (9V nominal)
- 9 volt power input (J2)

| Note: | This power input is compatible with the 9 volt power supply that is part of the MPLAB ICD 2 In-Circuit Debugger (DV164007). |

- LED power-on indicator (LED1)
- On-board 5V DC, low-dropout regulator

1.3.4 Communication Ports

- One RS232 port (J6)
- MPLAB ICD 2 programming connector (J5)
- SW2 selection of programming interface to the MPLAB ICD 2 Debugger/Programmer
Chapter 2. Hardware Overview

This chapter describes the dsPICDEM™ SMPS Buck Development Board hardware elements and identifies the hardware components. The topics covered include:

- Connectors
- User Interface Hardware
- Program or Debug Selection Switch (SW2)

2.1 CONNECTORS

Figure 2-1 shows the hardware connection (MPLAB ICD 2 and power supply) to the dsPICDEM™ SMPS Buck Development Board.

FIGURE 2-1: dsPICDEM™ SMPS BUCK DEVELOPMENT BOARD CONNECTED TO MPLAB® ICD 2 AND POWER SUPPLY

<table>
<thead>
<tr>
<th>No</th>
<th>Hardware Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Input Power Connector (J2)</td>
</tr>
<tr>
<td>2</td>
<td>RS232 connector (J6)</td>
</tr>
<tr>
<td>3</td>
<td>Programming/debugging connector (J5)</td>
</tr>
<tr>
<td>4</td>
<td>VOUT1 Connector (J1)</td>
</tr>
<tr>
<td>5</td>
<td>VOUT2 Connector (J3)</td>
</tr>
<tr>
<td>6</td>
<td>Expansion Header (J7)</td>
</tr>
</tbody>
</table>
2.1.1 Input Power Connector

The dsPICDEM™ SMPS Buck Development Board obtains +9V power from a power connector for a +9V AC/DC wall adapter as well as auxiliary power connection points (AUX PWR IN). A separate +5V DC regulator provides the operating voltage (Vdd) required by the dsPIC30F2020 device.

2.1.2 ICD Connector

An RJ11 female connector (J5) connects the MPLAB® ICD 2 to the dsPIC30F2020 device for programming and debugging.

2.1.3 RS-232 Serial Port

An RS-232 serial communication port (J6) is provided for monitoring and controlling the power supply by a remote processor. The PGM DEBUG switch (SW2) must be in set in program mode position (PGM) to communicate via the UART.

2.1.4 VOUT1

An external load can be connected to VOUT1 through connector J1. An on-board 5Ω 5 watt resistor is connected at the output of VOUT1 through MOSFET U6 to optionally load the first buck converter circuit. This load can be enabled or disabled in software. See Figure A-3: “dsPICDEM™ SMPS Buck Development Board Schematic 2 of 3”

2.1.5 VOUT2

An external load can be connected to VOUT2 through connector J1. See Figure A-4: “dsPICDEM™ SMPS Buck Development Board Schematic 3 of 3”

2.1.6 Expansion Header

Header J7 is an expansion connector that matches the dsPIC30F2020 device pins (see Table 2-2 for pin usage information).
### TABLE 2-2: DEVICE PINS IN EXPANSION CONNECTOR

<table>
<thead>
<tr>
<th>Pin Number Primary</th>
<th>Assignment</th>
<th>Primary Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>MCLR</td>
<td>Master Clear (Reset)</td>
</tr>
<tr>
<td>2</td>
<td>AN0/RB0</td>
<td>Analog Input 0 (Buck Converter 1 current)</td>
</tr>
<tr>
<td>3</td>
<td>AN1/RB1</td>
<td>Analog Input 1 (Buck Converter 1 voltage)</td>
</tr>
<tr>
<td>4</td>
<td>AN2/RB2</td>
<td>Analog Input 2 (Buck Converter 2 current)</td>
</tr>
<tr>
<td>5</td>
<td>AN3/RB3</td>
<td>Analog Input 3 (Buck Converter 2 voltage)</td>
</tr>
<tr>
<td>6</td>
<td>AN4/RB4</td>
<td>Analog Input 4 (Input Voltage)</td>
</tr>
<tr>
<td>7</td>
<td>AN5/RB5</td>
<td>Analog Input 5 (Potentiometer R29)</td>
</tr>
<tr>
<td>8</td>
<td>Vss</td>
<td>Ground reference for logic and I/O pins</td>
</tr>
<tr>
<td>9</td>
<td>AN6/OSCI/RB6</td>
<td>Analog Input 6 (Potentiometer R30)</td>
</tr>
<tr>
<td>10</td>
<td>AN7/OSCO/RB7</td>
<td>Analog Input 7 (Potentiometer R35)</td>
</tr>
<tr>
<td>11</td>
<td>EMUD1/RE7</td>
<td>ICD secondary communication channel data</td>
</tr>
<tr>
<td>12</td>
<td>EMUC1/RE6</td>
<td>ICD secondary communication channel clock</td>
</tr>
<tr>
<td>13</td>
<td>VDD</td>
<td>Positive supply for logic and I/O pins</td>
</tr>
<tr>
<td>14</td>
<td>OC2/RF6</td>
<td>Compare output</td>
</tr>
<tr>
<td>15</td>
<td>OC1/RD0</td>
<td>Compare output</td>
</tr>
<tr>
<td>16</td>
<td>RA9</td>
<td>Port A pin (LED3)</td>
</tr>
<tr>
<td>17</td>
<td>U1TX/PGC/RF7</td>
<td>UART1 Receive</td>
</tr>
<tr>
<td>18</td>
<td>U1RX/PGD/RF8</td>
<td>UART1 Transmit</td>
</tr>
<tr>
<td>19</td>
<td>Vss</td>
<td>Ground reference for logic and I/O pins</td>
</tr>
<tr>
<td>20</td>
<td>VDD</td>
<td>Positive supply for logic and I/O pins</td>
</tr>
<tr>
<td>21</td>
<td>PWM3H/RE5</td>
<td>PWM 3 High Output (Push Button Switch S2)</td>
</tr>
<tr>
<td>22</td>
<td>PWM3L/RE4</td>
<td>PWM 3 Low Output (Push Button Switch S4)</td>
</tr>
<tr>
<td>23</td>
<td>PWM2H/RE3</td>
<td>PWM 2 High Output (Buck Converter 2)</td>
</tr>
<tr>
<td>24</td>
<td>PWM2L/RE2</td>
<td>PWM 2 Low Output (Buck Converter 2)</td>
</tr>
<tr>
<td>25</td>
<td>PWM1H/RE1</td>
<td>PWM 1 High Output (Buck Converter 1)</td>
</tr>
<tr>
<td>26</td>
<td>PWM1L/RE0</td>
<td>PWM 1 Low Output (Buck Converter 1)</td>
</tr>
<tr>
<td>27</td>
<td>AVSS</td>
<td>Ground reference for analog module</td>
</tr>
<tr>
<td>28</td>
<td>AVDD</td>
<td>Positive supply for analog module</td>
</tr>
</tbody>
</table>
2.2 USER INTERFACE HARDWARE

Figure 2-2 identifies the hardware elements that comprise the user interface (jumpers, switches, LEDs and potentiometers) on the dsPICDEM™ SMPS Buck Development Board.

**FIGURE 2-2: JUMPERS/LED/SWITCHES/POTENTIOMETER**

2.2.1 Jumpers

The dsPICDEM™ SMPS Buck Development Board has seven jumpers that determine how features on the buck converters are used. Table 2-3 lists these jumpers and their functions.

**TABLE 2-3: JUMPER DESCRIPTIONS**

<table>
<thead>
<tr>
<th>Jumper</th>
<th>Description</th>
</tr>
</thead>
</table>
| JP1    | Buck Converter 1 Input Select  
ON: Connects the Input power to buck converter 1  
OFF: Input to buck converter 1 is left open |
| JP2    | Buck Converter 1 Load Drive  
ON: Turn ON buck converter 1 load (5Ω/5W) using OC1/RD0 pin  
OFF: On board load is disabled |
| JP3    | Buck Converter 2 Input Select  
ON: Connects the Input power to buck converter 2  
OFF: Input to buck converter 2 is left open |
2.2.2 Switches, LEDs and Potentiometers

The dsPICDEM™ SMPS Buck Development Board has 2 switches, 3 potentiometers and one LED for user applications. The board also has one power ON status LED and device reset switch.

<table>
<thead>
<tr>
<th>Jumper</th>
<th>Description</th>
</tr>
</thead>
</table>
| JP4    | Buck Converter 1 Synchronous MOSFET Drive  
        | ON: Enable Synchronous MOSFET drive for buck converter 1  
        | OFF: Disable Synchronous MOSFET drive for buck converter 1 |
| JP5    | Buck Converter 2 Synchronous MOSFET Drive  
        | ON: Enable Synchronous MOSFET drive for buck converter 2  
        | OFF: Disable Synchronous MOSFET drive for buck converter 2 |
| J4     | Buck Converter 1 Current Sense Position Select  
        | Jumper J4 is connected to the buck converter 1 output bulk capacitor. It allows the user to select the current sense resistor position for different applications.  
        | Position | Function |
        |        | 1-2 | Current sense resistor senses output load of converter 1 |
        |        | 2-3 | Current sense resistor senses inductor current of converter 1 |
| J8     | Buck Converter 2 Current Sense Position Select  
        | Jumper J8 is connected to the buck converter 2 output bulk capacitor. It allows the user to select the current sense resistor position for different applications.  
        | Position | Function |
        |        | 1-2 | Current sense resistor senses load current of converter 2 |
        |        | 2-3 | Current sense resistor senses inductor current of converter 2 |

2.2.3 Test Points

The dsPICDEM™ SMPS Buck Development Board provides seven power test points that can be used to debug the power stage and eight PWM test points that can be used to check the PWM signal and gate drive to buck converter 1 and 2. These test points are described in Table 2-5 and Table 2-6, respectively.
FIGURE 2-3: TEST POINTS

TABLE 2-5: POWER TEST POINTS

<table>
<thead>
<tr>
<th>Test Point</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TP1</td>
<td>5V DC Regulator Output</td>
</tr>
<tr>
<td>TP2</td>
<td>5V DC Regulator Output Ground (^{(1)})</td>
</tr>
<tr>
<td>P1</td>
<td>Input Supply Voltage</td>
</tr>
<tr>
<td>P2</td>
<td>Input Supply Ground (^{(1)})</td>
</tr>
<tr>
<td>P3</td>
<td>Buck Converter Output Ground (^{(1)})</td>
</tr>
<tr>
<td>P9</td>
<td>Buck Converter 1 Switching Point</td>
</tr>
<tr>
<td>P14</td>
<td>Buck Converter 2 Switching Point</td>
</tr>
</tbody>
</table>

Note 1: All ground test points are shorted

TABLE 2-6: PWM TEST POINTS

<table>
<thead>
<tr>
<th>Test Point</th>
<th>Signal</th>
</tr>
</thead>
<tbody>
<tr>
<td>P5</td>
<td>Buck Switch PWM signal (Buck Converter 1)</td>
</tr>
<tr>
<td>P6</td>
<td>Synchronous Switch PWM signal (Buck Converter 1)</td>
</tr>
<tr>
<td>P7</td>
<td>Buck Switch PWM signal (Buck converter 2)</td>
</tr>
<tr>
<td>P8</td>
<td>Synchronous Switch PWM signal (Buck Converter 2)</td>
</tr>
<tr>
<td>P10</td>
<td>Buck Switch Gate Drive (Buck Converter 1)</td>
</tr>
<tr>
<td>P11</td>
<td>Synchronous Switch Gate Drive (Buck Converter 1)</td>
</tr>
<tr>
<td>P12</td>
<td>Buck Switch Gate Drive (Buck Converter 2)</td>
</tr>
<tr>
<td>P13</td>
<td>Synchronous Switch Gate Drive (Buck Converter 2)</td>
</tr>
</tbody>
</table>
2.3 PROGRAM OR DEBUG SELECTION SWITCH (SW2)

The dsPIC30F2020 device program pins (PGC/PGD) are multiplexed with the UART pins (U1RX and U1TX). A DIP switch (SW2) selects whether the default programming pin pair (PGC/PGC) are used to program the device. Because PGC and PGD are multiplexed with the UART pins, the pins can only be used to program the device. Debugging is not possible with PGC/EMUC and PGD/EMUD.

When SW2 is in the PGM position, the PGC/PGD and PGC1/PGD1 pins are connected to the ICD 2. This configuration allows you to program the device with either the default programming pin pair (PGC/PGD) or the first set of auxiliary programming pins (PGC1/PGD1). Emulation and debugging in not possible when SW2 is in the PGM position and the default programming/emulation pins are selected (via the Configuration bits).

When SW2 is in the DEBUG position, PGC1/EMUC1 and PGD1/EMUD1 must be selected as the debugging pin pair in the Configuration bit settings window. Both programming and debugging are possible in this configuration.
Chapter 3. Using the dsPIC30F2020 Device

This chapter is a self-paced tutorial to get you started using the dsPICDEM™ SMPS Buck Development Board with its on-board dsPIC30F2020 device. Information is provided on these topics:

• Tutorial Overview
• Creating the Project
• Building the Code
• Programming the Chip
• Debugging the Code

3.1 TUTORIAL OVERVIEW

The tutorial demonstrates the main features of MPLAB IDE Integrated Development Environment and the MPLAB ICD 2 In-Circuit Debugger as they are used with the dsPICDEM™ SMPS Buck Development Board. On completing this tutorial, you should be able to:

• Create a project using the Project Wizard.
• Assemble and link the code and set the Configuration bits.
• Set up MPLAB IDE to use the MPLAB ICD 2 In-Circuit Debugger.
• Program the chip with the MPLAB ICD 2.
• View the code execution.
• View registers in a Watch window.
• Set a breakpoint and make the code halt at a chosen location.
• Use the function keys to Reset, Run, Halt and Single Step the code.

Before you begin the tutorial, run the install program on the dsPICDEM™ SMPS Buck Development Board CD. The default installation location is:

c:\Program Files\Microchip\Sync Buck Board\Firmware\DualBuck

3.2 CREATING THE PROJECT

The first step is to create a project and workspace in MPLAB IDE. Usually, you will have one project in one workspace.

Note: These instructions presume the use of MPLAB IDE 7.43 or newer.

A project contains the files needed to build an application (source code, linker script files, etc.) along with their associations to various build tools and build options.

A workspace contains one or more projects and information on the selected device, debug tool and/or programmer, open windows and their location, and other IDE configuration settings. MPLAB IDE provides a Project Wizard to help create new projects.
3.2.1 Select a dsPIC DSC Device

- Start MPLAB IDE.
- Close any workspace that might be open (File>Close Workspace).
- From the Project menu, select Project Wizard.
- From the Welcome screen, click Next> to display the Project Wizard Step One dialog as shown in the Figure 3-1.

FIGURE 3-1: PROJECT WIZARD, STEP 1, SELECT A DEVICE

- From the Device: pull-down list, select dsPIC30F2020 and click Next>. The Project Wizard Step Two dialog displays as shown in Figure 3-2.
3.2.2 Select Language Toolsuite

- From the Active Toolsuite pull-down menu, select Microchip ASM30 Toolsuite. This tool suite includes the assembler and linker that will be used.

  **Note:** If you are creating a project with source files written in a language other than Microchip assembly, choose the appropriate language tool suite from the drop-down selections.

- In the Toolsuite Contents block, select MPLAB ASM30 Assembler (pic30-as.exe).
- In the Location block, click **Browse...** and navigate to:
  C:\Program Files\Microchip\MPLAB ASM30 Suite\bin\pic30-as.exe
- With MPLAB LINK30 Object Linker (pic30-id.exe) selected in Toolsuite Contents, click **Browse...** and navigate to:
  C:\Program Files\Microchip\MPLAB ASM30 Suite\bin\pic30-id.exe
- Click **Next** to continue. The Project Wizard Step Three dialog displays as shown in Figure 3-3.
3.2.3 Name Your Project

- In the Project Name text box, type DualBuck.
- Click Browse... and navigate to C:\DualBuck to place your project in the tutorial folder (create this folder if it does not already exist).
- Click Next> to continue. The Project Wizard Step Four dialog displays as shown in Figure 3-4.
3.2.4 Add Files to Project

- In the left window, navigate to `C:\...\Firmware\DualBuck` and select these files:
  
  SMPS_PID_Control.s  
  isr_traps.s  
  p30f2020.gld  
  p30f2020.inc  

- Click **Add>>** to include these files in the project. The files appear with check boxes in the right-hand window.
- Check each box (to instruct the Project Wizard to copy these files to the project directory).
- Click **Next>** to continue.
- When the summary screen displays, click **Finish**.
- When the Save Workspace As window displays, type DualBuck.mcw in the "File name" field and save the workspace in `C:\DualBuck` (see Figure 3-5).
After the project wizard completes, the MPLAB IDE project window shows the `isr_traps.s` and `SMPS_PID_Control.s` files in the Source Files folder, the `p30f2020.inc` file in the Header Files folder and the `p30f2020.gld` file in the Linker Scripts folder (Figure 3-6).
A project and workspace has now been created in MPLAB IDE. DualBuck.mcw is the workspace file and DualBuck.mcp is the project file. Double click the SMPS_PID_Controls.s file in the project window to open the file. MPLAB IDE should now look similar to Figure 3-7.
3.3 BUILDING THE CODE

In this project, building the code consists of assembling the SMPS_PID_Controls.s and isr_traps.s files to create their respective object files, SMPS_PID_Controls.o and isr_traps.o, and then linking the object files to create the DualBuck.hex and DualBuck.cof output files. The .hex file contains the data necessary to program the device and the .cof file contains additional information that lets you debug at the source code level.

Before building, there are settings required to tell MPLAB IDE where to find the include files and to reserve space for the extra debug code when the MPLAB ICD 2 is used. The following line is near the top of the SMPS_PID_Controls.s file:

```
.include "p30f2020.inc"
```

This line causes a standard include file to be used. Microchip provides these files with all the Special Function Register (SFR) labels already defined for convenience. To build the code, select Build Options>Project from the Project menu. The Build Options dialog displays, as shown in Figure 3-8.

**FIGURE 3-8: BUILD OPTIONS**
3.3.1 Identify Assembler Include Path

- Select the General tab.
- At the Assembler Include Path, $(AINDIR) box, click **Browse**... and navigate to:
  C:\Program Files\Microchip\MPLAB ASM30 Suite\Support\Inc
  This path tells MPLAB IDE where to find the include files
- Click **Apply** and then click **OK**.

**Note:** The p30f2020.inc file was included when you added files to the project folder (section **Section 3.2.4 “Add Files to Project”**). Selecting an Assembler Include Path in the manner described here allows you to link to the latest .inc file included with MPLAB IDE. Skip this step to use the .inc file in the project folder.

3.3.2 Link for ICD 2

It is necessary to tell the linker that the code should be built with the intention to debug. This sets aside RAM for the MPLAB ICD 2 to use during debugging. If this step is not done, the MPLAB ICD 2 will not function properly in Debug mode.

- On the Project Manager toolbar, select “Debug” from the drop-down box (see Figure 3-9)

**FIGURE 3-9: LINK PROJECT FOR MPLAB® ICD 2**
3.3.3 Build the Project

- Select **Project>Build All**.
- Observe the progress of the build in the Output window as shown in Figure 3-10.

**FIGURE 3-10: BUILD OUTPUT WINDOW**

![Build Output Window](image)

3.4 PROGRAMMING THE CHIP

The MPLAB ICD 2 In-Circuit Debugger can be used to program and debug the dsPIC30F2020 device in-circuit on the dsPICDEM™ SMPS Buck Development Board.

**Note:** Before proceeding, make sure that the USB driver for the MPLAB ICD 2 has been installed on your PC (see the “**MPLAB® ICD 2 In-Circuit Debugger User’s Guide**” (DS51331) for more details regarding the installation of MPLAB ICD 2).

3.4.1 Setup the Device Configuration

- Use the **Configure>Configuration Bits** menu to display the configuration settings.
- Set up the Configuration bits as shown in Figure 3-11.

**FIGURE 3-11: CONFIGURATION SETTINGS**

![Configuration Settings](image)
3.4.2 Connect the MPLAB ICD 2 In-Circuit Debugger

- Before connecting the MPLAB ICD 2 make sure SW2 is in the **DEBUG** position.
- Connect the MPLAB ICD 2 to the PC with the USB cable as shown in Figure 3-12).
- Connect the MPLAB ICD 2 to the dsPICDEM™ SMPS Buck Development Board with the short RJ-11 (telephone) cable.
- Apply +9V power to the board.

**FIGURE 3-12:** dsPICDEM™ SMPS BUCK DEVELOPMENT BOARD CONNECTED TO MPLAB® ICD 2 IN-CIRCUIT DEBUGGER
3.4.3 Enable MPLAB ICD 2 Connection

- From the Debugger menu, click Select Tool>MPLAB ICD 2 to designate the MPLAB ICD 2 as the debug tool in MPLAB IDE.
- Select Debugger>Connect to connect the debugger to the device. The MPLAB ICD 2 should report that it found the dsPIC30F2020 device, as shown in Figure 3-13.
- Select Debugger>Settings to display the MPLAB ICD 2 Debugger settings.
- Select the Program tab.
- Check Allow ICD 2 to select memories and ranges, as shown in Figure 3-14. This setting will speed up operations by programming only a small part of the total program memory.

Note: The MPLAB ICD 2 may need to download the new firmware if this is the first time the MPLAB ICD 2 is being used with a dsPIC30F device. If any errors are shown, double click the error message to get more information.

FIGURE 3-13: ENABLING MPLAB® ICD 2

![Output window showing successful MPLAB ICD 2 connection and settings]
3.4.4 Program the dsPIC30F2020

- From the Debugger menu, select Program. The Output window (Figure 3-15) displays the program steps as they occur.
- Observe the process in the Output window. When “MPLAB ICD 2 Ready” displays, the device is programmed and ready to run.
- Use the Debugger>Reset menu to reset the code, then Debugger>Run to run the code.
FIGURE 3-15: PROGRAMMING THE DSPIC30F2020 DEVICE

![Output window showing programming progress]

- MPLAB ICD 2 Ready
- Programming Target...
- Validating configuration fields
- Erasing Part
- Programming Program Memory (0x0 - 0x43F)
- Verifying...
- Program Memory
- Verify Succeeded
- Loading Debug Executive
- Programming Debug Executive
- Debug Executive
- Programming Debug Vector
- Debug Vector
- Programming Configuration Bits
- Config Memory
- Verifying configuration memory...
- Connecting to debug executive...
- Programming succeeded

09-Oct-2006, 03:49:15

MPLAB ICD 2 Ready
3.5 DEBUGGING THE CODE

The MPLAB ICD 2 In-Circuit Debugger can be used to run, halt and step the code. A breakpoint can be set to halt the program after the code has executed the instruction at the breakpoint. The contents of the RAM and registers can be viewed whenever the processor has been halted.

The MPLAB ICD 2 In-Circuit Debugger uses the following function keys to access the main debugging functions:

- <F5> Halt
- <F6> Reset
- <F7> Single Step
- <F9> Run

In addition, there are more functions available by right clicking on a line of source code. The most important of these are “Set Breakpoint” and “Run to Cursor”.

3.5.1 Display the Code

- From the View menu, select View>Program Memory.
- On the Program Memory window, select the Symbolic tab, as shown in Figure 3-16.
- Press <F5> to halt the processor and press <F6> to reset. The program memory now shows a green arrow pointing to the line of code at address 0.

The instruction at this location is `goto 0x000100`. This code is added by the linker to make the program branch to the start of the code in the `Lab1.c` file. From location 0x000100 executable code starts.

**FIGURE 3-16: PROGRAM MEMORY WINDOW**
3.5.2 Step the Program

- Press <F7> to single step the code. The green arrow now points to the code below _reset in the SMPS_PID_Control.s source code, as shown in Figure 3-17.
- Right click two lines below the green arrow and choose "Run to Cursor". The green arrow then points to the line on which you right clicked.
- From the View menu, select View>Watch to open a Watch window as shown in Figure 3-18.
- From the Add SFR pull-down list, display DTR1.
- Click Add SFR to add the DTR1 register to the Watch window.
- Next, select PWMCON1 from the pull-down list and click Add SFR.
- Repeat for the ADCON register.
- You will be able to view these registers change as you step through the code.

FIGURE 3-17: SOURCE CODE WINDOW

FIGURE 3-18: WATCH WINDOW DISPLAY
3.5.3 Set Break Point

- To set a breakpoint, right click a code line and select “Set Breakpoint” from the pop-up menu.
  As an example, find the following line of code and set a breakpoint on this line.

```plaintext
cp0 VIN_GOOD_FLAG
```

A red stop sign should appear in the gutter (gray bar on the left) of the source code window, as shown in Figure 3-19.

- Press <F9> to run the code. The program halts on the instruction following the breakpoint.

**Note:** An alternate method is to simply double click the line. This feature may need to be enabled using the Edit>Properties menu.

**FIGURE 3-19:** SETTING BREAKPOINT

![MPLAB IDE Editor](image-url)

<table>
<thead>
<tr>
<th>Line</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>900</td>
<td>IDLE_LOOP:</td>
</tr>
<tr>
<td>901</td>
<td>call CHECKFLT_TIMER ; Check if fault timer is active or done</td>
</tr>
<tr>
<td>902</td>
<td>call CHECKVIN ; Check if input voltage is OK</td>
</tr>
<tr>
<td>903</td>
<td>cp0 VIN_GOOD_FLAG ; Do we have good Vin?</td>
</tr>
<tr>
<td>904</td>
<td>bra z, IDLE_LOOP ; Wait for good vin if we have had vin</td>
</tr>
<tr>
<td>905</td>
<td>call FAULTCHECK ; Check for overcurrent or undervoltage</td>
</tr>
<tr>
<td>906</td>
<td>cp0 FAULT_FLAG ; Do we have a fault?</td>
</tr>
<tr>
<td>907</td>
<td>bra nz, IDLE_LOOP ; Wait for fault timer to time out</td>
</tr>
<tr>
<td>908</td>
<td>cp0 SOFTSTART_FLAG ; Check soft start mode</td>
</tr>
<tr>
<td>909</td>
<td>bra z, NORMAL_OPERATION ; If no soft start, do normal stuff</td>
</tr>
<tr>
<td>910</td>
<td>mov $SOFT_START_PERIOD, w0 ; read soft start timer value</td>
</tr>
<tr>
<td>911</td>
<td>cp SYSTEM_TIMER ; (SYSTEM_TIMER - WREG)</td>
</tr>
<tr>
<td>912</td>
<td>bra lt, IDLE_LOOP ; Loop back until timer &gt; Period</td>
</tr>
<tr>
<td>913</td>
<td>call SOFTSTART ; Process soft start operations</td>
</tr>
</tbody>
</table>
Chapter 4. Demonstration Program Operation

The dsPIC30F2020 device supplied with the dsPICDEM™ SMPS Buck Development Board is pre-programmed with a demonstration program that illustrates simultaneous Proportional-Integral-Derivative (PID) control of the output voltage for the two buck circuits on the dsPICDEM™ SMPS Buck Development Board. This code is available on the CD that is provided with the dsPICDEM™ SMPS Buck Development Board kit. It can also be downloaded from the Microchip web site (www.microchip.com).

This section covers the following topics:
- Demonstration Program
- Demonstration Code
- Other Code Examples

4.1 DEMONSTRATION PROGRAM

The demonstration program provides simultaneous closed-loop control of the output voltage from both buck circuits on the dsPICDEM™ SMPS Buck Development Board. One PID loop controls a target voltage output (VOUT1) at 5V. The other PID loop controls a target voltage output (VOUT2) at 3.3V.

The PID control scheme consists of seven parameters. The main parameters are:

1. **Proportional Error Gain (P-Gain)** – This parameter produces a correction factor that is proportional to the magnitude of the output voltage error.
2. **Integral Error Gain (I-Gain)** – This parameter uses the cumulative voltage error to generate a correction factor that eliminates any residual error due to limitations in offset voltages and measurement resolution.
3. **Derivative Error Gain (D-Gain)** – This parameter produces a correction factor that is proportional to the rate of change of the output error voltage, which helps the system respond quickly to changes in system conditions.

Additional control parameters that are summed with the P, I, and D Gain terms are:

4. **Second Derivative, or Jerk Error, Gain (J-Gain)** – This parameter produces a correction factor that is proportional to the change in the differential error (i.e., the derivative of the derivative). J-Gain is a high frequency term that tends to provide quick response to an impulse event.
5. **Feed Forward Gain** – This parameter produces a correction factor based on the desired output voltage that is computed based on the magnitude of the input voltage, inductor current, and circuit attributes (i.e. inductor and capacitor values). This term allows the control loop to be proactive rather than reactive. In other words, when the input voltage changes, feed forward gain responds so that the control loop does not have to wait until the output voltage changes before making the appropriate gain correction.
6. **Dead Time Gain** – This parameter produces a correction factor, which compensates for the fact that the feed forward gain term does not account for the energy lost due to the dead time of the PWM signal (the time when both MOSFETs are off).
7. **Current-Limit Gain** – This parameter limits the cumulative control gain when the current is approaching its upper limit.
The demonstration program requires no manual preparation except to connect 9V power to the board. You can verify the VOUT1 and VOUT2 voltage levels by measuring them at the output terminals (J1 and J3, respectively).

If you installed the software that came on the dsPICDEM™ SMPS Buck Development Board CD, the demonstration program source code is located in the following folder on your PC.

C:\Program Files\Microchip\Sync Buck Board\Firmware\DualBuck

Instructions for programming the dsPIC30F2020 are provided in the Readme file that is included in the DualBuck folder. Chapter 3 also describes how to program the dsPIC30F2020 using the ICD 2. Figure 4-1 illustrates the program flow of the demonstration program.

FIGURE 4-1: SMPS DEMONSTRATION PROGRAM FLOW CHART

START

Initialization Routines:
• Peripherals – ADC, PWM, Timers, GPIO, etc.
• Variables – PID Gain Terms, Data Buffers
• Constants – Desired Voltage, Current Limit, etc.
• Interrupts – ADC, Timers
• Set Soft Start Flag
• System Stabilization

Fault-Check Routine

Fault-Check Routine

Does Fault Condition Exist?

Yes

Disable Outputs

No

Soft Start Routine

Soft Start Routine

Is Soft Start Active?

Yes

No

ADC Interrupt Routines:
• Measure VOUT
• Calculate PID Gain Parameters
• Update PWM Duty Cycle

ADC Interrupt

END

Idle Loop Functions:
• Check VIN
• Check Soft Start Flag
• Check/Reset Fault Timers and Flags
• Perform non-critical functions here (e.g. user application tasks)
4.2 DEMONSTRATION CODE

4.2.1 System Initialization

When power is applied to the board, the program starts by executing these system initialization routines:

- **Peripherals** – The required peripherals (PWM, ADC, Timers, GPIO) are configured and enabled.
- **Variables** – Program variables are defined. RAM locations and register usage are also defined and documented.
- **Constants** – Program constants are defined, including reference setpoints for both VOUT1 and VOUT2, input voltage, current limits, fault conditions, PWM periods and Timer periods.
- **Interrupts** – The ADC and Timer Interrupts are set up and enabled.
- **Soft Start** – The Soft Start flag is set
- **System Stabilization** – All outputs are discharged to ensure a stable value at startup.

4.2.2 Fault Check

The program checks the ADC for input undervoltage and output overvoltage conditions. If a fault occurs, the PWM outputs are disabled until the fault condition is cleared. If no fault is detected, the program proceeds.

4.2.3 Soft Start

If the Soft Start flag is set, the Soft Start Routine ramps up the output voltage in an open-loop fashion to bring the system within the operating range of the PID control loop. This routine ensures that the output does not overshoot the desired voltage. It also limits the current at startup.

4.2.4 ADC Interrupt

The ADC Interrupt is the heart of the demo program. This routine takes up approximately 75% of the execution time. It performs all the PID calculations and applies any needed corrections to the output.

Two simultaneous PID loops are being processed (one for VOUT1 and the other for VOUT2). Each loop has its own variables, constants and peripheral initialization.

Key points to note are:

- The ADC Interrupt can occur at any time during program execution, and
- It takes priority over any other tasks that the program is performing.

4.2.5 System Idle Loop

All auxiliary functions are performed in the System Idle routine. This is the time available to the CPU while the demo program is waiting for an ADC Interrupt. Non-critical functions can be performed in this loop. During this time the input voltage, fault timers and Soft Start flag are checked.
4.3 OTHER CODE EXAMPLES

There are several other code examples included on the dsPICDEM™ SMPS Buck Development Board CD. Please refer to the Readme files located in each code example folder for details on what each code example demonstrates. Check the Microchip website (www.microchip.com) for the latest updates to these code examples and for additional code examples.
Appendix A. Schematic and Layouts

This Appendix provides a layout drawing of the printed circuit board followed by schematics for the dsPICDEM™ SMPS Buck Development Board.

FIGURE A-1: dsPICDEM™ SMPS BUCK DEVELOPMENT BOARD LAYOUT
Index

B
Block Diagram
  Synchronous Buck Converter .................................. 7
Board Features ......................................................... 8

C
Communication Ports .................................................. 9
Connectors .................................................................. 11
Current Limit Gain .................................................... 37
Customer Notification Service ........................................ 4
Customer Support ....................................................... 5

D
Dead Time Gain ............................................................ 37
Derivative Error Gain (D-Gain) ........................................ 37
Development Board Power ............................................. 9
Documentation
  Conventions .......................................................... 2
  Layout ..................................................................... 1

E
Expansion Header ....................................................... 12

F
Feed Forward Gain ...................................................... 37

I
ICD Connector .............................................................. 12
Input Power Connector .................................................. 12
Input/Output Controls ................................................... 8
Integral Error Gain (I-Gain) ............................................ 37
Internet Address ......................................................... 3

J
Jerk Error Gain (J-Gain) ................................................ 37
Jumper Descriptions ..................................................... 14

K
Kit
  dsPICDEM™ SMPS Buck Development Board ............. 8

M
Microchip Internet Web Site ......................................... 3

P
PID Control .................................................................. 37
Power Stages .............................................................. 8
Power Test Points ....................................................... 16
Program/Debug Switch ............................................... 16, 17
Proportional Error Gain (P-Gain) .................................... 37
PWM Test Points ........................................................ 16

R
Reading, Recommended ............................................... 3
RS-232 Serial Port ....................................................... 12

S
Second Derivative Gain (J-Gain) .................................... 37
Synchronous Buck Converter Block Diagram ............... 7

T
Test Points ................................................................. 15

V
VOUT1 ..................................................................... 12
VOUT2 ..................................................................... 12

W
Warranty Registration ................................................... 3
WWW Address ............................................................. 3