Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.

- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.

- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

- Microchip is willing to work with the customer who is concerned about the integrity of their code.

- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights.

Trademarks

The Microchip name and logo, the Microchip logo, dsPIC, KEELOQ logo, MPLAB, PIC, PICmicro, PICSTART, rPIC and UNI/O are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

FilterLab, Hampshire, HI-TECH C, Linear Active Thermistor, MXDEV, MXLAB, SEEVAL and The Embedded Control Solutions Company are registered trademarks of Microchip Technology Incorporated in the U.S.A.

Analog-for-the-Digital Age, Application Maestro, CodeGuard, dsPICDEM, dsPICDEM.net, dsPICworks, dsSPEAK, ECAN, ECONOMONITOR, FanSense, Hi-TIDE, In-Circuit Serial Programming, ICSP, Mindi, MIWI, MPASM, MPLAB Certified logo, MPLIB, MPLINK, mTouch, Octopus, Omniscent Code Generation, PICC, PICC-18, PICDEM, PICDEM.net, PICkit, PICtail, PIC32 logo, REAL ICE, rFLAB, Select Mode, Total Endurance, TSHARC, UniWinDriver, WiperLock and ZENA are trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

All other trademarks mentioned herein are property of their respective companies.

© 2009, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.

Printed on recycled paper.

Microchip received ISO/TS-16949:2002 certification for its worldwide headquarters, design and wafer fabrication facilities in Chandler and Tempe, Arizona; Gresham, Oregon and design centers in California and India. The Company’s quality system processes and procedures are for its PIC® MCUs and dsPIC® DSCs, KEELOQ® code hopping devices, Serial EEPROMs, microperipherals, nonvolatile memory and analog products. In addition, Microchip’s quality system for the design and manufacture of development systems is ISO 9001:2000 certified.
# Table of Contents

## Chapter 1. Introduction

1.1 Kit Contents .......................................................... 11  
1.2 PIC32 Functionality and Features ............................... 12

## Chapter 2. Tutorial

2.1 Host Computer Requirements .................................. 15  
2.2 Installing the PIC32 USB Starter Kit II Software ........... 16  
2.3 Using the PIC32 USB Starter Kit II Out of the Box ...... 20  
2.4 Starting the Tutorial Project .................................... 21  
2.5 Building the Project ............................................... 22  
2.6 Programming the Device ........................................ 23  
2.7 Running the Program ............................................. 24  
2.8 Tutorial Program Operation .................................... 24

## Chapter 3. Create a New Project

3.1 Creating a New Project ........................................... 27

## Chapter 4. Hardware

4.1 Hardware Features ................................................ 37

## Appendix A. Board Layout and Schematics

A.1 Block Diagram ..................................................... 39  
A.2 Board Layout ...................................................... 40  
A.3 Board Schematics ................................................. 42
This chapter contains general information that will be useful to know before using the PIC32 USB Starter Kit II. Items discussed in this chapter include:

- Document Layout
- Conventions Used in this Guide
- Recommended Reading
- The Microchip Web Site
- Development Systems Customer Change Notification Service
- Customer Support
- Document Revision History

This document describes how to use the PIC32 Starter Kit II as a development tool to emulate and debug firmware on a target board. The user guide is composed of the following chapters:

- **Chapter 1. “Introduction”** provides a brief overview of the PIC32 USB Starter Kit II, highlighting its features and uses.
- **Chapter 2. “Tutorial”** provides step-by-step instructions for installing the PIC32 USB Starter Kit II and MPLAB® IDE to build and run the tutorial program on the PIC32 USB Starter Kit II.
- **Chapter 3. “Create a New Project”** provides step-by-step instructions for creating a new project using the MPLAB IDE and loading it onto the PIC32 USB Starter Kit II.
- **Chapter 4. “Hardware”** provides the hardware description of the PIC32 USB Starter Kit II.
- **Appendix A. “Board Layout and Schematics”** provides a block diagram, board layouts, and detailed schematics of the PIC32 USB Starter Kit II.
CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

## DOCUMENTATION CONVENTIONS

<table>
<thead>
<tr>
<th>Description</th>
<th>Represents</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Arial font:</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Italic characters</td>
<td>Referenced books</td>
<td><em>MPLAB® IDE User’s Guide</em></td>
</tr>
<tr>
<td></td>
<td>Emphasized text</td>
<td><em>...is the only compiler...</em></td>
</tr>
<tr>
<td>Initial caps</td>
<td>A window</td>
<td>the Output window</td>
</tr>
<tr>
<td></td>
<td>A dialog</td>
<td>the Settings dialog</td>
</tr>
<tr>
<td></td>
<td>A menu selection</td>
<td>select Enable Programmer</td>
</tr>
<tr>
<td>Quotes</td>
<td>A field name in a window or dialog</td>
<td>&quot;Save project before build&quot;</td>
</tr>
<tr>
<td>Underlined, italic text with right angle bracket</td>
<td>A menu path</td>
<td><em>File&gt;Save</em></td>
</tr>
<tr>
<td>Bold characters</td>
<td>A dialog button</td>
<td>Click <em>OK</em></td>
</tr>
<tr>
<td></td>
<td>A tab</td>
<td>Click the <em>Power</em> tab</td>
</tr>
<tr>
<td>Text in angle brackets &lt; &gt;</td>
<td>A key on the keyboard</td>
<td>Press &lt;Enter&gt;, &lt;F1&gt;</td>
</tr>
<tr>
<td><strong>Courier New font:</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plain Courier New</td>
<td>Sample source code</td>
<td>#define START</td>
</tr>
<tr>
<td>Filenames</td>
<td>autoexec.bat</td>
<td></td>
</tr>
<tr>
<td>File paths</td>
<td>C:\mcc18\h</td>
<td></td>
</tr>
<tr>
<td>Keywords</td>
<td>_asm, _endasm, static</td>
<td></td>
</tr>
<tr>
<td>Command-line options</td>
<td>-Opa+, -Opa-</td>
<td></td>
</tr>
<tr>
<td>Bit values</td>
<td>0, 1</td>
<td></td>
</tr>
<tr>
<td>Constants (in source code)</td>
<td>0xFF, ‘A’</td>
<td></td>
</tr>
<tr>
<td><strong>Italic Courier New</strong></td>
<td>A variable argument</td>
<td><em>file.o</em>, where <em>file</em> can be any valid filename</td>
</tr>
<tr>
<td>Optional arguments</td>
<td>mcc18 [options] file [options]</td>
<td></td>
</tr>
<tr>
<td>Choice of mutually exclusive arguments; an OR selection</td>
<td>errorlevel {0</td>
<td>1}</td>
</tr>
<tr>
<td>Ellipses...</td>
<td>Replaces repeated text</td>
<td><em>var_name [, var_name...]</em></td>
</tr>
<tr>
<td>Represents code supplied by user</td>
<td>void main (void) { ... }</td>
<td></td>
</tr>
</tbody>
</table>
RECOMMENDED READING

This user’s guide describes how to use the PIC32 USB Starter Kit II. The following Microchip documents are available and recommended as supplemental reference resources.

Release Notes for PIC32 Starter Kit

For the latest information on the PIC32 USB Starter Kit II, open PIC32 USB Starter Kit II Release Notes.htm located in either the root directory of the PIC32 USB Starter Kit II CD or (default):

C:\Microchip Starter Kits\PIC32 Starter Kits\documentation

The file generally contains the most current update information, as well as any issues that may not have been available when this user’s guide was published.

PIC32 Data Sheet (DS61143)

Consult this document for detailed information on PIC32 32-bit devices. Reference information found in this data sheet includes:

- Device memory map
- Device pinout and packaging details
- Device electrical specifications
- List of peripherals included on the device

MPLAB® C Compiler for PIC32 User’s Guide (DS51686)

This document, formerly the MPLAB C32 C Compiler for PIC32 User’s Guide, details the use of Microchip’s MPLAB C Compiler for PIC32 to develop an application.

MPLAB® IDE User’s Guide (DS51519)

Consult this document for more information pertaining to the installation and implementation of the MPLAB IDE software, as well as the MPLAB Editor and MPLAB SIM Simulator software that are included with it.

Universal Serial Bus Specification and Associated Documents

The Universal Serial Bus is defined by the USB 2.0 specification and its associated supplements and class-specific documents. These documents are available from the USB Implementers Forum. See their website at http://www.usb.org.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at http://www.microchip.com. This web site makes files and information easily available to customers. Accessible by most Internet browsers, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip consultant program member listings
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listings of seminars and events; and listings of Microchip sales offices, distributors and factory representatives
DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, access the Microchip web site at http://www.microchip.com, click Customer Change Notification and follow the registration instructions.

The Development Systems product group categories are:

- **Compilers** – The latest information on Microchip C compilers and other language tools. These include the MPLAB C18 and MPLAB C30 C compilers, and MPLAB C Compiler for PIC32; ASM32, MPASM™ and MPLAB ASM30 assemblers; MPLINK™, and MPLAB LINK30, MPLAB LINK32 object linkers; and MPLIB™ and MPLAB LIB30 object librarians.

- **Emulators** – The latest information on Microchip in-circuit emulators. This includes the MPLAB REAL ICE™ and MPLAB ICE 2000 in-circuit emulators.

- **In-Circuit Debuggers** – The latest information on the Microchip in-circuit debuggers. This includes the MPLAB ICD 3 and PICkit™ 2.

- **MPLAB IDE** – The latest information on Microchip MPLAB IDE, the Windows® Integrated Development Environment for development systems tools. This list is focused on the MPLAB IDE, MPLAB IDE Project Manager, MPLAB Editor and MPLAB SIM simulator, as well as general editing and debugging features.

- **Programmers** – The latest information on Microchip programmers. These include the MPLAB PM3 device programmer and the PICSTART® Plus, PICkit™ 1 and PICkit 2 development programmers.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Field Application Engineer (FAE)
- Technical Support

Customers should contact their distributor, representative or field application engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com
DOCUMENT REVISION HISTORY

Revision A (November 2009)

This is the initial release of the PIC32 USB Starter Kit II User’s Guide.
Chapter 1. Introduction

Thank you for purchasing the Microchip Technology PIC32 USB Starter Kit II. The board included in the starter kit provides a low-cost, modular development system for Microchip’s line of 32-bit microcontrollers.

The starter kit comes preloaded with demonstration software for the user to explore the new features of the PIC32. It is also expandable through a modular expansion interface, which allows the user to extend its functionality. The PIC32 USB Starter Kit II also supplies on-board circuitry for full debug and programming capabilities.

This chapter covers the following topics:
• Kit Contents
• PIC32 Functionality and Features

The preprogrammed example code on the PIC32 MCU is available via download from the Microchip web site at http://www.microchip.com. All project files have been included so that the code may be used directly to restore the PIC32 MCU on the starter kit to its original state (i.e., if the sample device has been reprogrammed with another program) or so you can use the tutorial code as a platform for further experimentation. Refer to 2.2 “Installing the PIC32 USB Starter Kit II Software” for download and installation instructions.

1.1 KIT CONTENTS

The PIC32 USB Starter Kit II contains the following items:
• PIC32 USB Starter Kit II development board
• USB Mini-B to full-sized A cable – USB debug cable to debug and power the board
• USB Micro-B to full-sized A cable – PIC32 USB cable to communicate with the PIC32 USB port

If you are missing any part of the kit, contact a Microchip sales office for assistance. A list of Microchip offices for sales and service is provided on the back page of this document.
1.2 PIC32 FUNCTIONALITY AND FEATURES

Representations of the layout of the PIC32 USB Starter Kit II are shown in Figure 1-1 and Figure 1-2.

The top assembly of the board includes these key features, as indicated in Figure 1-1:

1. PIC32MX795F512L 32-bit microcontroller.
2. Green power-indicator LED.
3. On-board crystal for precision microcontroller clocking (8 MHz).
4. USB connectivity for on-board debugger communications.
5. Orange debug indicator LED.
6. Three push button switches for user-defined inputs.
7. Three user-defined indicator LEDs.
8. USB Type A receptacle connectivity for PIC32 Host-based applications.
9. HOST mode power jumper.

Note: When running USB device applications, open the jumper JP2 to prevent possibly back-feeding voltage onto the VBUS from one port on the host to another (or from one host to another).
The bottom assembly of the board includes these key features, as indicated in Figure 1-2:

1. PIC32MX440F512H USB microcontroller for on-board debugging.
2. Regulated +3.3V power supply for powering the starter kit via USB or expansion board.
3. Connector for various expansion boards.
4. USB Host and OTG power supply for powering PIC32 USB applications.
5. USB Type Micro-AB receptacle for OTG and USB device connectivity for PIC32 OTG/device-based applications.

FIGURE 1-2: PIC32 USB STARTER KIT II LAYOUT (UNDERSIDE)
Table 1-1 shows the 100-pin to J2 connector serial communication mapping for the key digital modules available on the PIC32 device.

Serial communication module pins are multiplexed. These pins can be used for a single serial communication module or can be split between two serial communication modules. For example, four pins can be selected for the UART module with flow control, or the UART module can be selected without flow control, which uses only two pins, leaving two pins available for use by the I²C™, SPI, or ECAN™ modules.

**TABLE 1-1: J2 CONNECTOR MAP FOR SERIAL COMMUNICATIONS**

<table>
<thead>
<tr>
<th>PIC32 Pin</th>
<th>J2 Connector</th>
<th>UARTA</th>
<th>UARTB</th>
<th>I2CA</th>
<th>SPIA</th>
<th>ECAN™</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>45</td>
<td>U2ARTS</td>
<td>U2BTX</td>
<td></td>
<td>SCK2A</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>47</td>
<td>U2ARX</td>
<td>—</td>
<td>SDA2A</td>
<td>SDI2A</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>49</td>
<td>U2ATX</td>
<td>—</td>
<td>SCL2A</td>
<td>SDO2A</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>51</td>
<td>U2ACTS</td>
<td>U2BRX</td>
<td></td>
<td>SS2A</td>
<td></td>
</tr>
<tr>
<td>39</td>
<td>106</td>
<td>U3ARTS</td>
<td>U3BTX</td>
<td>—</td>
<td>SCK3A</td>
<td>AC1TX</td>
</tr>
<tr>
<td>40</td>
<td>108</td>
<td>U3ACTS</td>
<td>U3BRX</td>
<td></td>
<td>SS3A</td>
<td>AC1RX</td>
</tr>
<tr>
<td>47</td>
<td>94</td>
<td>U1ACTS</td>
<td>U1BRX</td>
<td>—</td>
<td>SS1A</td>
<td></td>
</tr>
<tr>
<td>48</td>
<td>92</td>
<td>U1ARTS</td>
<td>U1BTX</td>
<td>—</td>
<td>SCK1A</td>
<td></td>
</tr>
<tr>
<td>49</td>
<td>110</td>
<td>U3ARX</td>
<td>—</td>
<td>SDA3A</td>
<td>SDI3A</td>
<td></td>
</tr>
<tr>
<td>50</td>
<td>112</td>
<td>U3ATX</td>
<td>—</td>
<td>SCL3A</td>
<td>SDO3A</td>
<td></td>
</tr>
<tr>
<td>52</td>
<td>88</td>
<td>U1ARX</td>
<td>—</td>
<td>SDA1A</td>
<td>SDI1A</td>
<td></td>
</tr>
<tr>
<td>53</td>
<td>90</td>
<td>U1ATX</td>
<td>—</td>
<td>SCL1A</td>
<td>SDO1A</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 2. Tutorial

This chapter is a self-paced tutorial to get you started using the PIC32 USB Starter Kit II. Items discussed in this chapter include:

- Host Computer Requirements
- Installing the PIC32 USB Starter Kit II Software
- Using the PIC32 USB Starter Kit II Out of the Box
- Starting the Tutorial Project
- Building the Project
- Programming the Device
- Running the Program
- Tutorial Program Operation

2.1 HOST COMPUTER REQUIREMENTS

To communicate with and program the starter kit, the following hardware and software requirements must be met:

- PC-compatible system
- Two available USB ports on PC or powered USB hub
- Microsoft Windows® XP® or Windows Vista® operating system (the PIC32 USB Starter Kit II has not been tested on the Windows NT® and Windows 2000® operating systems).
2.2 INSTALLING THE PIC32 USB STARTER KIT II SOFTWARE

As a USB device, the starter kit board requires very little effort to install; most of the work is done by the operating system. Begin by closing all applications.

2.2.1 Install the Tools and Projects

1. Insert the PIC32 Starter Kit CD into your CD-ROM drive and click the Install from CD menu option. If the installation application does not automatically start, navigate to the files on the CD and open setup.exe.

   The following window appears:

   FIGURE 2-1: INSTALLING THE PIC32 STARTER KIT BOARD

   ![INSTALLING THE PIC32 STARTER KIT BOARD](image)

2. Reboot your system when prompted to do so.

   Note: The dialog also provides an option to check the Microchip web site for newer versions of the starter kit software.

2.2.2 View the Getting Started Tutorial

Perform the following steps to view the tutorial:

1. After your computer has rebooted, the Getting Started Tutorial menu opens.
2. View the tutorial instructions for connecting to the starter kit board and running the tutorial project.

If you performed the installation steps as you followed along in the Getting Started tutorial, skip to Section 2.4 “Starting the Tutorial Project” on page 21.

If you did not, continue to the next page for instructions about how to connect the board and install the device driver.
2.2.3 Connect the Starter Kit Board

Using the supplied USB cable, connect the board to an open USB port on your computer. (A USB hub that is not bus-powered can also be used.) Connect the other end of the cable into the USB connector on the starter kit board.

Check the board: the green power LED D3 should be lit. If it is not, check the connections at the port, hub and board.

2.2.4 Install the USB Device Driver

**Note:** The USB driver installation steps described here refer specifically to installing the driver on a Microsoft Windows XP operating system.

Perform the following steps to install the USB device driver:

1. When the USB cable is connected, the “Found New Hardware Wizard” dialog box opens, as shown in Figure 2-2. When asked whether to install the software automatically or install from a list or specific location, select “Install software automatically” and then click Next.

**FIGURE 2-2: FOUND NEW HARDWARE WIZARD**

![Found New Hardware Wizard](image)

Welcome to the Found New Hardware Wizard

The wizard helps you install software for:

PIC32 Starter Kits

If your hardware came with an installation CD or floppy disk, insert it now.

What do you want the wizard to do?

- Install the software automatically [Recommended]
- Install from a list or specific location [Advanced]

Click Next to continue.
2. As shown in Figure 2-3, the next dialog box tracks the wizard as it searches for the device. (This activity may take several seconds.) When it is done, click Next.

FIGURE 2-3: HARDWARE WIZARD – SEARCHING FOR DEVICE

3. If prompted to select a driver, select mp32mxsk.inf, as shown in Figure 2-4. Click Next to continue.

FIGURE 2-4: HARDWARE WIZARD – SELECTING THE DRIVER
4. If prompted with a dialog box for Windows Logo testing, as shown in Figure 2-5, click **Continue Anyway**.

**FIGURE 2-5: WINDOWS® LOGO TESTING**

![Hardware Installation dialog box](image)

The software you are installing for this hardware:

PIC32 Starter Kits

has not passed Windows Logo testing to verify its compatibility with Windows XP. [Tell me why this testing is important.]

Continuing your installation of this software may impair or destabilize the correct operation of your system either immediately or in the future. Microsoft strongly recommends that you stop this installation now and contact the hardware vendor for software that has passed Windows Logo testing.

[Continue Anyway] [STOP Installation]

5. The next window (Figure 2-6) indicates that the installation of the software for the starter kit is complete. Click **Finish**.

**FIGURE 2-6: COMPLETING DEVICE DRIVER INSTALLATION**

![Found New Hardware Wizard](image)

Completing the Found New Hardware Wizard

The wizard has finished installing the software for:

PIC32 Starter Kits

Click Finish to close the wizard.

[Back] [Finish] [Cancel]
2.3 USING THE PIC32 USB STARTER KIT II OUT OF THE BOX

Install the software before connecting the board to the host PC. The PIC32 USB Starter Kit II board may be used directly from the box as a demonstration board for the PIC32 device. The PIC32 is preprogrammed with the classic “Simon Says” game (simon_says_demo.hex) in the PIC32MX795F512L device and is ready for immediate use.

2.3.1 How to Play the Game

When the USB debug cable is plugged into the starter kit’s Mini-B (debug) receptacle, the three LEDs start blinking to indicate the start of a new game. Begin the game by pressing one of the switches, SW1-SW3, to choose the level of game difficulty. SW3 is the easiest, SW1 is the hardest. The goal is to imitate the light patterns as long as you can, without getting frazzled. Ultimately, you will make a mistake and all of the LEDs will light up to signal the end of the game. After a brief pause, you can press any switch to start a new game.

If you launch MPLAB IDE and connect to the starter kit while the game is running, the game will stop. Further, if you perform a debug or program operation from MPLAB IDE, the demo application will be replaced with the current MPLAB IDE project application. However, the game can be reloaded onto the starter kit by opening the file, simon_says_demo.mcw, from the following location:

[install directory]\PIC32 Starter Kits\simon_says_demo

The preprogrammed example code on the PIC32 has been included in the PIC32 USB Starter Kit II demo-projects download file, which is available from the Microchip web site (www.microchip.com). All project files have been included so that the code may be used directly to restore a PIC32 to its original state (i.e., if the sample device has been reprogrammed with another program), or so you can use the tutorial code as a platform for further experimentation.
2.4 STARTING THE TUTORIAL PROJECT

1. Connect the starter kit to the host PC and click the MPLAB IDE icon on your computer desktop. Select File>Open Workspace... from the menu bar and browse to the tutorial project file:

   [install directory]\PIC32 Starter Kits\usb_sk_hid_mouse_device_demo

   or browse to the file path that you used when you installed MPLAB IDE.

   The pane on the left of the MPLAB IDE interface displays project files, the ‘.c’, ‘.h’ and ‘.a’ (library) files that are used to build an application. The project files are organized by type into folders.

2. Select Debugger>Select Tool>PIC32 Starter Kit from the menu bar. “Starter Kit Found” should appear in the “Output” pane of the MPLAB IDE interface. If not, check the driver installation, as well as the connections between the hardware and the PC.

FIGURE 2-7: MPLAB® IDE WORKSPACE
2.5 BUILDING THE PROJECT

From the menu bar of the main MPLAB IDE window, select Project>Make. The build Output window appears, as shown in Figure 2-8.

Observe the progress of the build. When the “BUILD SUCCEEDED” message appears, you are ready to program the device.

FIGURE 2-8: BUILD OUTPUT WINDOW
2.6 PROGRAMMING THE DEVICE

2.6.1 Program the Device

1. Click the Program All Memories icon on the Program Device Tool Bar, as shown in Figure 2-9.

FIGURE 2-9: PROGRAM DEVICE TOOL BAR

2. A Programming Warning window, shown in Figure 2-10, opens to warn you about overwriting the memory. Click Yes.

FIGURE 2-10: PROGRAMMING WARNING WINDOW

3. The Output window, shown in Figure 2-11, tracks the progress of the output. A “Done” entry indicates that the programming of the device is complete.

FIGURE 2-11: OUTPUT WINDOW
2.7 RUNNING THE PROGRAM

Either select Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon (the turquoise triangle) on the Debug Tool Bar, shown in Figure 2-12, to run the new program.

FIGURE 2-12: DEBUG WINDOW

2.8 TUTORIAL PROGRAM OPERATION

The USB Human Interface Device (HID) mouse tutorial project demonstrates a simple USB peripheral device by emulating a mouse. Make the following connections to run the mouse demo:

1. Move jumper JP2 to the open position.
2. Use the USB debug cable (Mini-B to A) to attach the board’s debug connector J1 to the first USB port of the host PC. The board’s power source comes from the debugger connection.
3. Use the USB Micro-B to full-sized A cable to attach the board’s J5 connector (type Micro-AB receptacle) to the second USB port of the host PC.

Note: For the HID mouse demo (and all other USB device demos), the JP2 jumper should be open to prevent the possibility of back-feeding voltage onto the VBUS from one port on the host to another (or from one host to another).

After a pause, the PIC32 USB Starter Kit II will enumerate as a standard mouse HID, using drivers built into the host’s operating system. The successful completion of this process is usually accompanied by a “bing-bong” tone from the host PC. The output window will display a message indicating that the demo is running, as shown in Figure 2-13.

FIGURE 2-13: OUTPUT WINDOW
To move the mouse cursor, press the button switches on the starter kit. Table 2-1 shows the action associated with each button.

**TABLE 2-1: BUTTONS FOR CURSOR MOVEMENT**

<table>
<thead>
<tr>
<th>Button Pressed</th>
<th>Mouse Cursor Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW1</td>
<td>Moves Cursor Down</td>
</tr>
<tr>
<td>SW2</td>
<td>Moves Cursor to Right</td>
</tr>
<tr>
<td>SW1 and SW3</td>
<td>Moves Cursor Up</td>
</tr>
<tr>
<td>SW2 and SW3</td>
<td>Moves Cursor Left</td>
</tr>
</tbody>
</table>

To disable the HID mouse demo, disconnect the host PC from the Micro-AB receptacle on the starter kit. The host PC usually plays a reverse “bong-bing” tone to indicate the successful disconnection of the peripheral device.
Chapter 3. Create a New Project

This chapter explains how to create a new project. Items discussed in this chapter include:

- Creating a New Project
- Building the Project
- Programming the Device
- Running the Program

After completing this chapter, you should be able to accomplish the following tasks:

- Create a project using the Project Wizard
- Assemble and link the code, and set the Configuration bits
- Set up the MPLAB IDE to use the PIC32USB Starter Kit II
- Program the chip and run the program

3.1 CREATING A NEW PROJECT

The first step is to create a project and a workspace in the MPLAB IDE. Typically, there is a single project per workspace. A project contains the files needed to build an application (i.e., source code, header files, library, etc.), and their corresponding build options. A workspace contains one or more projects, information on the selected device, debug/programmer tool, and MPLAB IDE configuration settings.

MPLAB IDE contains a Project Wizard to help create a new project.

You will perform the following tasks as you create a new project:

Task 1: Select a Device ......................................................... page 28
Task 2: Select the Language Toolsuite ............................... page 29
Task 3: Name Your Project .................................................... page 30
Task 4: Add Files to Your Project ......................................... page 31
Task 5: Confirm the Configuration Settings ........................... page 32
Task 6: Build the Project ........................................................ page 33
Task 7: Program the Device .................................................... page 34
Task 8: Run the Program ........................................................ page 35
3.1.1 Task 1: Select a Device

1. Start MPLAB IDE.
2. Select File>Close Workspace on the menu bar, to close any open workspace.
3. Select Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is displayed, as shown in Figure 3-1.

FIGURE 3-1: SELECTING THE DEVICE

5. From the “Device” drop-down list, select “PIC32MX795F512L”.
6. Click Next. The Project Wizard Step Two: dialog box opens, as shown in Figure 3-2.
3.1.2 **Task 2: Select the Language Toolsuite**

1. From the “Active Toolsuite” drop-down list, select “Microchip PIC32 C Compiler Toolsuite”. The toolsuite includes the compiler, assembler and linker that will be used. If the PIC32 compiler option is not available, check the “Show all installed toolsuites” box.

2. Click **Next** to continue. The Project Wizard Step Three: dialog opens, as shown in Figure 3-3.
3.1.3 Task 3: Name Your Project

1. In the “Create New Project File” field, type C:\MyProject\BlinkLED.
2. Click Next and OK to continue. The Project Wizard Step Four: dialog opens, as shown in Figure 3-4.
3.1.4 Task 4: Add Files to Your Project

This window can be skipped, since no `.c` files have been created.

1. Click **Next** to continue.
2. Click **Finish** on the summary screen. A project and workspace have been created in the MPLAB IDE.
   
   BlinkLED.mcw is the workspace file and BlinkLED.mcp is the project file.
3. Select **File>**New from the menu bar to create a new file. A new file is created.
4. Select **File>**Save As... and save this file as 'BlinkLED.c' in the same folder, in this case, the C:\MyProject folder.
5. Now copy the source code provided in Example 3-1 to the BlinkLED.c file. The source code file is located in the PIC32 USB Starter Kit II directory:

   [install directory]\PIC32 Starter Kits\Blink_Leds

### EXAMPLE 3-1: PROJECT SOURCE CODE

```c
#include <plib.h> // Adds support for PIC32 Peripheral Library functions and macros

void Delay(unsigned int count)
{
    while(--count);
}

int main(void)
{
    /* LED setup - Turn off leds before configuring the IO pin as output */
    mPORTDClearBits(BIT_0 | BIT_1 | BIT_2); // same as LATDCLR = 0x0007

    /* Set RD0, RD1 and RD2 as outputs */
    mPORTDSetPinsDigitalOut(BIT_0 | BIT_1 | BIT_2 ); // same as TRISDCLR = 0x0007

    /* endless loop */
    while(1)
    {
        Delay(200000);
        mPORTDToggleBits(BIT_0); // toggle LED0 (same as LATDINV = 0x0001)

        Delay(200000);
        mPORTDToggleBits(BIT_1); // toggle LED1 (same as LATDINV = 0x0002)

        Delay(200000);
        mPORTDToggleBits(BIT_2); // toggle LED2 (same as LATDINV = 0x0004)
    }
    return 0;
}
```

6. In the Project window, right click the **Source Files** folder. Select “Add Files” and choose BlinkLED.c to add the file to the source directory, as shown in Figure 3-5.

**Note:** The Debug Print Library is automatically included by defining PIC32_STARTER_KIT as a compile time option (**Project>**Build Options>**Project>**MPLAB PIC32 Compiler>Preprocessor Macros), and including the file, Plib.h, in the source file.
7. Select **Debugger> Select Tool > PIC32 Starter Kit** from the menu bar, for the Target board.

**Note:** Make sure that the starter kit is connected to your PC.

### 3.1.5 Task 5: Confirm the Configuration Settings

Select **Configure> Configuration Bits** to confirm that the configuration settings are correct. Typical configuration settings for the starter kit are shown in Figure 3-6.

**Note:** The “Configuration Bits set in code” check box must be clear (not checked) if the configuration bits are set via this window and not in the code. The configuration settings can also be embedded in the source file. See the "**MPLAB C Compiler for PIC32 User’s Guide**" (DS51686) for information.
3.1.6 Task 6: Build the Project

1. Select Project>Make from the menu bar of the main MPLAB IDE window. The build Output window appears, as shown in Figure 3-7.
2. Observe the progress of the build. When the “BUILD SUCCEEDED” message displays, you are ready to program the device.
3.1.7 Task 7: Program the Device

1. Click the Program All Memories icon on the Program Device Tool Bar, as shown in Figure 3-8.

A Programming Warning window opens to warn you about overwriting the memory, as shown in Figure 3-9.

2. Click Yes.
The Output window, shown in Figure 3-10, tracks the progress of the output. A “Done” entry signals that the programming of the device is complete.

**FIGURE 3-10: OUTPUT WINDOW**

3.1.8 Task 8: Run the Program

Select **Debugger>Run** from the menu bar of the MPLAB IDE or click the Run icon (the turquoise triangle) on the Debug Tool Bar, as indicated in Figure 3-11, to run the new program.

**FIGURE 3-11: RUN THE PROGRAM**

The starter kit LEDs blink to indicate that the program is running successfully.
Chapter 4. Hardware

This chapter describes the hardware features of the PIC32 USB Starter Kit II.

4.1 HARDWARE FEATURES

The key features of the PIC32 USB Starter Kit II are listed below. They are presented in the order given in Section 1.2 “PIC32 Functionality and Features”. You can refer to Figure 1-1 for their locations on the board.

4.1.1 Processor Support

The PIC32 USB Starter Kit II is designed with a permanently mounted (i.e., soldered) PIC32MX795F512L processor.

4.1.2 Power Supply

There are two ways to supply power to the PIC32 USB Starter Kit II:

- USB bus power connected to USB debug connector J1.
- An external application board with a regulated DC power supply that provides +5V can be connected to the J2 application board connector that is provided on the bottom side of the board.

One green LED (D3) is provided to show that the PIC32 microcontroller is powered up.

4.1.3 Debug USB Connectivity

The PIC32 USB Starter Kit II includes a PIC32MX440F512H USB microcontroller that provides debugger connectivity over USB. The PIC32MX440F512H is hard wired to the PIC32 device to provide two types of protocol translation:

- I/O pins of PIC32MX440F512H to the ICSP™ pins of the PIC32
- I/O pins of PIC32MX440F512H to the JTAG pins of the PIC32

The PIC32 USB Starter Kit II currently uses the JTAG pins of the PIC32 device for programming and debugging.

4.1.4 PIC32 USB Connectivity

There are three possible ways to connect to the PIC32 USB microcontroller:

HOST Mode

Connect the device to the Type A connector J4, located on the top side of the starter kit. If using the Debug USB port to power the Host port, install jumper JP2 to short the back-power prevention diode. Note that a maximum of ~400 mA can be supplied from the Debug USB port to the Host port using this method.

If the full 500 mA supply is needed, an external supply must be connected to the application board and jumper JP2 must be removed to prevent back-powering the Debug USB port.
DEVICE Mode

First, connect the debug Mini-B USB cable to port J1. Next, connect the starter kit to the host using a cable with a Type-B Micro plug to the starter kit’s Micro A/B port J5, located on the bottom side of the starter kit. The other end of the cable must have a Type-A plug. Connect it to a USB host. Jumper J2 should be removed.

OTG Mode

Connect the starter kit to the OTG device using an OTG Micro A/B cable to the Micro A/B port J5, located on the bottom side of the starter kit. The starter kit provides an on-board power supply capable of providing 120 mA Max. This supply is controlled by the PIC32MX795F512L microcontroller. Jumper J2 should be removed.

4.1.5 Switches

Push button switches provide the following functionality:
- SW1: Active-low switch connected to RD6
- SW2: Active-low switch connected to RD7
- SW3: Active-low switch connected to RD13

The switches do not have any debounce circuitry and require the use of internal pull-up resistors; this allows you to investigate software debounce techniques. When idle, the switches are pulled high (+3.3V). When pressed, they are grounded.

4.1.6 LEDs

The RD0 through RD2 LEDs are connected to PORTD of the processor. The PORTD pins are set high to light the LEDs.

4.1.7 Oscillator Options

The installed microcontroller has an oscillator circuit connected to it. The main oscillator uses an 8 MHz crystal (Y2) and functions as the controller’s primary oscillator. Use of an external crystal is required to develop USB applications. The USB specification dictates a frequency tolerance of +/- 0.25% for full speed. Non-USB applications can use the internal oscillators. The starter kit also has provisions for an external secondary oscillator (Y3); however, this is not populated.

The PIC32MX440F512H is independently clocked and has its own 8 MHz crystal (Y1).

4.1.8 120-Pin Modular Expansion Connector

The PIC32 USB Starter Kit II has been designed with a 120-pin modular expansion interface, which allows the board to provide basic generic functionality now, and easy extendability to new technologies as they become available.

TABLE 4-1: STARTER KIT CONNECTOR PART NUMBERS

<table>
<thead>
<tr>
<th>Connector</th>
<th>HIROSE Electric PN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starter Kit Connector</td>
<td>FX10A-120P/12-SV1(71)</td>
</tr>
<tr>
<td>Application Board Connector</td>
<td>FX10A-120S/12-SV(71)</td>
</tr>
</tbody>
</table>
Appendix A. Board Layout and Schematics

A.1 BLOCK DIAGRAM

FIGURE A-1: HIGH-LEVEL BLOCK DIAGRAM OF THE PIC32 USB STARTER KIT II

Note 1: From Debugger USB Port
A.2 BOARD LAYOUT

FIGURE A-2: PIC32 USB STARTER KIT II LAYOUT (TOP ASSEMBLY)
FIGURE A-3: PIC32 USB STARTER KIT II LAYOUT (BOTTOM ASSEMBLY)
A.3 BOARD SCHEMATIC

FIGURE A-4: PIC32 USB STARTER KIT II SCHEMATIC (SHEET 1 OF 3)
FIGURE A-5: PIC32 USB STARTER KIT II SCHEMATICS (SHEET 2 OF 3)
Index

A
Active Toolsuite........................................................ 29

B
Building the tutorial project....................................... 22

C
Connect the Starter Kit Board .................................. 17
Create a Project
  Build the Project................................................ 33
  Configuration settings ....................................... 32
Customer Change Notification Service ...................... 8
Customer Support...................................................... 8

D
Documentation
  Conventions................................................................ 6

H
Hardware Features
  LEDs ........................................................................ 37, 38
  Oscillator Options ................................................. 38
  PICtail Plus Card Edge Connectors .................. 38
  Power Supply.................................................... 37
  Processor Support ............................................... 37
  Switches .................................................................. 38
  USB Connectivity.................................................. 37
Host Computer Requirements............................... 15

I
Installing the USB Device Driver.............................. 17
Internet Address.......................................................... 7

L
Language Toolsuite .................................................. 29
LEDs
  Power.................................................................... 17

M
Microchip Internet Web Site ...................................... 7
MPLAB IDE Simulator, Editor User’s Guide............ 7

P
PIC32
  Layout
    32-bit microcontroller ..................................... 12
    Connector for expansion boards ...................... 12
    Debug indicator LED.................................... 12
    Expansion board connector ........................... 13
    HOST mode power jumper .............................. 12
    On-board crystal .......................................... 12
    Power supply ............................................. 13
    Power-indicator LED...................................... 12
    Switches ..................................................... 12
    USB connectivity ......................................... 12
    USB Host and OTG power supply ..................... 13
    USB microcontroller .................................... 13
    USB Type A receptacle ................................. 12
    USB Type Micro-AB receptacle ....................... 13
    User-defined LEDs ....................................... 12
PIC32 USB Starter Kit II Out of the box ............ 20
Preprogrammed example code ............................. 20
Project Wizard......................................................... 27

R
Readme........................................................................ 7
Restore PIC32 original programming.................. 20

S
Starter Kit Board
  Block Diagram................................................... 39
  Connecting........................................................ 17
  Installing device driver ..................................... 17
Starter Kit Layout
  Bottom Assembly ............................................ 13, 41
  Top Assembly .................................................. 12, 40
Starter Kit Schematics
  Sheet 1 of 3.................................................... 42
  Sheet 2 of 3.................................................... 43
  Sheet 3 of 3.................................................... 44

T
Tutorial Program Operation................................. 24
Tutorial Project
  Program operation ............................................. 24
  Programming the device .................................. 23
  Starting.......................................................... 21

U
USB
  Connectivity ...................................................... 37

W
WWW Address.......................................................... 7
## Worldwide Sales and Service

### AMERICAS

**Corporate Office**  
2355 West Chandler Blvd.  
Chandler, AZ 85224-6199  
Tel: 480-792-7200  
Fax: 480-792-7277  
Technical Support: [http://support.microchip.com](http://support.microchip.com)  
Web Address: [www.microchip.com](http://www.microchip.com)

**Atlanta**  
Duluth, GA  
Tel: 678-957-9614  
Fax: 678-957-1455

**Boston**  
Westborough, MA  
Tel: 774-760-0087  
Fax: 774-760-0088

**Chicago**  
Itasca, IL  
Tel: 630-285-0071  
Fax: 630-285-0075

**Cleveland**  
Independence, OH  
Tel: 216-447-0084  
Fax: 216-447-0083

**Dallas**  
Addison, TX  
Tel: 972-818-7423  
Fax: 972-818-2924

**Detroit**  
Farmington Hills, MI  
Tel: 248-538-2250  
Fax: 248-538-2260

**Kokomo**  
Kokomo, IN  
Tel: 765-864-8360  
Fax: 765-864-8387

**Los Angeles**  
Mission Viejo, CA  
Tel: 949-462-9523  
Fax: 949-462-9608

**Santa Clara**  
Santa Clara, CA  
Tel: 408-961-6444  
Fax: 408-961-6445

**Toronto**  
Mississauga, Ontario, Canada  
Tel: 905-673-0699  
Fax: 905-673-6509

### ASIA/PACIFIC

**Asia Pacific Office**  
Suites 3707-14, 37th Floor  
Tower 6, The Gateway  
Harbour City, Kowloon  
Hong Kong  
Tel: 852-2401-1200  
Fax: 852-2401-3431

**Australia - Sydney**  
Tel: 61-2-9868-6733  
Fax: 61-2-9868-6755

**China - Beijing**  
Tel: 86-10-8528-2100  
Fax: 86-10-8528-2104

**China - Chengdu**  
Tel: 86-28-8665-5511  
Fax: 86-28-8665-7889

**China - Hong Kong SAR**  
Tel: 852-2401-1200  
Fax: 852-2401-3431

**China - Nanjing**  
Tel: 86-25-8473-2460  
Fax: 86-25-8473-2470

**China - Qingdao**  
Tel: 86-532-8502-7355  
Fax: 86-532-8502-7205

**China - Shanghai**  
Tel: 86-21-5407-5533  
Fax: 86-21-5407-5066

**China - Shenyang**  
Tel: 86-24-2334-2829  
Fax: 86-24-2334-2393

**China - Shenzhen**  
Tel: 86-755-8203-2660  
Fax: 86-755-8203-1760

**China - Wuhan**  
Tel: 86-27-5980-5300  
Fax: 86-27-5980-5118

**China - Xiamen**  
Tel: 86-592-2388138  
Fax: 86-592-2388130

**China - Xian**  
Tel: 86-29-8833-7252  
Fax: 86-29-8833-7256

**China - Zhuhai**  
Tel: 86-756-3210040  
Fax: 86-756-3210049

**India - Bangalore**  
Tel: 91-80-3090-4444  
Fax: 91-80-3090-4080

**India - New Delhi**  
Tel: 91-11-4160-8631  
Fax: 91-11-4160-8632

**India - Pune**  
Tel: 91-20-2566-1512  
Fax: 91-20-2566-1513

**Japan - Yokohama**  
Tel: 81-45-471-6166  
Fax: 81-45-471-6122

**Korea - Daegu**  
Tel: 82-53-744-4301  
Fax: 82-53-744-4302

**Korea - Seoul**  
Tel: 82-2-554-7200  
Fax: 82-2-558-5932 or 82-2-558-5934

**Malaysia - Kuala Lumpur**  
Tel: 60-3-6201-9857  
Fax: 60-3-6201-9859

**Malaysia - Penang**  
Tel: 60-4-227-8870  
Fax: 60-4-227-4068

**Philippines - Manila**  
Tel: 63-2-634-9065  
Fax: 63-2-634-9069

**Singapore**  
Tel: 65-6334-8870  
Fax: 65-6334-8850

**Taiwan - Hsin Chu**  
Tel: 886-3-6578-300  
Fax: 886-3-6578-370

**Taiwan - Kaohsiung**  
Tel: 886-7-536-4818  
Fax: 886-7-536-4803

**Taiwan - Taipei**  
Tel: 886-2-2500-6610  
Fax: 886-2-2500-6012

**Thailand - Bangkok**  
Tel: 66-2-694-1351  
Fax: 66-2-694-1350

### EUROPE

**Austria - Wels**  
Tel: 43-7242-2244-39  
Fax: 43-7242-2244-393

**Denmark - Copenhagen**  
Tel: 45-4450-2828  
Fax: 45-4485-2829

**France - Paris**  
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-50-20-79

**Germany - Munich**  
Tel: 49-89-627-144-0  
Fax: 49-89-627-144-44

**Italy - Milan**  
Tel: 39-0331-742611  
Fax: 39-0331-466781

**Netherlands - Drunen**  
Tel: 31-416-690399  
Fax: 31-416-690340

**Spain - Madrid**  
Tel: 34-91-708-08-90  
Fax: 34-91-708-08-91

**UK - Wokingham**  
Tel: 44-118-921-5869  
Fax: 44-118-921-5820

03/26/09