Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip's Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
- Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip's code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights.
EU Declaration of Conformity

This declaration of conformity is issued by the manufacturer. The development/evaluation tool is designed to be used for research and development in a laboratory environment. This development/evaluation tool is not a Finished Appliance, nor is it intended for incorporation into Finished Appliances that are made commercially available as single functional units to end users under EU EMC Directive 2004/108/EC and as supported by the European Commission’s Guide for the EMC Directive 2004/108/EC (8th February 2010).

This development/evaluation tool complies with EU RoHS2 Directive 2011/65/EU.

For information regarding the exclusive, limited warranties applicable to Microchip products, please see Microchip’s standard terms and conditions of sale, which are printed on our sales documentation and available at www.microchip.com.

Signed for and on behalf of Microchip Technology Inc. at Chandler, Arizona, USA

Derek Carlson  
VP Development Tools

02-May-12

Date
Safety Notice

The safety notices and operating instructions provided should be adhered to, to avoid a safety hazard. If in any doubt, consult your supplier.

**WARNING** – This system must be earthed (grounded) at all times.

**WARNING** – The output terminals are NOT isolated from the incoming AC mains supply and may be at up to 410V with respect to ground, regardless of the input mains supply voltage applied. These terminals are live during operation AND for five minutes after disconnection from the supply. Do not attempt to access the terminals or remove the cover during this time.

**WARNING** – The unit may obtain power through the output terminals if these are connected to a rotating motor acting as a generator. If this is the case, then the previous warning also applies (i.e., the output terminals are live when connected to the generator and for five minutes after the generator has been stopped). Note that this case can arise even when the unit has been disconnected from the incoming AC mains supply.

**CAUTION** – The system should not be installed, operated, serviced or modified except by qualified personnel who understand the danger of electric shock hazards and have read and understood the user instructions. Any service or modification performed by the user is done at the user’s own risk and voids all warranties.

**CAUTION** – If a motor is connected to the output of this unit, the frame should be connected to the output protective ground terminal provided. Particular care should be taken to mechanically guard such a motor, bearing in mind that unexpected behavior is likely to result from the process of code development.

**CAUTION** – For continued protection against the risk of fire, replace the fuse with one of the same type only (i.e., Fast Act Fuse 15A/250V).

- The system is intended for evaluation and development purposes and should only be operated in a normal laboratory environment as defined by IEC 61010-1:2001
- Clean with a dry cloth only
- Operate flat on a bench, do not move during operation and do not block the ventilation holes
- The system should not be operated without all the supplied covers fully secured in place
- The system should not be connected or operated if there is any apparent damage to the unit
- The unit is designed to be connected to the AC mains supply via a standard non-locking plug. As the unit has no mains switch, this plug constitutes the means of disconnection from the supply and thus the user must have unobstructed access to this plug during operation.
# Table of Contents

Chapter 1. Introduction  
1.1 Overview .................................................................................................................. 15

Chapter 2. Getting Started  
2.1 Board Components .................................................................................................... 21  
2.2 User Interface ............................................................................................................. 22  
2.3 Connecting the System .............................................................................................. 23  
2.4 Power Sequences ....................................................................................................... 27

Chapter 3. Running the Demonstration

Chapter 4. Hardware  
4.1 Power Factor Correction (PFC) Stage Board .............................................................. 35  
4.2 Power Module Stage .................................................................................................. 40  
4.3 Electrical Specifications ........................................................................................... 49

Appendix A. Board Layout and Schematics

Appendix B. Debugging and Troubleshooting with MPLAB® 8  
B.1 Setting up an Application for Debugging ................................................................. 65  
B.2 Running the Application .......................................................................................... 66  
B.3 Debugging the Application ...................................................................................... 67  
B.4 Programming an Application .................................................................................. 69  
B.5 Determining Device Support and Reserved Resources ........................................ 70  
B.6 Troubleshooting ....................................................................................................... 70  
B.7 Settings Dialog and Info Tab .................................................................................... 70
Preface

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and documentation are constantly evolving to meet customer needs, so some actual dialogs and/or tool descriptions may differ from those in this document. Please refer to our web site (www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each page, in front of the page number. The numbering convention for the DS number is “DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. Select the Help menu, and then Topics to open a list of available on-line help files.

INTRODUCTION

This preface contains general information that will be useful to know before using the dsPICDEM™ MCHV-2 Development Board. Topics discussed in this preface include:

- Document Layout
- Conventions Used in this Guide
- Warranty Registration
- Recommended Reading
- The Microchip Web Site
- Development Systems Customer Change Notification Service
- Customer Support
- Document Revision History

DOCUMENT LAYOUT

This user’s guide describes how to use the dsPICDEM™ MCHV-2 Development Board. The document is organized as follows:

- **Chapter 1. “Introduction”** – This chapter introduces the dsPICDEM™ MCHV-2 Development Board and provides a brief overview of its features.
- **Chapter 2. “Getting Started”** – This chapter provides information on getting started with the dsPICDEM™ MCHV-2 Development Board.
- **Chapter 3. “Running the Demonstration”** – This chapter describes the demonstration software that is preloaded on the device that accompanies the dsPICDEM™ MCHV-2 Development Board.
- **Chapter 4. “Hardware”** – This chapter describes the hardware on the dsPICDEM™ MCHV-2 Development Board.
- **Appendix A. “Board Layout and Schematics”** – This appendix provides diagrams of the hardware layout, as well as schematic diagrams for the dsPICDEM™ MCHV-2 Development Board.
- **Appendix B. “Debugging and Troubleshooting with MPLAB® 8”** – This appendix provides debug and programming guidance for MPLAB 8 users.
CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

<table>
<thead>
<tr>
<th>DOCUMENTATION CONVENTIONS</th>
<th>Description</th>
<th>Represents</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arial font:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Italic characters</td>
<td>Referenced books</td>
<td><em>MPLAB® IDE User’s Guide</em></td>
<td><em>is the only compiler...</em></td>
</tr>
<tr>
<td></td>
<td>Emphasized text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initial caps</td>
<td>A window</td>
<td>the Output window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>A dialog</td>
<td>the Settings dialog</td>
<td></td>
</tr>
<tr>
<td></td>
<td>A menu selection</td>
<td>select Enable Programmer</td>
<td></td>
</tr>
<tr>
<td>Quotes</td>
<td>A field name in a window or dialog</td>
<td><em>“Save project before build”</em></td>
<td></td>
</tr>
<tr>
<td>Underlined, italic text with right angle bracket</td>
<td>A menu path</td>
<td><em>File&gt;Save</em></td>
<td></td>
</tr>
<tr>
<td>Bold characters</td>
<td>A dialog button</td>
<td>Click <em>OK</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>A tab</td>
<td>Click the <em>Power</em> tab</td>
<td></td>
</tr>
<tr>
<td>N'Rnnnn</td>
<td>A number in verilog format, where N is the total number of digits, R is the radix and n is a digit.</td>
<td>4'b0010, 2'hF1</td>
<td></td>
</tr>
<tr>
<td>Text in angle brackets &lt; &gt;</td>
<td>A key on the keyboard</td>
<td>Press <em>&lt;Enter&gt;, &lt;F1&gt;</em></td>
<td></td>
</tr>
<tr>
<td>Courier New font:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plain Courier New</td>
<td>Sample source code</td>
<td><em>#define START</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Filenames</td>
<td><em>autoexec.bat</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>File paths</td>
<td><em>c:\mcc18\h</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Keywords</td>
<td><em>_asm</em>, <em>_endasm</em>, <em>static</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Command-line options</td>
<td><em>-Opa+, -Opa-</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bit values</td>
<td>0, 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Constants</td>
<td><em>0xFF, ‘A’</em></td>
<td></td>
</tr>
<tr>
<td>Italic Courier New</td>
<td>A variable argument</td>
<td><em>file.o, where file can be any valid filename</em></td>
<td></td>
</tr>
<tr>
<td>Square brackets [ ]</td>
<td>Optional arguments</td>
<td><em>mcc18 [options] file [options]</em></td>
<td></td>
</tr>
<tr>
<td>Curly braces and pipe character: {</td>
<td>Choice of mutually exclusive arguments; an OR selection</td>
<td>*errorlevel {0</td>
<td>1}*</td>
</tr>
<tr>
<td>Ellipses...</td>
<td>Replaces repeated text</td>
<td><em>var_name [,..., var_name...]</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Represents code supplied by user</td>
<td><em>void main (void) { ... }</em></td>
<td></td>
</tr>
</tbody>
</table>
WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. Sending in the Warranty Registration Card entitles users to receive new product updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING

This user’s guide describes how to use the dsPICDEM™ MCHV-2 Development Board. The device-specific data sheets contain current information on programming the specific microcontroller or digital signal controller devices. Other useful documents are listed below. The following Microchip documents are available and recommended as supplemental reference resources:

MPLAB® C Compiler for PIC24 MCUs and dsPIC® DSCs User’s Guide (DS51284)

This comprehensive guide describes the usage, operation and features of Microchip’s MPLAB C compiler (formerly MPLAB C30) for use with 16-bit devices.

MPLAB® IDE User’s Guide (DS51519)

This user’s guide describes how to set up the MPLAB IDE software and use it to create projects and program devices.

MPLAB X IDE User’s Guide (DS52027)

This document describes how to setup the MPLAB X IDE software and use it to create projects and program devices.

MPLAB® Assembler, Linker and Utilities For PIC24 MCUs And dsPIC® DSCs User’s Guide (DS51317)

This user’s guide describes the usage, operation, and features of the MPLAB® Assembler for PIC24 MCUs and dsPIC® DSCs (formerly MPLAB ASM30), which produces relocatable machine code from symbolic assembly language for the PIC24 MCU and dsPIC DSC families of devices. The assembler is a Windows console application that provides a platform for developing assembly language code. The assembler is a port of the GNU assembler from the Free Software Foundation.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in the Readme subdirectory of the MPLAB IDE installation directory. The Readme files contain updated information and known issues that may not be included in this user’s guide.

dsPIC33EP256MC506 Plug-In Module (PIM) for Internal Op amp Configuration Information Sheet (DS52062)

This document provides device specific information for the dsPIC33EP256MC506 Internal Op amp configuration PIM.

To obtain any of these documents, visit the Microchip web site at www.microchip.com.
THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQs), technical support requests, online discussion groups, Microchip consultant program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.

To register, access the Microchip web site at www.microchip.com, click on Customer Change Notification and follow the registration instructions.

The Development Systems product group categories are:

- **Compilers** – The latest information on Microchip C compilers and other language tools. These include the MPLAB® C compiler; MPASM™ and MPLAB 16-bit assemblers; MPLINK™ and MPLAB 16-bit object linkers; and MPLIB™ and MPLAB 16-bit object librarians.
- **Emulators** – The latest information on the Microchip MPLAB REAL ICE™ in-circuit emulator.
- **In-Circuit Debuggers** – The latest information on the Microchip in-circuit debugger, MPLAB ICD 3.
- **MPLAB IDE** – The latest information on Microchip MPLAB IDE, the Windows® Integrated Development Environment for development systems tools. This list is focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager and general editing and debugging features.
- **Programmers** – The latest information on Microchip programmers. These include the MPLAB PM3 device programmer and the PICkit™ 3 development programmers.
CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support

Customers should contact their distributor, representative or field application engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (July 2012)

This is the initial released version of the document.
Chapter 1. Introduction

1.1 OVERVIEW

The Microchip dsPICDEM MCHV-2 Development Board is intended to aid the user in the rapid evaluation and development of a wide variety of motor control applications using PIC24 Microcontrollers (MCUs) and dsPIC® Digital Signal Controllers (DSCs). This development system is targeted to control Brushless DC (BLDC) motors, Permanent Magnet Synchronous Motors (PMSM), and AC Induction Motors (ACIM) in sensor or sensorless operation.

This flexible and cost-effective tool can be configured in different ways for use with Microchip’s specialized Motor Control devices. The dsPICDEM MCHV-2 Development Board is essentially a backward-compatible upgraded version of the dsPICDEM MCHV Development System. The dsPICDEM MCHV-2 Development Board is designed to support the PIC24F, PIC24E, dsPIC33F, and dsPIC33E Motor Control device families, and offers a mounting option to connect a generic 100-pin Plug-In Module (PIM).

The system has a three-phase power module device that contains the motor inverter and the gate driver’s circuitry. The circuit drives a BLDC, PMSM, or ACIM motor using different control techniques without requiring any additional hardware. It also has Power Factor Correction (PFC) circuitry in order to provide a full set of tools used in motor control applications. Figure 1-1 provides a photograph of the dsPICDEM MCHV-2. A block diagram that shows the main components of the system is provided in Figure 1-2.

The rated continuous output current from the inverter is 6.5A (RMS). This allows up to approximately 2 kVA output when running from a 208V to 230V single-phase input voltage in a maximum 30°C (85°F) ambient temperature environment. Therefore, the system is ideally suited for running a standard 3-Phase Induction Motor of up to 1.4 kW (1.8 HP) rating or a slightly higher rated industrial servo-motor. The power module is capable of driving other types of motors and electrical loads that do not exceed the maximum power limit and are predominantly inductive. Furthermore, single-phase loads can be driven using one or two of the inverter outputs.

The unit is capable of operating from 90V up to a maximum of 265V. A more detailed explanation of power limitations is provided in Chapter 4. “Hardware”.

**Note:** It is recommended to carefully read the hardware section mentioned above before attempting to use the system.
FIGURE 1-1: dsPICDEM™ MCHV-2 DEVELOPMENT BOARD

dsPICDEM MCHV-2 Development Board
(Part # DM330023-2)
FIGURE 1-2: SYSTEM BLOCK DIAGRAM

PFC Stage Board

- PFC Circuitry
- VAC Voltage Feedback
- VAC Zero Crossing
- PFC Current Feedback Circuitry
- Rectifier
- 3.3VA-3.3V
- 15V PSU
- EMI Choke, In-rush current protection, FUSE
- 90V-265V

Power Module Board

- VBUS
- PFC PWM
- PFC Fault
- PFC Feedback Signals
- 15V, 3.3V, A-3.3V
- 15V PSU
- 90V-265V
- Non-isolated ICSP™ connector
- Voltage Feedback Circuitry (Vbus and Motor)
- dsPIC® DSC or PIC24 MCU
- Matrix Board
- Alternative 3.3V/A3.3V
- Fault Circuitry
- Hall Sensors Circuitry
- Power Module
- MOTOR
- Hall Sensors
- Alternative 15V PSU
- Isolated User Interface
- RS-232/USB
- Starter Kit on Board
- POT, PB, RESET
- External Programmer/Debugger
- RX
- TX
- ICSP commands
- User Interface
- Matrix Board
- or on Board
1.1.1 Features

This section provides some of the key features of the dsPICDEM MCHV-2 Development Board.

Motor Control Interfaces:
- Three-phase inverter bridge with a power rating of 400V/6.5A (J17)
- Hall sensors/Quadrature Encoder Interface (QEI) for sensored motor control algorithms (J9)
- Phase voltage feedback for sensorless BLDC operation
- DC bus current sense resistor for single shunt vector control
- Phase current sense resistor for dual shunt vector control
- Overcurrent protection
- Support for PIC24 MCUs and dsPIC DSCs with internal op amps and comparators

Input/Output:
- One isolated push button (S1)
- Isolated reset push button (RESET)
- Isolated 10 kΩ potentiometer (POT1)
- LED indicators for PWM outputs
- Two LED indicators for debugging purposes (D2 and D19)

Isolated Communication Ports:
- UART communication via USB (J6)
- UART communication via RS-232 (J8)

Built-In Isolated Programmer/Debugger (J20):
- Starter Kit on Board programmer/debugger (daughter board)

Power Supply Connectors:
- Power Tab Fast-On connectors (BP1 and BP2) for the power stage
- Auxiliary 24V power input connector (J15) for the PIC24 MCU or dsPIC DSC device and low-power circuitry (non-populated)
- Auxiliary 15V and 3.3V regulators for regulating auxiliary power supply (non-populated)

Programming Connectors:
- ICSP™ connector for programming a PIC24 MCU or dsPIC DSC device (J18), non-isolated
- ICSP connector for programming the PIC18LF2450 USB module to the UART Bridge (J1), isolated
- ICSP connector for programming the Starter Kit on Board Programmer/Debugger, isolated (J1)
Power Factor Corrector:
- Maximum input voltage 90 VAC-265 VAC
- Current Feedback circuitry
- VAC input voltage sensing
- Zero-crossing detection
- DC bus sensing
- Overcurrent protection (The maximum power available is specified in Section 4.3 “Electrical Specifications”.)

Built-In Power Supplies:
- 15V power supply, maximum power available 11W
- 3.3V power supply, maximum power available 2W

Additional Protection Circuitry:
- 250 VAC/15A fuse
- In-rush current limiter
- EMI filter
Chapter 2. Getting Started

2.1 BOARD COMPONENTS

The dsPICDEM MCHV-2 Development Board consists of two stages:

• PFC Stage
  The first stage is integrated by the Power Factor Correction (PFC) circuitry, the full-bridge rectifier, the 15V power supply, and the 3.3V power supply.

• Power Module Stage
  The second stage is the power module board. This board contains the Plug-In Module (PIM) connector, the isolated user interface connectors, and the motor drive.

Figure 2-1 shows an interior view.

FIGURE 2-1: dsPICDEM™ MCHV-2 DEVELOPMENT BOARD ENCLOSURE VIEW
2.2 USER INTERFACE

The dsPICDEM MCHV-2 has the following components to interact with the user. Figure 2-2 shows a photograph of the front of the system.

- Input/Output Control Switches (Figure 2-2):
  - One isolated push button (S1)
  - Isolated reset push button (RESET)
  - Isolated 10 kΩ potentiometer (POT1)
  - LED indicators for PWM outputs
  - Two LED indicators for debugging purposes (D2 and D19 on the Power Module Board; not shown in Figure 2-2)

- PWM Outputs (Figure 2-2)
  - Enable and disable jumpers (J7)

- Isolated Communication Ports (Figure 2-2):
  - UART communication via USB (J6)
  - UART communication via RS-232 (J8)
  - Communication Ports Selector (J2, J3)

- Built-In Isolated Programmer/Debugger (Figure 2-2)
  - Starter Kit type programmer/debugger (J20)

- Motor Connectors (Figure 2-4):
  - Three-phase inverter bridge connector with a power rating of 400V/6.5A (J17)
  - Hall sensors/Quadrature encoder interface for sensored motor control algorithms (J9)

- Power Supply Connector (Figure 2-3)
  - AC power inlet specified for 40VAC-220VAC 10Amps max (J1)

FIGURE 2-2: dsPICDEM™ MCHV-2 DEVELOPMENT BOARD (FRONT)
2.3 CONNECTING THE SYSTEM

<table>
<thead>
<tr>
<th>CAUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>The user must be aware of the operating procedures outlined below and ensure that they are followed. Failure to do so may result in damage to the system.</td>
</tr>
</tbody>
</table>

2.3.1 Power Connections

It is recommended that cables used for the power connections should be terminated with blue or red insulated crimp terminals. If crimp terminals are not used, care should be taken to ensure that stray strands of wire do not short to adjacent terminals or the enclosure. If possible, all wires should be stripped and tinned with solder before connecting to the dsPICDEM™ MCHV-2 Development Board terminals.
For the AC mains supply input, standard double-insulated, 3-core flex cable should be used with a minimum current rating of 10A (1 mm² 18 AWG). A computer power cable can be used.

**Note:** The system is designed for installation category II. Therefore, the incoming mains cable should be wired into a standard non-locking 2-pin in addition with a earth ground type plug.

The recommended output cable size is 1.0 to 1.5 mm² (18-16 AWG) and it should have a 600V rating. This cable should also be double insulated or have a protective ground screen. Access to the terminal screws is provided via holes in the lid of the enclosure. A slotted screwdriver should be used.

**Note:** The user should only access the power terminals when the system is fully discharged (see the “Safety Notice” on page 5).

Figure 2-7 provides the locations of all connectors. Corresponding tables that describe each connection are provided in the relevant section.

**FIGURE 2-5:** dsPICDEM™ MCHV-2 DEVELOPMENT BOARD CONNECTIONS

The power connections are listed in Table 2-1.
2.3.2 Host/Communication Connections

A mini-USB-to-USB certified cable and a standard DB9 male-to-female cable should be used to connect the dsPICDEM™ MCHV-2 Development Board to the host computer.

The communication port connectors are listed in Table 2-2. Refer to Figure 2-5 for their exact location.

<table>
<thead>
<tr>
<th>Number</th>
<th>Name</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>USB-to-UART connector</td>
<td>Input/Output</td>
</tr>
<tr>
<td>13</td>
<td>RS-232- to-UART connector</td>
<td>Input/Output</td>
</tr>
<tr>
<td>14</td>
<td>USB connector for the Starter Kit on Board programmer/debugger</td>
<td>Input/Output</td>
</tr>
<tr>
<td>15</td>
<td>Non-isolated ICSP™ connector for device programming/debugging</td>
<td>Input/Output</td>
</tr>
<tr>
<td>16</td>
<td>Matrix board</td>
<td>Input/Output</td>
</tr>
</tbody>
</table>

2.3.3 Connection Sequence

The recommended connection sequence is listed below. The user should ensure that the following sequence is met before connecting the system to the mains, a motor and a host computer.

**Note:** Before making any connection, verify that the system is not powered and it is fully discharged. The system is completed discharged when the red LED D13 is OFF.

1. Connect the motor terminals R, Y, and B (also known as RWB or 123 or ABC) to the connection nodes M1, M2, and M3 (4, 5, and 6 in Figure 2-5), respectively.
2. Follow the next steps if position sensors are utilized to control the motor. If not, proceed to step 3.
   a) If the motor position is sensed with Hall Sensors, connect the terminals A, B, and C to the connection nodes HA, HB, and HC (7, 8, and 9 in Figure 2-5), respectively. Also, connect the positive terminal +5V to the connection node +5V and the ground terminal to the connection node GND (10 and 11 in Figure 2-5).
   b) If the motor position is sensed with a Quadrature Encoder, connect the terminals phase A, phase B, and Index to the connection nodes HA, HB, and HC (7, 8, and 9 in Figure 2-5), respectively.
3. Connect the communication ports.
   a) If RS-232 communication is used, connect the DB9 male connector to the
      RS-232 port. Connect the other end to the host PC (12 in Figure 2-5).
   b) If USB communication is used, connect the mini-USB male terminal to the
      mini-USB female connector labeled “USB” (12 in Figure 2-5). Connect the
      other end to the host PC.

   **Note:** The Microchip serial emulator driver (mchpcdc.inf) should be installed on
   your PC in order to activate the USB-to-Serial emulator. The emulator can
   be obtained from the dsPICDEM MCHV-2 Development Board product
   page: [http://www.microchip.com/mchv2](http://www.microchip.com/mchv2)

4. Connect the USB cable to the mini-USB female connector labeled
   “Program/Debug” (14 in Figure 2-5). Connect the USB male terminal to the USB
   ports of the host PC.

   **Note:** The built-in programmer/debugger is supported in MPLAB IDE Version
   8.83 (or higher) and MPLAB X Version 1.10 (or higher).

5. Ensure that the appropriate matrix board is plugged into the connector labeled
   J4 and that the board is oriented so that its pins are correctly lined up, as shown
   in Figure 2-6. Refer to Section 4.2.5 “Matrix Board” for more information
   regarding the matrix board.

   **FIGURE 2-6: MATRIX BOARD CONNECTION**

6. Power Cord connection. Make sure the power cord is disconnected from the AC
   mains before connecting the female terminal of the power cable to the AC input
   connector (1, 2, and 3 in Figure 2-5) of the dsPICDEM™ MCHV-2 Development
   Board.

   **Note:** The unit is designed to be connected to the AC mains supply via a standard
   non-locking plug. As the unit has no mains switch, this plug constitutes the
   means of disconnection from the supply. Therefore, the user must have
   unobstructed access to this plug during operation.
2.4 POWER SEQUENCES

The user should ensure that the following power sequences are adhered to.

2.4.1 Power-up Sequence

The unit is powered-up when the power cable is connected to the AC mains. To verify
that the unit is powered make sure that the LEDs D6, D13, D17 and D18 are ON.

Note: The unit is designed to be connected to the AC mains supply via a standard
non-locking plug. As the unit has no mains switch, this plug constitutes the
means of disconnection from the supply and thus the user must have
unobstructed access to this plug during operation.

2.4.2 Power-down Sequence

1. Stop firing all power devices by removing the PWM OUTPUTS shunt jumper.
2. Turn OFF the incoming AC supply by disconnecting the power cord from the
   mains.
3. Wait until the red DC bus LED indicator (D13) located next to the DC bus
   connector is no longer illuminated (this will take 5 minutes or less).

2.4.3 Programming/Debugging an Application Code Using the
   Built-in Starter Kit on Board Programmer/Debugger

The MPLAB Starter Kit on Board Programmer/Debugger for the dsPICDEM™ MCHV-2
Development Board may be used with MPLAB X, the free integrated development envi-
ronment, which is available from Microchip's web site (www.microchip.com). MPLAB X
allows the Starter Kit on Board to be used as an in-circuit debugger as well as a
programmer.

In-circuit debugging allows you to run, examine and modify your program using the
Starter Kit on Board hardware. This greatly assists you in debugging your firmware and
hardware together.

Special Starter Kit on Board software interacts with the MPLAB X application to run,
stop, and single-step through programs. Breakpoints can be set and the processor can
be reset. Once the processor is stopped, the register’s contents can be examined and
modified.

Note: Refer to Appendix B. “Debugging and Troubleshooting with MPLAB®
8” for MPLAB IDE Version 8 debug and programming guidance.

2.4.4 Setting Up an Application for Debug

To prepare the application for debug:

1. Launch MPLAB X, and then open the application project. The related workspace
   will be open. For information on projects and workspaces, refer to the MPLAB X
documentation listed in the “Recommended Reading” section of the “Preface”
in this user’s guide.
2. In the toolbar, click Debug Project. The build progress will be visible in the Build
   tab of the Output window.
3. Once the build sequence is complete, MPLAB X will program the target device
   and begin executing the application code in Debug mode, as shown in
   Figure 2-7.
FIGURE 2-7: MPLAB® X WORKSPACE

```c
// with doit

#else

// Initialize current offset compensation

while(!pinButton) // wait here until button 1 is pressed

#elif RTDM

RTDM_ProcessMgs();
#endif

#endif RTDM

RTDM_ProcessMgs();
#endif

while(pinButton) // when button 1 is released

#endif

SetupParm();
```

PM0SM (Build, Load, ...) × Debugger Console × Starter Kit on Board ×
2.4.4.1 RUNNING THE APPLICATION IN DEBUG MODE

The Starter Kit on Board executes the application code in either real-time (Continue) or steps (Step Into, Step Over, Run to Cursor, and Set PC at Cursor). Real-time execution occurs when you select Continue in MPLAB X. Once the device code is halted, either by clicking Pause or by a breakpoint, you can step.

| Note: | When Pause is clicked to stop the program execution, all of the peripherals are frozen. |

To see how these options function, do the following:

1. Select Debug>Reset or click the Reset icon to reset the program.
2. Select Debug>Continue or click the Continue icon. Observe how the application operates.
3. Select Debug>Pause or click the Pause icon to stop program execution. A green solid arrow will mark the line of code in the File window where the program halted.
4. Select Debug>Step Into or click the Step Into icon to step the program execution once. The green solid arrow will move down one line of code in the File window. Repeatedly click the button to step through the code.
5. Select Debug>Reset click the Reset icon to reset the program again.
6. Select Debug>Finish Debug Session or click the Finish Debug Session icon to exit Debug mode.
2.4.4.2 DEBUGGING THE APPLICATION

MPLAB X provides an editor and several debug features such as breakpoints and Watch windows to aid in application code debugging.

2.4.4.2.1 Editing Application Code

To view application code so it may be edited, do one of the following:

Select File>Open File to search for and open an existing code file, or double click a file in the Project window to open an existing code file. See an example Project window in Figure 2-8.

FIGURE 2-8: PROJECT EXAMPLE

For more information on using MPLAB X to create and edit code, see the MPLAB X Help.

2.4.5 Programming an Application

When the program is successfully debugged and running, the next step is to program the device for stand-alone operation in the finished design. When doing this, the resources reserved for debug are released for use by the application. To program the application, use the following steps:

1. Select Debug>Finish Debug Session or click the Finish Debug Session icon to exit Debug mode.

2. Select Run>Run Project or click the Run Project icon to build the application, program the device, and release it from reset. Alternatively, click the Make and Program Device icon to build the application and program the device (this action does not release the device from reset).

At this point, the application code will run independently.
2.4.6 Determining Device Support and Reserved Resources

Due to the built-in in-circuit debugging capability of ICD devices and the ICSP function offered by the debugger, the Starter Kit on Board uses some on-chip resources when debugging. It also uses program memory and file register locations in the target device during debugging. These locations are not available for use by user code. In MPLAB X, registers marked with an “R” in the register display represents reserved registers.

2.4.7 Troubleshooting

2.4.7.1 DEBUG CONNECTION PROBLEMS

While using the Starter Kit on Board as a debugger, you may receive the error “Starter Kits (PKOB) not found” when programming the device. This can result from communication being lost between the Starter Kit on Board and MPLAB X. To resolve this:

1. Unplug the USB cable from the Starter Kit.
2. Plug the USB cable back into the Starter Kit.

MPLAB X should automatically reconnect to the Starter Kit on Board and display its serial number (SN) in the same dialog box. Click the serial number followed by OK to continue. If this does not work, do the following:

1. Check the USB connection between the PC and Starter Kit at both ends.
2. If using a USB hub, make sure it is powered.
3. Make sure the USB port is not in use by another device.

2.4.7.2 PROGRAMMING PROBLEMS

If during the course of developing your own application you can no longer program the device, you may have set device configuration bits to code protect or some other state that prevents programming. To view the settings of the configuration bits, select Window>PIC Memory Views>Configuration bits.

2.4.8 Starter Kit on Board Information Tab

The firmware version and operating system (OS) version of the Starter Kit on Board can be obtained from the Project Dashboard window of MPLAB X. The project dashboard window also displays other useful information such as Starter Kit on Board Vdd, target device ID, and target device ID revision.
Chapter 3. Running the Demonstration

This chapter describes the demonstration software that is preloaded on the dsPIC® device that is included with the dsPICDEM MCHV-2 Development Board. This demonstration software, which is based on application note AN1162, demonstrates how to use the dsPICDEM™ MCHV-2 Development Board for controlling an AC induction motor (ACIM). For more information on this application note please refer to the following Microchip web page: www.microchip.com/motor

Note: The demonstration code preloaded on the dsPIC device is the latest version available at the time this board was packaged. There may be a newer version of software available online. Visit www.microchip.com/motor to download the latest version of software for the application note AN1162.

Follow these basic steps to run the demonstration:

Note 1: Before making any connection, verify that the system is not powered and it is fully discharged. The system is completed discharged when the red LED D13 is off.

2: One AC Induction Motor (part number: AC300023) is required to run this demonstration.

1. Connect the system as described in 2.3.3 “Connection Sequence”. Ensure that the Internal Op amp Configuration matrix board is connected to J4.

2. Power up the dsPICDEM™ MCHV-2 Development Board by connecting the power cord to the mains. To verify that the unit is powered, make sure that the LEDs D6, D13, D17, and D18 are ON. The very first time you connect the system to any host PC, you should briefly see a popup balloon in the system tray (lower right of desktop) that states: 1) new hardware has been found, 2) drivers are being installed, and 3) new hardware is ready for use. If you do not see these messages and the Starter Kit on Board does not work, try reconnecting the USB. If this does not work, see Section 2.4.7 “Troubleshooting”.

Note: The unit is designed to be connected to the AC mains supply via a standard non-locking plug. As the unit has no mains switch, this plug constitutes the means of disconnection from the supply. Therefore, the user must have unobstructed access to this plug during operation.

3. When powered up, the application will turn on the LEDs PWM1L1, PWM1L2 and PWM1L3.

To use the demonstration application, follow these steps:

a) Make sure the PWM OUTPUT shunt jumper is installed.
b) To start/stop the motor, press the switch labeled “PUSHBUTTON”.
c) Use the potentiometer labeled “POT” to control the direction and speed of the motor.
Chapter 4. Hardware

This chapter describes the hardware components of the dsPICDEM™ MCHV-2 Development Board.

Topics covered include:
- Power Factor Correction (PFC) Stage Board
- Power Module Stage
- Electrical Specifications

4.1 POWER FACTOR CORRECTION (PFC) STAGE BOARD

This board has two main functions; the first one is to provide the required power supplies to the power module board stage. The second function is to create the power bus rail that will be used to energize the motor through the power module.

Note: The circuits for the hardware described in this section are shown in Appendix A. “Board Layout and Schematics”.

4.1.1 AC Supply Input

The AC supply input stage of the board consists of the following components:
- F1 – 15A/250 VAC fast acting fuse (only replace with a part of the same rating)
- C1, C2 – Film capacitors to aid in the suppression of AC supply transients and to also provide a low impedance return path for any currents that flow from the power device tabs to the heat sink and enclosure due to capacitive coupling
- C3 – Film capacitor to aid in the suppression of AC supply transients.
- R1 – A metal oxide varistor located across the incoming supply lines to suppress high energy transients.
- L1 – 2.3 mH/15A Choke inductor for suppressing EMI
- C4 – Film capacitor to aid in the suppression of EMI
- C5, C6 – Film capacitors to aid in the suppression of AC supply transients and to also provide a low impedance return path for any currents that flow from the power device tabs to the heat sink and enclosure due to capacitive coupling
- R7 – A 1W high-voltage resistor, which acts to discharge C4
- R6 – A resistor with a negative temperature coefficient that acts to limit the surge of input current that would occur at initial application of power due to the discharged DC bus capacitance. The initial nominal cold resistance is 1 Ohm, which reduces once current flows and the device heats up.
- BR1 – A single-phase bridge rectifier to convert the incoming AC into DC suitable for input to the power conditioning stage.
4.1.2 Active Power Factor Correction (PFC)

The active PFC circuit is essentially a simple boost chopper with the control aimed at shaping the input current to follow the incoming mains supply waveform. The purpose of the different parts of the circuit is described below.

- **L6** – A high frequency axial inductor with a single layer winding on a ferrite core. This component is in series with the main inductor (L7) to reduce the effect of the self-capacitance of its winding. Without L6, significant high frequency (15 MHz) ringing of the inductor current occurs at every transistor turn-on, which would increase EMI and the PFC transistor switching loss.

- **L7** – A power inductor with three stacked toroidal cores made from a powdered-iron material to limit the core loss while maintaining good energy storage density. The particular cores used are Magnetics 0077083A7. A simple multi-layer winding is used which results in moderate copper loss but significant self-capacitance. Sixty-six turns of 1.5 mm diameter enameled copper wire is used. The design offers a good compromise between cost, core loss and size for this application. The nominal inductance is 1 mH at 10A.

- **Q2** – A 600V TO-247 IGBT. As the tab of the device is not isolated, a thermally conductive insulator is used. When closed, Q2 increase the energy stored in the inductor L7. When open, energy stored in the inductance is transferred to the DC bus capacitors (C30-C32). Energy is also drawn from the AC supply during this time. By appropriate control of the switches, the input current waveform can be profiled to obtain good power factor and low harmonic distortion.

- **D12** – A 600V TO-247 diode optimized for use at high switching frequency. As the tab of the device is not isolated, a thermally conductive insulator is used.

- **C28, R31, R32, R33, D11** – A “snubber” that acts to damp high frequency oscillations and limit the rate of change of voltage across Q2.

- **C30, C31, C32** – 470 µF/450V electrolytic capacitors which act as the main DC bus energy storage capacitors.

- **R25, R26, C25, D8, Q1, R27, R28** – A lever shifter to boost the PWM signal coming from the dsPIC DSC.

- **U19** – Microchip TC4421A gate drive IC. This contains a low resistance complementary push-pull MOSFET pair and input circuitry suitable for interfacing to a wide range of input voltages. It is an ideal choice for this application allowing up to 10A of peak gate drive current to switch Q2 rapidly and therefore achieve low switching loss. It also has a small footprint allowing it to be located physically close to the transistors allowing a low inductance gate circuit layout.

- **D9, C26, C27** – These components act to provide a dynamic level shifting circuit to U19 while Q2 switch. Inductance of the power tracking between the source of Q2 due to the physical board layout means there is a substantial transient voltage between the +15V supply point reference at R28 and the source of Q2. This simple low cost circuit allows the power supply of U19 to move transiently.

- **R75, R29 and D10** – These components control the current and voltage to turn on and turn off the IGBT. R29 controls the rising time and the di/dt when the IGBT is turned on. R29 in parallel with R75 control the falling time and the di/dt when the IGBT is turned off.

The power factor corrector design is based on the application note AN1106, for more information on this application note please refer to one of the following Microchip Web sites:

- www.microchip.com/smps
- www.microchip.com/motor
4.1.3 PFC Feedback Circuitry

In a DSC-based PFC, the relevant analog parameters and the control loops need to be redefined and discretized. This enables changeover from existing hardware to its digital counterpart easier and more logical.

The PFC is an AC-to-DC converter, which converts the AC input voltage to a DC voltage and maintains sinusoidal input current at a high input power factor. In a DSC-based PFC, three inputs signals are required to implement the current control.

The input rectifier (BR1) converts (shown in Section 4.1.1 “AC Supply Input”) the alternating voltage at power frequency into unidirectional voltage. This rectified voltage is fed to the chopper circuit to produce a smooth and constant DC output voltage to the load. The chopper circuit is controlled by the PWM switching pulses generated by the dsPIC DSC device, based on three measured feedback signals:

- Rectified input voltage
- AC input voltage zero-crossing event
- Rectified input current
- DC bus voltage

The rectified input voltage is measured in two stages:

- Signal conditioning: R22, R23, R24, C24, and D7 convert and filter the AC input voltage waveform from 90-265 VAC to 0-3.3 VAC. D7 limit the maximum voltage to 3.3V. C24 along with R22, R23 form a low-pass filter. The circuit is shown in Appendix A.
- Amplification: the operational amplifier MCP6024 (U13B) amplifies the conditioned AC input voltage; R45, R46, R47, R48, R49 and R51 set the gain. The MC6024 also shifts the conditioned AC input voltage to a 1.65V DC level. Therefore, the voltage applied to the dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by R50, R53, and R54. R39 and C39 filter out the high-frequency noise.

AC input voltage zero-crossing event is sensed using a voltage divider (R2-R5) and two opto-couplers (U1 and U2). The circuit is shown in Appendix A.

Rectified input current is measured using the shunt resistor R34 and the operational amplifier MCP6024 (U13A); R38, R39, R40, R41, R42 and R43 set the gain. R43 shifts the voltage present at the shunt resistor to a 1.65V DC level. Therefore, the voltage applied to the dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by R43, R53, and R54. R44 and C37 filter out the high-frequency noise. The circuit is shown in Appendix A.

DC bus voltage, the DC bus voltage is sensed at the power module stage. Please refer to Section 4.2.4 “Feedback Circuitry”.

4.1.4 Power Supplies

The PFC stage board provides the 15 volts power supply required to fire the power module IGBTs. The 15 volts power supply is built using a low power off-line SMPS primary switcher. The switching frequency is fixed to 60 kHz, the feedback signal to the power supply is provided by the opto-coupler. The output voltage is regulated at 15V with a maximum output current of 0.750A, the resultant maximum power is 11.25W. The input voltage range for this power supply is from 90 VAC to 260 VAC.

The PFC stage board also provides the 3.3 volts to powering-up the PIC24 MCU or dsPIC DSC, the isolation circuitry, the communication ports, the Starter Kit programmer, etc. It also generates the 3.3 volts for powering the analog circuits and the analog reference for the Analog-To-Digital Converter (ADC) module.
The 3.3 volts rail is created using a step-down regulator which is attached to the 15 volts regulator. The maximum output current is 0.650A, thus the resultant maximum power is 2.145W.

The 3.3 volts rail required for the analog circuits such as the current feedback and the Analog-to-digital converter is generated by a decoupling circuitry attached to the 3.3 volts regulator.

4.1.5 Fault Circuitry

Given the development nature of the system, robust independent FAULT protection is provided on the PFC Stage Board. Two different fault categories are used to indicate a FAULT to the PIC24 MCU or dsPIC DSC.

DC Bus Overcurrent, this fault signal is generated when the maximum current limit of 15A is reached. The comparison of the threshold value and the actual current is done by comparator U8. The threshold limit is set by R56 and R57. R69 is a shunt jumper resistor that can disconnect the overcurrent fault to the PIC24 MCU or dsPIC DSC.

DC Bus Overvoltage, this fault signal is generated when the maximum voltage limit on the DC bus rails is reached. The threshold value is set to 432V. The comparison of the threshold value and the actual DC bus voltage is done by comparator U7. The threshold limit is set by R60, R61 and R62. R66 is a shunt jumper resistor that can disconnect the overvoltage fault to the PIC24 MCU or dsPIC DSC.

| Note: | Both comparators are of open-drain type and need an external pull-up resistor. Both circuits share this pull-up resistor creating an OR condition at the output. |

4.1.6 Board Connectors

The PFC stage board has four tab fast-on connectors, one AC inlet and one 14-pin keyed connector for attaching a flat cable.

For the AC mains supply input, standard double-insulated, 3-core flex cable should be used with a minimum current rating of 10A (1 mm² 18 AWG). A computer power cable can be used. The recommended cable size is 1.0 to 1.5 mm² (18-16 AWG) and it should have a 600V rating. This cable should also be double insulated or have a protective ground screen.

| Note 1: | The system is designed for installation category II. Therefore, the incoming mains cable should be wired into a standard non-locking 2-pin in addition with an earth ground type plug. |
| 2: | The unit is designed to be connected to the AC mains supply via a standard non-locking plug. As the unit has no mains switch, this plug constitutes the means of disconnection from the supply. Therefore, the user must have unobstructed access to this plug during operation. |

The tab fast-on connectors AC_N and AC_L provides the connections to the bridge rectifier BR1. The recommended cable size is 16-18 AWG or 1.0 to 1.5 mm². It is also recommended that cables used for the power connections should be terminated with blue or red crimp terminals. If crimp terminals are not used, care should be taken to ensure that stray strands of wire do not short to adjacent terminals or the enclosure. If possible, all wires should be stripped and tinned with solder before connecting to the dsPICDEM MCHV-2 Development Board terminals.
The fast-on connectors PFC_OUT “+” and PFC_OUT “-” provide DC bus voltage to the Power Module Stage. The recommended cable size is 16-18 AWG or 1.0 to 1.5 mm². It is also recommended that cables used for the power connections should be terminated with blue or red crimp terminals. If crimp terminals are not used, care should be taken to ensure that stray strands of wire do not short to adjacent terminals or the enclosure. If possible, all wires should be stripped and tinned with solder before connecting to the dsPICDEM MCHV-2 Development Board terminals.

**Note:** The user should only access the power terminals when the system is fully discharged (see the "Safety Notice" on page 5).

The 14-pin keyed connector provides the signals and power supply rails from and to the Power Stage. These signals are shown in Table 4-1.

**TABLE 4-1: 14-PIN KEYED CONNECTORS**

<table>
<thead>
<tr>
<th>Number</th>
<th>Name</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3.3V, digital rail</td>
<td>Output</td>
</tr>
<tr>
<td>2</td>
<td>Not Connected</td>
<td>NC</td>
</tr>
<tr>
<td>3</td>
<td>3.3V, analog rail</td>
<td>Output</td>
</tr>
<tr>
<td>4</td>
<td>AC input voltage feedback</td>
<td>Output</td>
</tr>
<tr>
<td>5</td>
<td>Ground, analog rail</td>
<td>Output</td>
</tr>
<tr>
<td>6</td>
<td>AC input current feedback</td>
<td>Output</td>
</tr>
<tr>
<td>7</td>
<td>Fault (Overcurrent OR Overvoltage condition)</td>
<td>Output</td>
</tr>
<tr>
<td>8</td>
<td>VAC zero crossing signal</td>
<td>Output</td>
</tr>
<tr>
<td>9</td>
<td>Ground, digital rail</td>
<td>Output</td>
</tr>
<tr>
<td>10</td>
<td>PWM signal for the PFC IGBT</td>
<td>Input</td>
</tr>
<tr>
<td>11</td>
<td>Ground, digital rail</td>
<td>Output</td>
</tr>
<tr>
<td>12</td>
<td>Not Connected</td>
<td>NC</td>
</tr>
<tr>
<td>13</td>
<td>15V</td>
<td>Output</td>
</tr>
<tr>
<td>14</td>
<td>Not Connected</td>
<td>NC</td>
</tr>
</tbody>
</table>
4.2 POWER MODULE STAGE

This board has two main functions; the first is to control the motor using a PIC24 MCU or dsPIC DSC and a Power Module and the associated feedback signals for each control algorithm. The second is to provide a safe method in which to interact with the user.

Note: The circuits for the hardware described in this section are shown in Appendix A. “Board Layout and Schematics”.

4.2.1 Plug-In Module Configuration

Table 4-2 summarizes the pinout functionality of the PIM (U11).

<table>
<thead>
<tr>
<th>PIM Pin #</th>
<th>Signal Name</th>
<th>Pin Out Description</th>
<th>Routed via Matrix Board</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>DBG_LED1</td>
<td>Debug LED 1</td>
<td>No</td>
</tr>
<tr>
<td>2</td>
<td>VDD</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>3</td>
<td>PWM1H3</td>
<td>PWM Output - 3H</td>
<td>No</td>
</tr>
<tr>
<td>4</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>5</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>6</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>7</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>8</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>9</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>10</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>11</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>12</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>13</td>
<td>MCLR</td>
<td>Device Master Clear</td>
<td>No</td>
</tr>
<tr>
<td>14</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>15</td>
<td>VSS</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>16</td>
<td>VDD</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>17</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>18</td>
<td>FAULT</td>
<td>IBUS Current Fault (active-low logic)</td>
<td>No</td>
</tr>
<tr>
<td>19</td>
<td>PFC_FLT</td>
<td>IPFC fault (overvoltage or overcurrent)</td>
<td>No</td>
</tr>
<tr>
<td>20</td>
<td>PIM_INDEX/POT/V_M3</td>
<td>Hall sensor/Current sense/Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>21</td>
<td>PIM_QEB/IB/V_M2</td>
<td>Hall sensor/Current sens/Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>22</td>
<td>PIM_QEA/IA/V_M1</td>
<td>Hall sensor/Current sense/Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>23</td>
<td>PIM_IBUS/Vbus</td>
<td>DC bus voltage (downscaled)</td>
<td>Yes</td>
</tr>
<tr>
<td>24</td>
<td>PIM_IB/POT</td>
<td>AC input zero-cross/AC input voltage (downscaled)/Potentiometer</td>
<td>Yes</td>
</tr>
<tr>
<td>25</td>
<td>PIM_IA/IPFC</td>
<td>PFC current (buffered)</td>
<td>Yes</td>
</tr>
<tr>
<td>26</td>
<td>PGC</td>
<td>Device programming clock line</td>
<td>No</td>
</tr>
<tr>
<td>27</td>
<td>PGD</td>
<td>Device programming data line</td>
<td>No</td>
</tr>
<tr>
<td>28</td>
<td>AVdd/2</td>
<td>Reference voltage (half of AVdd voltage)</td>
<td>No</td>
</tr>
<tr>
<td>29</td>
<td>PIM_REC_NEUTR</td>
<td>Reconstructed motor neutral line voltage</td>
<td>Yes</td>
</tr>
<tr>
<td>30</td>
<td>AVdd</td>
<td>Analog supply</td>
<td>No</td>
</tr>
<tr>
<td>31</td>
<td>AVss</td>
<td>Analog supply</td>
<td>No</td>
</tr>
<tr>
<td>32</td>
<td>PIM_POT</td>
<td>Potentiometer signal</td>
<td>Yes</td>
</tr>
<tr>
<td>33</td>
<td>PIM_POT</td>
<td>Potentiometer signal</td>
<td>Yes</td>
</tr>
</tbody>
</table>
### TABLE 4-2: dsPICDEM™ MCHV-2 DEVELOPMENT BOARD PIM PINOUT FUNCTIONALITY (CONTINUED)

<table>
<thead>
<tr>
<th>PIM Pin #</th>
<th>Signal Name</th>
<th>Pin Out Description</th>
<th>Routed via Matrix Board</th>
</tr>
</thead>
<tbody>
<tr>
<td>34</td>
<td>PIM_GEN2</td>
<td>General I/O</td>
<td>Yes</td>
</tr>
<tr>
<td>35</td>
<td>PIM_DC_BUS</td>
<td>DC bus voltage (downscaled)</td>
<td>Yes</td>
</tr>
<tr>
<td>36</td>
<td>Vss</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>37</td>
<td>VDD</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>38</td>
<td>PIM_VAC_VOL2</td>
<td>AC input voltage (unbuffered)</td>
<td>Yes</td>
</tr>
<tr>
<td>39</td>
<td>PIM_IPFC_C_SHUNT</td>
<td>PFC shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>40</td>
<td>PIM_PFC_L</td>
<td>PFC shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>41</td>
<td>PIM_V_M1/POT</td>
<td>Hall sensor / Current sense / Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>42</td>
<td>PIM_V_M2</td>
<td>Hall sensor / Current sense / Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>43</td>
<td>PIM_V_M3/IBUS</td>
<td>Hall sensor / Current sense / Voltage feedback signal</td>
<td>Yes</td>
</tr>
<tr>
<td>44</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>45</td>
<td>Vss</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>46</td>
<td>Vss</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>47</td>
<td>HB/QEB</td>
<td>Hall sensor / QEI input</td>
<td>No</td>
</tr>
<tr>
<td>48</td>
<td>HC/INDEX</td>
<td>Hall sensor / QEI input</td>
<td>No</td>
</tr>
<tr>
<td>49</td>
<td>RX</td>
<td>UART Receive</td>
<td>No</td>
</tr>
<tr>
<td>50</td>
<td>TX</td>
<td>UART Transmit</td>
<td>No</td>
</tr>
<tr>
<td>51</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>52</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>53</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>54</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>55</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>56</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>57</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>58</td>
<td>PIM_FLT_OUT2</td>
<td>General I/O</td>
<td>Yes</td>
</tr>
<tr>
<td>59</td>
<td>PIM_FLT_OUT1</td>
<td>General I/O</td>
<td>Yes</td>
</tr>
<tr>
<td>60</td>
<td>DBG_LED2</td>
<td>Debug LED #2</td>
<td>No</td>
</tr>
<tr>
<td>61</td>
<td>HOME</td>
<td>Home signal for QEI (test point only)</td>
<td>No</td>
</tr>
<tr>
<td>62</td>
<td>VDD</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>63</td>
<td>OSCI</td>
<td>Crystal oscillator in</td>
<td>No</td>
</tr>
<tr>
<td>64</td>
<td>OSCO</td>
<td>Crystal oscillator out</td>
<td>No</td>
</tr>
<tr>
<td>65</td>
<td>Vss</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>66</td>
<td>PIM_IBUS+</td>
<td>IBUS shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>67</td>
<td>PIM_IBUS-</td>
<td>IBUS shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>68</td>
<td>BTN</td>
<td>Push Button</td>
<td>No</td>
</tr>
<tr>
<td>69</td>
<td>N/A</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>70</td>
<td>RX</td>
<td>UART Receive</td>
<td>No</td>
</tr>
<tr>
<td>71</td>
<td>PIM_PFC_PWM</td>
<td>PFC PWM output</td>
<td>Yes</td>
</tr>
<tr>
<td>72</td>
<td>HA/QEA</td>
<td>Hall sensor / QEI input</td>
<td>No</td>
</tr>
<tr>
<td>73</td>
<td>PIM_IB+</td>
<td>IB shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>74</td>
<td>PIM_IA+</td>
<td>IA shunt signal</td>
<td>Yes</td>
</tr>
<tr>
<td>75</td>
<td>Vss</td>
<td>N/A</td>
<td>No</td>
</tr>
<tr>
<td>76</td>
<td>HB/QEB</td>
<td>Hall sensor / QEI input</td>
<td>No</td>
</tr>
<tr>
<td>77</td>
<td>PIM_HALLC/INDEX/STP_PWM</td>
<td>Hall sensor / QEI input</td>
<td>Yes</td>
</tr>
<tr>
<td>78</td>
<td>PIM_PFC_PWM</td>
<td>PFC PWM output</td>
<td>Yes</td>
</tr>
</tbody>
</table>
4.2.2 Power Supplies

The system default configuration is to get the 15V, 3.3V and 3.3V analog rail voltages from the PFC stage board. However, it is also possible to use an external 24V power supply to generate these voltages.

U19, C70, C73, C71 and C74 regulate the voltage applied to the system via J15 (28V max). The output of the regulator is connected to the system through R109. The circuit is shown in Appendix A. “Board Layout and Schematics”.

Note: It is the responsibility of the user to populate these components if an external power supply is used.

U18, C67, R110, C68, D16, D15, L3, R111, R112 and C75 regulate the 15 volts to create a 3.3V digital rail. This auxiliary 3.3V digital rail is applied to the system through R106. The circuit is shown in Appendix A. “Board Layout and Schematics”.

Note: It is the responsibility of the user to populate these components if an external power supply is used.
R114, R107, C69, and C72 form a decoupling circuit for generating a 3.3V rail for the analog circuitry such as the ADC reference and the current feedback reference. This auxiliary 3.3V analog rail is applied to the system through R108.

| Note: | It is the responsibility of the user to populate these components if an external power supply is used. |

### 4.2.3 Power Module

The three-phase inverter is embedded in a power module (U16). This power module contains:

- 600V/30A 3-phase IGBT Inverter Bridge
- Gate driver circuitry for each IGBT
- Three Independent connections to the negative DC bus for current sensing
- Short-circuit protection circuitry
- Thermal Shutdown
- Gate Driver Power Supply Undervoltage protection
- Gate Driver Power Supply Overvoltage protection
- Single-grounded power supply
- Isolation of 2.5 kV per minute
- Maximum switching frequency: 20 kHz

The PIC24 MCU or dsPIC DSC provides the PWM signals to this power module in order to turn on/off the IGBT, and therefore apply power to the motor phases. R95 and R124 set the threshold limit for the overcurrent circuitry. If this voltage is greater than 0.5V (typical), a fault signal is asserted and the low-side IGTBs are turned off. R94 and C53 form a low-pass RC filter that filters out the frequencies above 88.4 kHz.

C56 sets the fault pulse duration, the value of C56 is given by the following equation: C56 = 18.3E-6 x 1.8E-3 seconds. Therefore, the fault pulse duration is 54 µs.

The power module fault output pin (VFO) is open-collector configured. R50 pulls up the fault output to the analog 3.3V rail. R53 and C40 form a low-pass RC filter that filters out the frequencies above 53 kHz.

For more information about this power module please refer to the manufacturer’s data sheet.

### 4.2.4 Feedback Circuitry

The Power Module Stage provides three different methods to sense the motor position. These signals are also useful to determine the speed, the torque, current consumption and the applied voltage.

**Hall Sensors**, the hall sensors circuitry is designed to attach open-collector configured sensors. It has a pull-up resistor at the hall sensor inputs (R23, R24, and R25) and a voltage divider (R26-R29, R27-R30, R28-R31) in order to scale the input waveforms to the PIC24 MCU or dsPIC DSC logic levels. C25-C27 and R26-R28 form a low-pass RC filter for each hall sensor signal.

**Phase Voltage Feedback** circuitry for each phase is compounded by a voltage divider, a current limiter and a low-pass RC filter. R79, R84 and R92 scale the phase M1 voltage in order to match the PIC24 MCU or dsPIC DSC logic levels. R85 limits the current going to the ADC pin (< 6mA). C51, R79 and R84 form the low-pass filter. The phase M2 and M3 has the exact same circuitry as shown in the schematic.
**DC Bus Voltage Feedback** is compounded by a voltage divider and a low-pass RC filter. R75, R76 and R81 scale the DC bus voltage in order to match the PIC24 MCU or dsPIC DSC logic levels. C47, R75 and R76 form the low-pass filter.

**Inverter Leg Shunt Resistor Feedback**, a shunt resistor is located between the emitter of the low side switches M1 and M2 and the "-DC bus". A simple differential amplifier circuit is used as shown in Appendix A. “Board Layout and Schematics”. The operation of the circuit used for the M1 phase leg is described below:

The current is measured using the shunt resistor R86 and the operational amplifier MCP6024 (U13A); R32, R33, R34, R36, and R37 set the gain. R38 shifts the voltage present at the shunt resistor to a 1.65V DC level. Hence the voltage applied to the PIC24 MCU or dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by R59, R60, R38 and U13D. R35 and C34 filter out the high-frequency noise.

The same topology is used for the phase M2.

**DC Bus Current Feedback**, a shunt resistor is located between the shunt resistors of side switches M1 and M2 and the "-DC bus". A simple differential amplifier circuit is used as shown in the schematic. The operation of the circuit used for sensing the DC bus current is described as follows:

The current is sensed using the shunt resistor R95 and the operational amplifier MCP6024 (U13C); R49, R51, R52, R56, and R57 set the gain. R58 shifts the voltage present at the shunt resistor to a 1.65V DC level. Hence the voltage applied to the PIC24 MCU or dsPIC DSC ADC channel varies within 0-3.3V. The offset is controlled by R59, R60, R58 and U13D. R54 and C42 filter out the high-frequency noise.

---

**Note:** It is possible to select any of these feedback signals using jumpers J12, J13 and J14, please refer to Section 4.2.9 “User Interfaces” for more information.

### 4.2.5 Matrix Board

The functions of matrix board interface are to:

- Connect the appropriate signals to the correct pins on the Plug-In Module
- Disconnect signals and provide isolation on signal paths that are not being used in a particular hardware configuration

The matrix board header has two rows of pins. One row (pin 1 to pin 25) hosts signals from different signal sources while the other (pin 26 to pin 50) hosts connections to the Plug-In Module. A block diagram describing the matrix board interface is shown in Figure 4-1.

**FIGURE 4-1: MATRIX BOARD BLOCK DIAGRAM**

![Matrix Board Block Diagram]

1. Shunt resistor signals (Direct)
2. Reconstructed motor neutral voltage
3. Feedback signals (Hall sensor/Phase voltage/Shunt resistor)
4. DC bus voltage
5. Potentiometer
6. Matrix Board
7. Plug-In Module

---

DS52074A-page 44 © 2012 Microchip Technology Inc.
The dsPICDEM MCHV-2 Development Board uses discrete op amps (U13) to amplify the shunt resistor signals. Alternatively, some of the PIC24 MCUs or dsPIC DSCs include on-board op amps that can be used for this purpose. To accommodate these two basic configurations, the dsPICDEM MCHV-2 Development Board comes with two matrix boards.

The Internal Op amp Configuration matrix board is used to configure the development board to use op amps internal to the PIC24 MCU or dsPIC DSC. This matrix board bypasses the current feedback circuitry on the Power Module Board and directly connects the shunt resistor signals to appropriate pins of the Plug-In Module.

The External Op amp Configuration matrix board is used to configure the development board to use the current feedback circuitry on the Power Module Board. This matrix board disconnects the shunt resistor signals from the Plug-In Module pins and connects the current feedback circuitry output to the appropriate Plug-In Module pins.

### 4.2.6 Fault Circuitry

In addition to the fault signal generated by the power module, the system can also create a DC bus overcurrent fault.

**DC Bus Overcurrent**, this fault signal is generated when the maximum current limit of 15A is reached. The comparison of the threshold value and the actual current is done by comparator U14. The threshold limit is set by R42 and R47.

**Note:** The comparator is open-drained and needs an external pull-up resistor. Both the power module output and the comparator output share this pull-up resistor creating an OR condition at the output.

### 4.2.7 Isolation

The power supply used by the push buttons, communication ports, and the Starter Kit on Board programmer/debugger is isolated from the power supply used by the power module or the PIC24 MCU or dsPIC DSC. An isolated 3.3V rail is generated from the digital 3.3V rail using a DC-to-DC converter (U10). This converter provides galvanic isolation rated up to 1000 Vdc/1 second.

### 4.2.8 Communication Ports

The power module stage board provides two methods for transmitting/receiving data to and from the system. Both communication methods are powered using the isolated 3.3V rail.

**UART-to-USB** communication port is based on a PIC18LFJ2450 device with a serial emulator firmware. This device translates the USB signals to PIC24 MCU or dsPIC DSC UART compatible signals. Isolation for the UART-to-USB communication port is provided by U25.

**UART-to-RS-232** communication port is based on a RS-232 transceiver (U9). This device translates the PIC24 MCU or dsPIC DSC UART signals to UART compatible signals. Isolation for the UART-to-RS-232 communication port is provided by U25.

Shunt jumpers J2 and J3 select the communication port. Table 4-3 shows the possible configurations.
TABLE 4-3: COMMUNICATION PORT CONFIGURATION

<table>
<thead>
<tr>
<th>Designator</th>
<th>Position</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J2</td>
<td>1-2</td>
<td>Connects UART receive line to RX.</td>
</tr>
<tr>
<td></td>
<td>2-3</td>
<td>Connects USB receive line to RX.</td>
</tr>
<tr>
<td>J3</td>
<td>1-2</td>
<td>Connects UART transmit line to TX.</td>
</tr>
<tr>
<td></td>
<td>2-3</td>
<td>Connects USB transmit line to TX.</td>
</tr>
</tbody>
</table>

4.2.9 User Interfaces

There are two types of user interfaces, isolated and non-isolated:

- Isolated interfaces:
  - Potentiometer labeled “POT” (R14)
  - RESET push button
  - PUSH BUTTON (S1)
  - PWM OUTPUT enable shunt jumper (J7)
  - Communication Port Selection shunt jumper (J2 and J3)
  - ICSP programmer/debugger connector for the Starter Kit on Board (J4)
  - ICSP programmer/debugger connector for the UART-to-USB converter (J1)

- Non-Isolated interfaces:
  - 15V Power Supply LED (D17)
  - 3.3V Power Supply LED (D18)
  - PWM2L1, PWM1L1, PWM1H1, PWM1L2, PWM1H2, PWM1L3, PWM1H3 LEDs
  - USB communication LED (D1)
  - USB cable connected LED (D3)
  - Starter Kit on Board USB cable connected LED (D21)
  - Starter Kit on Board Power On LED (D19)
  - ICSP programmer/debugger connector for the PIC24 MCU or dsPIC DSC (J18)
  - Feedback Selection Shunt Jumpers J11, J12, J13, and J14
  - Debug LEDs (D2 and D19)

Table 4-4 shows the multiple feedback signals that can be selected.

TABLE 4-4: MULTIPLE FEEDBACK SIGNALS

<table>
<thead>
<tr>
<th>Designator</th>
<th>Position</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J11</td>
<td>1-2</td>
<td>Connects AC input voltage zero-crossing event to VACZX_VAC_POT</td>
</tr>
<tr>
<td></td>
<td>3-4</td>
<td>Connects AC input voltage to VACZX_VAC_POT</td>
</tr>
<tr>
<td></td>
<td>5-6</td>
<td>Connects the POT voltage to VACZX_VAC_POT</td>
</tr>
<tr>
<td>J12</td>
<td>1-2</td>
<td>Connects Phase M1 shunt current feedback to MONITOR_1</td>
</tr>
<tr>
<td></td>
<td>3-4</td>
<td>Connects Phase M1 voltage feedback to MONITOR_1</td>
</tr>
<tr>
<td></td>
<td>5-6</td>
<td>Connects Hall A/QEA sensor signal to MONITOR_1</td>
</tr>
<tr>
<td>J13</td>
<td>1-2</td>
<td>Connects Phase M2 shunt current feedback to MONITOR_2</td>
</tr>
<tr>
<td></td>
<td>3-4</td>
<td>Connects Phase M2 voltage feedback to MONITOR_2</td>
</tr>
<tr>
<td></td>
<td>5-6</td>
<td>Connects Hall B/QEB sensor signal to MONITOR_2</td>
</tr>
<tr>
<td>J14</td>
<td>1-2</td>
<td>Connects DC bus shunt current feedback to MONITOR_3</td>
</tr>
<tr>
<td></td>
<td>3-4</td>
<td>Connects Phase M3 voltage feedback to MONITOR_3</td>
</tr>
<tr>
<td></td>
<td>5-6</td>
<td>Connects Hall C/INDEX sensor signal to MONITOR_3</td>
</tr>
<tr>
<td></td>
<td>7-8</td>
<td>Connects the POT voltage to MONITOR_3</td>
</tr>
</tbody>
</table>
4.2.10 Hardware for Programming and Debugging

The dsPICDEM™ MCHV-2 Development Board, with its built-in Starter Kit on Board debugger/programmer, provides an all-in-one solution for debugging and programming applications using MPLAB IDE. The debugging/programming operations are controlled by a PIC24FJ256GB106 MCU. The PIC24FJ256GB106’s built-in USB engine provides the communications interface between the Starter Kit on Board and the host PC.

Power to the Starter Kit on Board is provided via the isolated 3.3V rail. The PIC24FJ256GB106 MCU accomplishes debugging or programming of the target PIC24 MCU or dsPIC DSC by controlling the target’s MCLR, PGC1/EMUC1, and PGD1/EMUD1 signals. A Microchip 25LC256 serial EEPROM is used to store the serial number and debug control information. Isolation for the MCLR, PGC1/EMUC1, and PGD1/EMUD1 signals is provided by the digital isolators U3, U6, U22 and U7.

4.2.11 Board Connectors

Figure 4-2 provides the locations of the connectors. The Power Module Stage Board connectors are listed in Table 4-4.
TABLE 4-5: POWER MODULE STAGE BOARD CONNECTORS

<table>
<thead>
<tr>
<th>Number</th>
<th>Designator</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Motor Phase 1 (M1)</td>
<td>Output/Power</td>
</tr>
<tr>
<td>2</td>
<td>Motor Phase 2 (M2)</td>
<td>Output/Power</td>
</tr>
<tr>
<td>3</td>
<td>Motor Phase 3 (M3)</td>
<td>Output/Power</td>
</tr>
<tr>
<td>4</td>
<td>DC Bus &quot;+&quot;</td>
<td>Input/Power</td>
</tr>
<tr>
<td>5</td>
<td>DC Bus &quot;-&quot;</td>
<td>Input/Power</td>
</tr>
<tr>
<td>6</td>
<td>Hall Sensor A (HA)</td>
<td>Input</td>
</tr>
<tr>
<td>7</td>
<td>Hall Sensor B (HB)</td>
<td>Input</td>
</tr>
<tr>
<td>8</td>
<td>Hall Sensor C (HC)</td>
<td>Input</td>
</tr>
<tr>
<td>9</td>
<td>Hall Sensors, 5V power supply terminal</td>
<td>Output/Power</td>
</tr>
<tr>
<td>10</td>
<td>Hall Sensors, Ground terminal</td>
<td>Output/Power</td>
</tr>
<tr>
<td>11</td>
<td>UART-to-USB connector</td>
<td>Input/Output</td>
</tr>
<tr>
<td>12</td>
<td>UART-to-RS-232 connector</td>
<td>Input/Output</td>
</tr>
<tr>
<td>13</td>
<td>USB connector for the Starter Kit Programmer/Debugger</td>
<td>Input/Output</td>
</tr>
<tr>
<td>14</td>
<td>Connector for matrix board (J4)</td>
<td>Input/Output</td>
</tr>
<tr>
<td>15</td>
<td>Isolated ICSP™ programmer/debugger connector for UART-to-USB converter (J1)</td>
<td>Input/Output</td>
</tr>
<tr>
<td>16</td>
<td>ICSP programmer/debugger connector for PIC24 MCU or dsPIC DSC (J18)</td>
<td>Input/Output</td>
</tr>
<tr>
<td>17</td>
<td>14-pin keyed connector (J16)</td>
<td>Input/Output/Power</td>
</tr>
</tbody>
</table>

The 14-pin keyed connector provides the signals and power supply rails from and to the Power Module Stage. These signals are shown in Table 4-6.

TABLE 4-6: 14-PIN KEYED CONNECTORS

<table>
<thead>
<tr>
<th>Number</th>
<th>Name</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3.3V, digital rail</td>
<td>Output</td>
</tr>
<tr>
<td>2</td>
<td>AC input voltage feedback (not buffered)</td>
<td>Output</td>
</tr>
<tr>
<td>3</td>
<td>3.3V, analog rail</td>
<td>Output</td>
</tr>
<tr>
<td>4</td>
<td>AC input voltage feedback (buffered)</td>
<td>Output</td>
</tr>
<tr>
<td>5</td>
<td>Ground, analog rail</td>
<td>Output</td>
</tr>
<tr>
<td>6</td>
<td>AC input current feedback</td>
<td>Output</td>
</tr>
<tr>
<td>7</td>
<td>Fault (Overcurrent or Overvoltage condition)</td>
<td>Output</td>
</tr>
<tr>
<td>8</td>
<td>VAC zero crossing signal</td>
<td>Output</td>
</tr>
<tr>
<td>9</td>
<td>PFC shunt signal</td>
<td>Output</td>
</tr>
<tr>
<td>10</td>
<td>PWM signal for the PFC IGBT</td>
<td>Input</td>
</tr>
<tr>
<td>11</td>
<td>Ground, digital rail</td>
<td>Output</td>
</tr>
<tr>
<td>12</td>
<td>PWM fault</td>
<td>Output</td>
</tr>
<tr>
<td>13</td>
<td>15V</td>
<td>Output</td>
</tr>
<tr>
<td>14</td>
<td>PFC shunt signal</td>
<td>Output</td>
</tr>
</tbody>
</table>
4.3 ELECTRICAL SPECIFICATIONS

The maximum power and current capability of the system is dictated by the allowable temperature rise of the different components. Establishing maximum limits is not simple given the different ways the user may use the system. The voltage and the nature of the electrical load used both affects the dissipation that occurs. In determining the allowable limits for the power semiconductors, the following assumptions have been made:

- Heat sink is at 70°C (worst case)
- Thermal resistance of the insulating thermal pad is 3°C/W

**TABLE 4-7: INVERTER ELECTRICAL SPECIFICATIONS**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Min</th>
<th>Typ</th>
<th>Max</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC Bus</td>
<td>40</td>
<td>310</td>
<td>400</td>
<td>Vdc</td>
</tr>
<tr>
<td>Current</td>
<td>0.1</td>
<td>6.5(1)</td>
<td>10(1)</td>
<td>A</td>
</tr>
<tr>
<td>Power Rating</td>
<td>4</td>
<td>2015(2)</td>
<td>4000(2)</td>
<td>Watts</td>
</tr>
<tr>
<td>Switching Frequency</td>
<td>0</td>
<td></td>
<td>20</td>
<td>kHz</td>
</tr>
</tbody>
</table>

**Note 1:** The system continuously operated during one hour, 15 kHz switching frequency and the PFC boost circuit disabled.

**Note 2:** It is possible to increase the available maximum output power up to 4000W by using an external ventilation mechanism attached to system near to the power module. To provide additional air flow, a conventional AC muffin fan can be used (Comair-rotron part number 028021 or 028023). An alternative bonded fin heat sink with fans attached is also an option (C&H Technology, Inc. part number CH5117F).

**TABLE 4-8: PFC ELECTRICAL SPECIFICATIONS**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Min</th>
<th>Typ</th>
<th>Max</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC Bus</td>
<td>90</td>
<td>380</td>
<td>400</td>
<td>Vdc</td>
</tr>
<tr>
<td>Current</td>
<td>0.1</td>
<td>2.6(1)</td>
<td>3.5(1)</td>
<td>A</td>
</tr>
<tr>
<td>Power Rating</td>
<td>9</td>
<td>1000(2)</td>
<td>1400(2)</td>
<td>Watts</td>
</tr>
<tr>
<td>Switching Frequency</td>
<td>0</td>
<td>50</td>
<td>100</td>
<td>kHz</td>
</tr>
</tbody>
</table>

**Note 1:** The system continuously operated during one hour, 50 kHz switching frequency.

**Note 2:** It is possible to increase the available maximum output power up to 1400W by using an external ventilation mechanism attached to system near to the PFC IGBT. To provide additional air flow, a conventional AC muffin fan can be used (Comair-rotron part number 028021 or 028023). An alternative bonded fin heat sink with fans attached is also an option (C&H Technology, Inc. part number CH5117F).
Appendix A. Board Layout and Schematics

FIGURE A-1: PFC STAGE BOARD LAYOUT (TOP)
FIGURE A-3: PFC STAGE SCHEMATIC (SHEET 2 OF 3)
FIGURE A-4: PFC STAGE SCHEMATIC (SHEET 3 OF 3)
FIGURE A-8: POWER MODULE STAGE SCHEMATIC (SHEET 2 OF 6)
FIGURE A-9: POWER MODULE STAGE SCHEMATIC (SHEET 3 OF 6)
FIGURE A-11: POWER MODULE STAGE SCHEMATIC (SHEET 5 OF 6)
FIGURE A-12: POWER MODULE STAGE SCHEMATIC (SHEET 6 OF 6)
FIGURE A-13: INTERNAL OP AMP CONFIGURATION MATRIX BOARD SCHEMATIC

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>7</td>
<td>8</td>
<td>9</td>
<td>10</td>
<td>11</td>
<td>12</td>
<td>13</td>
<td>14</td>
<td>15</td>
<td>16</td>
<td>17</td>
<td>18</td>
<td>19</td>
<td>20</td>
<td>21</td>
<td>22</td>
<td>23</td>
<td>24</td>
<td>25</td>
<td>26</td>
<td>27</td>
<td>28</td>
<td>29</td>
<td>30</td>
<td>31</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
FIGURE A-14: EXTERNAL OP AMP CONFIGURATION MATRIX BOARD SCHEMATIC

![Diagram of external op amp configuration matrix board schematic]
Appendix B. Debugging and Troubleshooting with MPLAB® 8

This appendix provides debug and programming guidance for MPLAB 8 users. For more information on how to use MPLAB 8 IDE, refer to the following documentation:

- “MPLAB IDE User’s Guide” (DS51519)
- “MPLAB IDE Quick Start Guide” (DS51281)
- MPLAB IDE Online Help

B.1 SETTING UP AN APPLICATION FOR DEBUGGING

To prepare the application for debug:

1. Launch MPLAB IDE, and then open the application project. The related workspace will be open. For information on projects and workspaces, see the MPLAB IDE documentation mentioned at the beginning of this chapter.
2. Select **Project>Build All** to build the application code. The build’s progress will be visible in the Build tab of the Output window.
3. Select **Debugger>Select Tool>Starter Kit on Board**. MPLAB IDE will change to add Starter Kit on Board debug features (Figure B-1): 1) the status bar will show Starter Kit on Board as the debug tool, 2) a Starter Kit on Board debug toolbar will be added, 3) the Debugger menu will change to add Starter Kit on board debug functions, and 4) the Output window will display communication status between MPLAB IDE and the Starter Kit on Board on the Starter Kit on Board tab.

**FIGURE B-1: STARTER KIT ON BOARD AS DEBUG TOOL**
4. Select **Debugger>Program** to program the application code into the target PIC24 MCU or dsPIC DSC device on the dsPICDEM MCHV-2 Development board. The debug programming progress will be visible in the Starter Kit on Board tab of the Output window.

**Note:** Debug executive code is automatically programmed in the upper program memory of the Starter Kit on Board device when the Starter Kit on Board is selected as a debugger. Debug code must be programmed into the target device to use the in-circuit debugging capabilities of the Starter Kit on Board.

**B.2 RUNNING THE APPLICATION**

The Starter Kit on Board executes in either real-time (Run) or steps (Step Into, Step Over, and Animate) real-time execution occurs when you select Run in MPLAB IDE. Once the target device code is halted, either by Halt or a breakpoint, you can step. Toolbar buttons can be used for quick access to commonly used debug operations. Refer to Section 3.3 “Running the Example Application” in the “MPLAB Starter Kit for dsPIC® Digital Signal Controllers User’s Guide” (DS51700).

**Note:** All the peripherals are frozen when the “Halt” button is pressed to stop the program execution.

To see how these options function, do the following:

1. Select **Debugger>Reset>Processor Reset** or click the Reset button to reset the program.
2. Select **Debugger>Run** or click the Run button. Observe how the application operates.
3. Select **Debugger>Halt** or click the Halt button to stop the program execution. A green solid arrow will mark the line of code in the File window where the program halted.
4. Select **Debugger>Step Into** or click the Step Into button to step the program execution once. The green solid arrow will move down one line of code in the File window. Repeatedly click the button to step through the code.
5. Select **Debugger>Reset>Processor Reset** or click the Reset button to reset the program again. The arrow will disappear, meaning the device is reset.
B.3 DEBUGGING THE APPLICATION

MPLAB IDE provides an editor and several debug features such as breakpoints and Watch windows to aid in application code debugging.

B.3.1 Editing Application Code

To view application code so it may be edited, do one of the following:

1. Select **Edit> New** to create new code or **Edit> Open** to search for and open an existing code file, or double click a file in the Project window to open an existing code file. See an example Project window in **Figure B-2**.

For more information on using the MPLAB Editor to create and edit code, see the MPLAB Editor Help.

B.3.2 Using breakpoints and Mouseovers

To set a breakpoint in code:

1. Double click the gutter: Double click in the window gutter next to the line of code where you want the breakpoint. Double click again to remove the breakpoint.

2. Note: Double click must be set up for breakpoints. Select the **Edit> Properties**, and click the ASM/C/BAS File Type tab, and then select the “Double-click Toggles Breakpoint” check box.

3. Pop-up Menu: Place the cursor over the line of code where you want the breakpoint. Then, right-click to pop up a menu and select Set Breakpoint. Once a breakpoint is set, “Set Breakpoint” will become “Remove Breakpoint” and “Disable breakpoint”. Other options on the popup menu under Breakpoints are for deleting, enabling, or disabling all breakpoints.

4. Breakpoint Dialog: Open the Breakpoint dialog (**Debugger> Breakpoints**) to set, delete, enable, or disable breakpoints. See the MPLAB IDE Help for more information on this dialog.

5. A breakpoint set in code will appear as a red hexagon with a “B” as shown in **Figure B-3**.
FIGURE B-3: BREAKPOINT EXAMPLE

Once code is halted, hovering over a variable opens a tool tip window that contains the current value of the variable.

**Note:** This feature must be configured. Select **Edit>Properties** and click the Tooltips tab, and select the “Enable Variable Mouseover Values” check box.
B.3.3 Using Watch Windows

To use a Watch window:

1. The Watch window is made visible on the desktop by selecting View>Watch. It contains four selectable Watch views (via tabs) in which to view variables (SFRs, symbols and absolute addresses).

2. Select an SFR or Symbol from the list and click the related Add button to add it to the Watch window. Or click in the "Address" column and enter an absolute address.

A Watch window populated with SFRs and Symbols will look like Figure B-4. For more on using Watch windows, see MPLAB IDE Help.

FIGURE B-4: WATCH WINDOW EXAMPLE

B.4 PROGRAMMING AN APPLICATION

When the program is successfully debugged and running, the next step is to program the device for stand-alone operation in the finished design. When doing this, the resources reserved for debug are released for use by the application. To program the application, use the following steps:

1. Disable Starter Kit on Board as a debug tool by selecting Debugger>Select Tool>None.

2. Select Starter Kit on Board as the programmer in the Programmer>Select Programmer menu.

3. Select Programmer>Program.

At this point, the application code will run independently.
B.5 DETERMINING DEVICE SUPPORT AND RESERVED RESOURCES

Due to the built-in in-circuit debugging capability of ICD devices and the ICSP function offered by the debugger, the Starter Kit on Board uses some on-chip resources when debugging. It also uses program memory and file register locations in the target device during debugging. These locations are not available for use by user code. In the MPLAB IDE, registers marked with an "R" in the register display represents reserved registers.

For information on device resources that are needed for in-circuit debugging, please refer to the MPLAB ICD 2 Help, found in MPLAB IDE under Help>Topics. The device reserved resource information found under “Resources Used By MPLAB ICD 2” is the same for the Starter Kit on Board.

B.6 TROUBLESHOOTING

B.6.1 Debugging Connection Problems

While using the Starter Kit on Board as a debugger, you may receive the error “Starter Kit on Board not connected to this computer” when programming the device. This can result from communication being lost between the Starter Kit on Board and MPLAB IDE. To resolve this:

1. Unplug the USB cable from the Starter Kit on Board.
2. Plug the USB cable back into the Starter Kit on Board.

MPLAB IDE should automatically reconnect to the Starter Kit on Board. If this does not work, do the following:

1. Check the USB connection between the PC and Starter Kit on Board at both ends.
2. If using a USB hub, make sure it is powered.
3. Make sure the USB port is not in use by another device.

B.6.2 PROGRAMMING PROBLEMS

If during the course of developing your own application you can no longer program the device on the Starter Kit on Board, you may have set device configuration bits to code protect or some other state that prevents programming. To view the settings of the configuration bits, select Configure>Configuration bits.

B.7 SETTINGS DIALOG AND INFO TAB

When you select Debugger>Settings or Programmer Settings, you will open the Starter Kit on Board Settings dialog. Currently, there is only one tab (Info) on this dialog, which provides the following information:

- Firmware Version: The version of firmware on the Starter Kit on Board.
- Debug Exec Version: The version of the debug executive that is loaded into the target device program memory to enable debug operation.
Index

A
Application Debug Setup ......................................... 27
Application Debugging ............................................. 30
Application Programming ......................................... 30

C
Communication Port Connectors .................................... 25
Connection Sequence ............................................... 25
Customer Notification Service .................................... 12
Customer Support .................................................... 13

D
DC BUS Current Feedback ........................................... 44
DC BUS Overcurrent ................................................... 45
DC BUS Voltage Feedback ......................................... 44
Demonstration Software .............................................. 33

Documentation
Conventions ................................................................ 10
Layout ..................................................................... 9
dsPICDEM™ MCHV-2 Development Board
Block Diagram .......................................................... 17
Features ................................................................... 18
Overview .................................................................. 15

H
Hall Sensors .............................................................. 43
Hardware Components ............................................... 35

I
Interface Components ................................................ 22
Internet Address ....................................................... 12

Inverter Leg Shunt Resistor Feedback .......................... 44

M
Microchip Internet Web Site ....................................... 12

P
PFC Stage .................................................................. 21, 35
Phase Voltage Feedback .............................................. 43
Power Connections ..................................................... 23, 25
Power Module ........................................................... 43
Power Module Stage ...................................................... 21, 40
Power Supplies ........................................................... 42
Power-down Sequence ............................................... 27
Power-up Sequence ...................................................... 27
Programming and Debugging ..................................... 27
Programming Problems .............................................. 31

R
Reading, Recommended .............................................. 11
Running the Starter Kit on Board Application ................ 29

S
Safety Notice ................................................................ 5
System Connections ..................................................... 24

T
Troubleshooting .......................................................... 31

W
Warranty Registration ................................................... 11
WWW Address ............................................................ 12
<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Atlanta Duluth, GA Tel: 678-957-9614 Fax: 678-957-1455</td>
<td>Australia - Sydney Tel: 61-2-9868-6733 Fax: 61-2-9868-6755</td>
<td>India - New Delhi Tel: 91-11-4160-8631 Fax: 91-11-4160-8632</td>
<td>Denmark - Copenhagen Tel: 45-4450-2828 Fax: 45-4485-2829</td>
</tr>
<tr>
<td>Boston Westbrook, MA Tel: 774-760-0087 Fax: 774-760-0088</td>
<td>China - Beijing Tel: 86-10-8569-7000 Fax: 86-10-8528-2104</td>
<td>India - Pune Tel: 91-20-2566-1512 Fax: 91-20-2566-1513</td>
<td>France - Paris Tel: 33-1-69-53-63-20 Fax: 33-1-69-30-90-79</td>
</tr>
<tr>
<td>Chicago Itasca, IL Tel: 630-285-0071 Fax: 630-285-0075</td>
<td>China - Chengdu Tel: 86-28-8665-5511 Fax: 86-28-8665-7889</td>
<td>Japan - Osaka Tel: 81-66-152-7160 Fax: 81-66-152-9310</td>
<td>Germany - Munich Tel: 49-89-627-144-0 Fax: 49-89-627-144-44</td>
</tr>
<tr>
<td>Dallas Addison, TX Tel: 972-818-7423 Fax: 972-818-2924</td>
<td>China - Hangzhou Tel: 86-571-2819-3187 Fax: 86-571-2819-3189</td>
<td>Korea - Daegu Tel: 82-53-744-4301 Fax: 82-53-744-4302</td>
<td>Netherlands - Drunen Tel: 31-416-690399 Fax: 31-416-690340</td>
</tr>
<tr>
<td>Detroit Farmington Hills, MI Tel: 248-538-2250 Fax: 248-538-2260</td>
<td>China - Hong Kong SAR Tel: 852-2401-1200 Fax: 852-2401-3431</td>
<td>Korea - Seoul Tel: 82-2-554-7200 Fax: 82-2-558-5932 or 82-2-558-5934</td>
<td>Spain - Madrid Tel: 34-91-708-08-90 Fax: 34-91-708-08-91</td>
</tr>
<tr>
<td>Indianapolis Noblesville, IN Tel: 317-773-8323 Fax: 317-773-5453</td>
<td>China - Nanjing Tel: 86-25-8473-2460 Fax: 86-25-8473-2470</td>
<td>Malaysia - Kuala Lumpur Tel: 60-3-6201-9857 Fax: 60-3-6201-9859</td>
<td>UK - Wokingham Tel: 44-118-921-5869 Fax: 44-118-921-5820</td>
</tr>
<tr>
<td>Los Angeles Mission Viejo, CA Tel: 949-462-9523 Fax: 949-462-9608</td>
<td>China - Qingdao Tel: 86-532-8502-7355 Fax: 86-532-8502-7205</td>
<td>Malaysia - Penang Tel: 60-4-227-8870 Fax: 60-4-227-4068</td>
<td></td>
</tr>
</tbody>
</table>