Introduction

This document describes how to set the ATSAMB11-MR/ZR Xplained Pro evaluation board for the Bluetooth® Low Energy Over-the-Air Upgrade (BLE OTAU) application supported by the Advanced Software Framework (ASF). This also shows how to include the OTAU service in the application to provide OTAU capability to the BLE based products.

Figure 1. ATSAMB11-MR/ZR Xplained Pro Board

Features

The OTAU application provides the following features:

- Advertisement
- Pairing
- OTAU service and battery service
- OTAU Target mode
## Table of Contents

Introduction......................................................................................................................1

Features.......................................................................................................................... 1

1. Functional Overview.................................................................................................. 3

2. Block Diagram........................................................................................................... 4

3. Hardware Setup.........................................................................................................5

4. Software Setup.......................................................................................................... 6
   4.1. Installation Steps..........................................................................................................................6
   4.2. Build Procedure............................................................................................................................6

5. OTAU SPI Flash Memory Map................................................................................ 14

6. Console Logging......................................................................................................15

7. Running the Demo...................................................................................................16

8. BluSDK SMART Software Architecture................................................................... 23

9. Document Revision History..................................................................................... 24

The Microchip Web Site................................................................................................ 25

Customer Change Notification Service........................................................................25

Customer Support......................................................................................................... 25

Product Identification System......................................................................................26

Microchip Devices Code Protection Feature..................................................................26

Legal Notice................................................................................................................... 27

Trademarks................................................................................................................... 27

Quality Management System Certified by DNV.............................................................28

Worldwide Sales and Service........................................................................................29
1. **Functional Overview**

The OTAU profile enables firmware upgrade over the BLE protocol stack using Generic Attribute Profile (GATT). The BLE OTAU protocol defines the communication between the OTAU target and OTAU manager. The OTAU manager can be a mobile device (iOS/Android) or any BLE device that implements the OTAU manager GATT client protocol that transfers the upgrade firmware to the OTAU target. The OTAU target implements the OTAU GATT server protocol to receive the new firmware image or resume an interrupted downloaded image.
2. Block Diagram
The following figure shows the functional components involved in the OTAU process.

Figure 2-1. Block Diagram of the OTAU Process

- iOS/Android mobile phone with Microchip SmartConnect App (OTAU Manager)
- ATSAMB11 (OTAU Target)
3. **Hardware Setup**

The following figure shows connection of the ATSAMB11-MR/ZR XPro board to the host PC using a micro-USB cable.

**Figure 3-1. ATSAMB11 XPro Board Setup**
4. Software Setup

4.1 Installation Steps

1. Download and install the Atmel Studio software.
2. Install the standalone Advanced Software Framework (ASF) package.
3. Install the latest version of SAMB11-DFP from Tools > Device Pack Manager, to support BLE OTAU.
4. Keil IDE Installation – To use Keil IDE instead of Atmel Studio, perform the following:
   4.2. Download and install Python® from https://www.python.org/downloads/.

   Note: When installing Atmel Studio, the driver for SAMB11-MR/ZR XPRO is installed. Therefore, Atmel Studio must be installed to use the Keil compiler.
5. Download and install the Microchip SmartConnect App on the mobile phone, available in Apple Store for iPhone® and in the Google Play™ Store for Android™.

Note:
1. Atmel Studio offers predefined example projects for the SAM B11 and SAM B11ZR XPro boards.
2. For more information on the previous releases, refer to the Atmel Studio Release Notes available on the Microchip Website.

OTAU Application for ATSAMB11 - This application generates the image files for both the factory version and the upgraded version. The OtauImageCreator command line tool is used to generate both the factory format .img and the OTAU binary format (.bin) files. This tool is available as part of the BluSDK SMART package.

4.2 Build Procedure

The OTAU application demo requires two different firmware images to be generated from the example project. They are:
1. Initial/Factory version – image flashed onto the ATSAM B11 device.
2. New/Upgrade version – image used by the OTAU manager (mobile application) for upgrade.

4.2.1 Build the Initial Factory Version

4.2.1.1 Factory Image Build Procedure for Atmel Studio

This example build procedure is developed on Atmel Studio using the SAM B11 Xplained Pro board, which is also valid for the SAM B11ZR Xplained Pro board.
1. Open the Atmel Studio and select File > New > Example Project.
2. In the New Example Project from ASF or Extensions window:
   2.1. Select “SAMB11” in the **Device Family** and enter **OTAU** in the search box.
   2.2. Select the BLE OTAU application of ATSAMB11 by expanding the “Atmel - Atmel Corp.” in the **All Projects** tab. This selection automatically populates the Project Name, Location, Solution, Solution Name, and Device.
   2.3. Click **OK**.

**Figure 4-2. Selecting OTAU Application from Example Projects**

3. Select “Accept the License Agreement” check box and then click **Finish**.

4. The Atmel Studio generates the OTAU application project for the ATSAMB11.

5. Go to **Project Properties > Toolchain > Symbols**. Select the symbol **NDEVICE_INFORMATION_SERVICE**, as shown in following figure:
Figure 4-3. Symbol Value for Factory Version

Note: The starting letter of the symbol "N" denotes the exclusion of device information service in the initial/factory version of the application.

6. To build solution, go to Build > Build Solution or press <F7>.

Figure 4-4. Building the OTAU Application

7. When the project is built, an executable application firmware file with .img extension is created in the "Debug" or respective project configuration folder.

Note: The executable file for ATSAMB11 device is a custom .img format (custom format) and not hex or bin format.

8. The command line tool OtauImageCreator.exe available in the BluSDK SMART package is used to create the factory format firmware image from the application executable file. The metadata corresponding to the application firmware such as firmware version, vendor and product identification, and hardware revision are provided in the factory_img.conf configuration file. The template of the factory_img.conf file is provided along with OtauImageCreator tool. The following figure shows the help content available in the OtauImageCreator tool.
9. Edit the factory_img.conf file to modify the information such as the Vendor ID, Product ID, and the version of the application firmware (Initial/Factory version).

10. In the command prompt, navigate to the directory/folder which contains the firmware executable .img file and invoke the following command:

   ```
   <tool path>\OtauImageCreator.exe -f -c "<conf file path>\factory_img.conf" -i "OTAU_APP_SAMB11_XPLAINED_PRO.img" -o "BAS_OTAU_Factory_Image.img"
   ```

11. Upon executing the above command, the factory format binary file (`BAS_OTAU_Factory_Image.img`) is generated. Go to Tools > Device Programming to download this binary file into the ATSAMB11 XPro board, as shown in the following figure.

   **Figure 4-7. Selecting Device Programming**

12. In the EDBG (XXXXXXXX) Device Programming window,
   12.1. Select the appropriate EDBG tool and connect to the ATSAMB11 XPro board.
12.2. Click **Apply** and then click **Read** to read the Device Signature.

12.3. After reading the **Device**, select the **Memories** tab and browse to the factory format .img file in the **SPI Flash** field.

12.4. Click **Program** to load the factory image to the ATSAMB11 device, as shown in the following figure.

**Note:** The size of factory image is greater than 240 KB and it might take a few minutes to complete writing this image into the flash.

**Figure 4-8. Flashing the Application on ATSAMB11 XPro Board**

---

### 4.2.1.2 Factory Image Build Procedure for Keil IDE

This example build procedure is developed on Keil IDE using the SAMB11-MR/ZR Xplained Pro board. The Applications for Keil IDE are available in the BluSDK Smart release package under \SDK. After unzipping the package, the OTAU example application is available in `<release_dir>/apps/otau_app` folder.

1. Open `otau_app.uvprojx` project from the Keil IDE.
2. After opening the project, the following files are available in the Project tab:
   - `otau_app.c`
   - `app_startup.s`
   - `ble_services`
   - `ble_profiles`
   - `services`
   - `libs (driver_lib.lib, ble_api.lib)`
   - `utils`
3. Set the appropriate build symbols (see the following figure):
   - For ATSAMB11-MR: `BLE_MODULE=SAMB11_MR`
   - For ATSAMB11-ZR: `BLE_MODULE=SAMB11_ZR`
4. Set symbol “NDEVICE_INFORMATION_SERVICE”, as shown in the following figure.

**Figure 4-10. Symbol Value for Factory Version**

![Options for Target 'otau_app']

- **Define:** OTAU_SERVICE=ote, NDEVICE_INFORMATION_SERVICE=packed
- **Undefined:**

**Note:** The starting letter of the symbol “N” denotes the exclusion of device information service in the initial/factory version of the application.

5. Select **Project > Rebuild all target files** to compile the project.

**Figure 4-11. Compiling the Project**

![Options for Target 'otau_app']

6. When the project is built, an application executable `out.img` file is created in the `\tools` folder.

7. The command line tool `OtauImageCreator.exe`, available in `<release_dir>\tools \OttauImageCreator` is used to create the factory format firmware image from the application executable `out.img` file. The metadata corresponding to the application firmware such as, firmware version, vendor and product identification, and hardware revision are provided in the
factory_img.conf configuration file. The template of the factory_img.conf file is provided along with the OtauImageCreator tool.

8. Edit the factory_img.conf file to modify the information such as, the Vendor ID, Product ID, and the version of the application firmware (Initial/Factory version).

9. Go to Flash > Download to download the factory image via the USB on the SAMB11 XPro board. This step calls the factory_img.bat file and creates factory image otau_app_factory.img from out.img and invokes factory_image_download.py (a Python® file) to download it into the SPI flash, available on the SAMB11.

10. After flashing the factory image, the following message is displayed in the build output section.

```plaintext
Wrote page 971 of 976 pages ....
Wrote page 972 of 976 pages ....
Wrote page 973 of 976 pages ....
Wrote page 974 of 976 pages ....
Wrote page 975 of 976 pages ....
Wrote page 976 of 976 pages ....
Finished, resetting target
Press any key to continue ...
```

11. Now the OTAU factory application is running on the SAMB11 XPro board.

### 4.2.2 Build the Upgrade Version

The upgrade application is generated using the same example project, while using a different symbol definition in order to include a feature. This feature differentiates the upgrade version from the factory version.

#### 4.2.2.1 Upgrade Binary Build Procedure for Atmel Studio

Perform the following steps to generate the upgrade image in OTAU format using Atmel Studio.

1. In the OTAU application, go to Project Properties > Toolchain > Symbols and set the device information service symbol to DEVICE_INFORMATION_SERVICE. The definition of this symbol includes device information service in the application. Go to Build > Build Solution or press the <F7> button to compile and link the application; this creates the .img output file.

![Figure 4-12. Symbol Value for Upgrade Version](image)

2. The OtauImageCreator tool is also used to generate the firmware binary in OTAU format which is a custom format required by the OTAU manager (mobile application). Edit the upgrade_img.conf file and change the firmware version to a value greater than the factory version.

3. Open the command prompt and navigate to the directory/folder that contains the executable .img file for the upgrade application. Invoke the following command to generate the binary file corresponding to the upgrade firmware in OTAU format.

```plaintext
<tool path>\OtauImageCreator.exe -c "<conf file path>\upgrade_img.conf" -i "OTAU_APP_SAMB11_XPLAINED_PRO.img" -o "OTAU_Upgrade_Binary.bin"
```
Figure 4-13. Generate Upgrade Version Binary in OTAU Format

Alternatively, the upgraded image can be generated by the upgrade_img.bat file. Before running the bat file, the firmware image has to be copied into the upgrade_img.bat folder. Replace the name of the firmware image in the -i option by editing the upgrade_img.bat file. Double click on the bat file to generate the upgraded binary image.

4. The upgraded binary image is generated and is used by the mobile application to upgrade the current firmware in the ATSAMB11 XPro board.

4.2.2.2 Upgrade Binary Build Procedure for Keil IDE

Perform the following steps to generate the upgraded image in OTAU format using Keil IDE.

1. In the OTAU application, set the device information service symbol to “DEVICE_INFORMATION_SERVICE”. The definition of this symbol includes device information service in the application.

Figure 4-14. Symbol Value for Upgrade Version

2. Select Project > Rebuild all target files to compile the project. This creates the out.img output file in the \tools folder.

3. The OtauImageCreator tool is also used to generate the upgraded firmware binary in OTAU format, which is a custom format required by the OTAU manager (mobile application).

4. Edit the upgrade_img.conf file (<release_dir>\tools\OtauImageCreator\) and change the Firmware version to a value greater than the factory version. The metadata corresponding to the application firmware such as, firmware version, vendor and product identification, and hardware revision are provided in the upgrade_img.conf configuration file.

5. The upgraded image is generated by upgrade_img.bat file using out.img file. Double-click upgrade_img.bat file to generate the upgraded binary image otau_app_upgrade.bin file.

6. The upgraded binary image is generated and this is used by the mobile application to upgrade the current firmware in the SAMB11 XPro board.

**Note:** Image acceptance criteria is based on the following:

1. Upgrade Firmware version must be greater than Factory image firmware version.
2. Vendor ID, Product ID, and hardware version must be same as factory_img.conf.
5. **OTAU SPI Flash Memory Map**

The following figure illustrates the SAMB11 SPI Flash Memory split-up and storage of OTA factory image and upgrade image.

*Figure 5-1. OTAU SPI Flash Memory Map*

<table>
<thead>
<tr>
<th>Address</th>
<th>Description</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x00000000</td>
<td>SPI Flash Header (Factory Image Only)</td>
<td>4KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Patch (Factory Image)</td>
<td>20KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Patch (Upgrade Image)</td>
<td>20KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Application Header Patch (Factory Image)</td>
<td>4KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Application Header Patch (Upgrade Image)</td>
<td>4KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Application (Factory Image)</td>
<td>92KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>Application (Upgrade Image)</td>
<td>92KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>OTAU Meta Data</td>
<td>4KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>OTAU Meta Data (Backup)</td>
<td>4KB</td>
</tr>
<tr>
<td>0x00000000</td>
<td>RFU</td>
<td>8KB</td>
</tr>
</tbody>
</table>

© 2017 Microchip Technology Inc.
6. **Console Logging**

For the purpose of debugging, a logging interface can be implemented in the applications. The logging interface utilizes the same EDBG port that connects to the ATSAMB11 XPro board. A serial port monitor application (for example, Tera Term) is opened and attached to the appropriate COM port enumerated by the device on the PC.
7. **Running the Demo**

1. Power ON the ATSAMB11 XPro board by connecting the USB cable.

2. Ensure that the factory version of the firmware binary is flashed on to the board. Refer to **Build the Initial/Factory version**.

3. Open any Terminal Application (for example, Tera Term). Select the COM port enumerated on the PC and set the following parameters:
   - Baudrate 115200
   - Parity None
   - One Stop bit
   - One Start bit
   - No Hardware Handshake

4. Press the **Reset** button on the ATSAMB11 board.

5. The device is in advertising mode and the firmware version is displayed as 1.0.0 (the factory firmware).

   **Figure 7-1. OTAU Device in Advertising Mode**

6. The upgrade firmware binary file generated in the **Build the Upgrade Version** is transferred to the mobile application in the following ways:

   6.1. With iOS, the binary file is sent to a client email available in the iOS device. When the mail with the binary file is received in the mobile device, the binary is downloaded and copied to the Microchip SmartConnect application as shown in the following figure.
6.2. With Android devices, the upgrade firmware binary is placed in the Atmel folder. The folder named “Atmel” is created when the Microchip SmartConnect application is installed on the mobile phone.

7. Open the Microchip SmartConnect App from the mobile phone (Android/IOS). From the Dashboard page select Bluetooth Smart navigation pane.

**Note:** With an Android mobile phone, ensure that the location service is enabled.

**Figure 7-3. Dashboard of Microchip SmartConnect Application**

8. Press **START SCAN** to view the available BLE devices in the vicinity. “ATMEL-OTA” service is discovered and displayed. Click **ATMEL-OTA** to establish connection.
9. Enter the pass key from mobile (123456) as shown in the terminal and pair with the OTA application running in the ATSAMB11 device.

**Figure 7-5. Pairing Process**

```
Initializing SAMB11
SAMB11 Chip ID: 0x20000000
BD Address: 0x849805f0247f3701, Address Type:0
BluSmartSDK Firmware Version: 1.6.6.991
SAMB11 FW Version: 0x10000000
Device Firmware version: 1.0.0
BLE Started Advertisement
OBUU Process Paused...!!!
Connected to peer device with address: 0x7d6d1156f116f1
Connection Handle: 0
New MIU Value: 512
Please Enter the following Pass-code (on other Device): 123456
```
10. When the connection is successfully established, the battery service offered by the device displays. In the background, the mobile application compares the available upgrade firmware version against the firmware version of the device. A firmware upgrade pop-up window is displayed to notify the user about the latest firmware version.

11. Start the firmware upgrade by pressing the **Update** button in the pop-up window. The status of the upgrade process displays.
12. When the firmware upgrade is completed, the mobile application disconnects from the OTA application and the ATSAMB11 device reboots with the upgraded firmware. The latest firmware version of the device displays in the command window.
13. Perform the following steps on the mobile phone to clear the Bluetooth cache in order to discover the upgraded services:

13.1. Go to **Settings** and select **Forget This Device** for ATMEL-OTA

**Figure 7-8. Remove ATMEL-OTA from Mobile Cache**

13.2. Disable and enable the Bluetooth.

**Figure 7-9. Power Cycle Bluetooth Radio**

14. Once again, scan and reconnect to “ATMEL-OTA” from the mobile application. In addition to the Battery Service, a new “Device Information Service” displays. The Device Information Service is present in the upgraded firmware version. Click **Device Information Service** to view detailed information of the device.
Figure 7-10. BLE Device Scanning and Service Pages

- **BLE Scanner**: One device found, with the device name as ATMEL-OTA and the battery level at 42%. The device's MAC address is 88F9D65F3E81.

- **Service List**: The Battery Service is available, with an assigned number of 0x180F. The description states that the battery service exposes the state of a battery within a device.

- **Device Information Service**: The assigned number is 0x180A. The description mentions that the device information service exposes manufacturer and/or vendor information about a device.

- **Device Information**:
  - **Manufacturer Name**: ATMEL
  - **Model Number**: BLE DEVICE
  - **Serial Number**: BTL1000v/SAMB11
  - **Hardware Revision**: Rev A
  - **Firmware Revision**: FW_BETA
  - **Software Revision**: SW_BETA
  - **System ID**:
8. **BluSDK SMART Software Architecture**

The following diagram illustrates the various layers for implementing applications in the BluSDK SMART Architecture.
9. Document Revision History
Rev A - 09/2017

<table>
<thead>
<tr>
<th>Section</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document</td>
<td>Initial Release</td>
</tr>
</tbody>
</table>
The Microchip Web Site

Microchip provides online support via our web site at http://www.microchip.com/. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQ), technical support requests, online discussion groups, Microchip consultant program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Customer Change Notification Service

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.


Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Field Application Engineer (FAE)
- Technical Support

Customers should contact their distributor, representative or Field Application Engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://www.microchip.com/support
## Product Identification System

To order or obtain information, e.g., on pricing or delivery, refer to the factory or the listed sales office.

<table>
<thead>
<tr>
<th>PART NO.</th>
<th>Device</th>
<th>Tape and Reel Option</th>
<th>Temperature Range</th>
<th>Package</th>
<th>Pattern</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Device: PIC16F18313, PIC16LF18313, PIC16F18323, PIC16LF18323

### Tape and Reel Option:
- Blank = Standard packaging (tube or tray)
- T = Tape and Reel\(^{(1)}\)

### Temperature Range:
- I = -40°C to +85°C (Industrial)
- E = -40°C to +125°C (Extended)

### Package:\(^{(2)}\)
- JQ = UQFN
- P = PDIP
- ST = TSSOP
- SL = SOIC-14
- SN = SOIC-8
- RF = UDFN

### Pattern:
- QTP, SQTP, Code or Special Requirements (blank otherwise)

### Examples:
- PIC16LF18313- I/P Industrial temperature, PDIP package
- PIC16F18313- E/SS Extended temperature, SSOP package

### Note:
1. Tape and Reel identifier only appears in the catalog part number description. This identifier is used for ordering purposes and is not printed on the device package. Check with your Microchip Sales Office for package availability with the Tape and Reel option.
2. Small form-factor packaging options may be available. Please check [http://www.microchip.com/packaging](http://www.microchip.com/packaging) for small-form factor package availability, or contact your local Sales Office.

## Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, AnyRate, AVR, AVR logo, AVR Freaks, BeaconThings, BliCloud, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, Heldo, JukeBlox, KeeLoq, KeeLoq logo, Kleer, LANCheck, LINK MD, maXStylus, maXTouch, MediaLB, megaAVR, MOST, MOST logo, MPLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, Prochip Designer, QTouch, RightTouch, SAM-BA, SpyNIC, SST, SST Logo, SuperFlash, tinyAVR, UNI/O, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

ClockWorks, The Embedded Control Solutions Company, EtherSynch, Hyper Speed Control, HyperLight Load, IntelliMOS, mTouch, Precision Edge, and Quiet-Wire are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

Silicon Storage Technology is a registered trademark of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.

© 2017, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.
Quality Management System Certified by DNV

ISO/TS 16949
Microchip received ISO/TS-16949:2009 certification for its worldwide headquarters, design and wafer fabrication facilities in Chandler and Tempe, Arizona; Gresham, Oregon and design centers in California and India. The Company’s quality system processes and procedures are for its PIC®, dsPIC®, DSC, KEELQ® code hopping devices, Serial EEPROMs, microperipherals, nonvolatile memory and analog products. In addition, Microchip’s quality system for the design and manufacture of development systems is ISO 9001:2000 certified.
<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Office</td>
<td>Asia Pacific Office</td>
<td>China - Xiamen</td>
<td>Austria - Wels</td>
</tr>
<tr>
<td>2355 West Chandler Blvd.</td>
<td>Suites 3707-14, 37th Floor</td>
<td>Tel: 86-592-2388138</td>
<td>Tel: 43-7242-2244-39</td>
</tr>
<tr>
<td>Chandler, AZ 85224-6199</td>
<td>Tower 6, The Gateway</td>
<td>Fax: 86-592-2388130</td>
<td>Fax: 43-7242-2244-393</td>
</tr>
<tr>
<td>Tel: 480-792-7200</td>
<td>Harbour City, Kowloon</td>
<td>China - Zhuhai</td>
<td>Denmark - Copenhagen</td>
</tr>
<tr>
<td>Fax: 480-792-7277</td>
<td>Hong Kong</td>
<td>Tel: 86-756-3210040</td>
<td>Tel: 45-4450-2828</td>
</tr>
<tr>
<td>Technical Support:</td>
<td>Tel: 852-2943-5100</td>
<td>Fax: 86-756-3210049</td>
<td>Fax: 45-4485-2829</td>
</tr>
<tr>
<td><a href="http://www.microchip.com/">http://www.microchip.com/</a></td>
<td>Fax: 852-2401-3431</td>
<td>India - Bangalore</td>
<td>Finland - Espoo</td>
</tr>
<tr>
<td>support</td>
<td></td>
<td>Tel: 91-80-3090-4123</td>
<td>Tel: 358-9-4520-820</td>
</tr>
<tr>
<td>Web Address:</td>
<td></td>
<td>Fax: 91-80-3090-4444</td>
<td>Florida - Tallahassee</td>
</tr>
<tr>
<td><a href="http://www.microchip.com">www.microchip.com</a></td>
<td></td>
<td>India - New Delhi</td>
<td>Tel: 91-11-4160-8631</td>
</tr>
<tr>
<td>Atlanta</td>
<td></td>
<td>Japan - Osaka</td>
<td>Fax: 91-11-4160-8632</td>
</tr>
<tr>
<td>Duluth, GA</td>
<td></td>
<td>Tel: 81-6-6152-7160</td>
<td>China - Hangzhou</td>
</tr>
<tr>
<td>Tel: 678-957-9614</td>
<td></td>
<td>Fax: 81-6-6152-9310</td>
<td>Tel: 86-20-8755-8029</td>
</tr>
<tr>
<td>Fax: 678-957-1455</td>
<td></td>
<td>China - Dongguan</td>
<td>Fax: 86-2-554-7200</td>
</tr>
<tr>
<td>Austin, TX</td>
<td></td>
<td>Tel: 86-769-8702-9880</td>
<td>Fax: 86-2-558-5932 or</td>
</tr>
<tr>
<td>Tel: 512-257-3370</td>
<td></td>
<td>82-2-558-5934</td>
<td>Singapore</td>
</tr>
<tr>
<td>Boston</td>
<td></td>
<td>Malaysia - Kuala Lumpur</td>
<td>Tel: 60-3-6201-9857</td>
</tr>
<tr>
<td>Westborough, MA</td>
<td></td>
<td>Tel: 60-3-6201-9859</td>
<td>Fax: 60-3-6201-9859</td>
</tr>
<tr>
<td>Tel: 774-760-0087</td>
<td></td>
<td>Malaysia - Penang</td>
<td>Malaysia - Penang</td>
</tr>
<tr>
<td>Fax: 774-760-0088</td>
<td></td>
<td>Tel: 60-4-227-8870</td>
<td>Tel: 60-4-227-8870</td>
</tr>
<tr>
<td>Chicago</td>
<td></td>
<td>Fax: 60-4-227-4068</td>
<td>Fax: 60-4-227-4068</td>
</tr>
<tr>
<td>Itasca, IL</td>
<td></td>
<td>China - Qingdao</td>
<td>France - Toronto</td>
</tr>
<tr>
<td>Tel: 630-285-0071</td>
<td></td>
<td>Tel: 86-532-8502-7355</td>
<td>Tel: 38-2-422-588</td>
</tr>
<tr>
<td>Fax: 630-285-0075</td>
<td></td>
<td>Fax: 86-532-8502-7205</td>
<td>Fax: 38-2-422-588</td>
</tr>
<tr>
<td>Dallas</td>
<td></td>
<td>China - Shenzhen</td>
<td>Portugal - Lisbon</td>
</tr>
<tr>
<td>Addison, TX</td>
<td></td>
<td>Tel: 86-755-8864-2200</td>
<td>Tel: 351-2-303-055</td>
</tr>
<tr>
<td>Tel: 972-818-7423</td>
<td></td>
<td>Fax: 86-755-8203-1760</td>
<td>Fax: 351-2-303-055</td>
</tr>
<tr>
<td>Fax: 972-818-2924</td>
<td></td>
<td>China - Shenyang</td>
<td>Estonia - Tallinn</td>
</tr>
<tr>
<td>Detroit</td>
<td></td>
<td>Tel: 86-24-2334-2829</td>
<td>Tel: 37-2-433-999</td>
</tr>
<tr>
<td>Novi, MI</td>
<td></td>
<td>Fax: 86-24-2334-2393</td>
<td>Fax: 37-2-433-999</td>
</tr>
<tr>
<td>Tel: 248-848-4000</td>
<td></td>
<td>China - Shenzhen</td>
<td>Hungary - Budapest</td>
</tr>
<tr>
<td>Houston, TX</td>
<td></td>
<td>Tel: 86-755-8684-2200</td>
<td>Tel: 36-1-2-337-639</td>
</tr>
<tr>
<td>Tel: 281-894-5983</td>
<td></td>
<td>Fax: 86-755-8203-1760</td>
<td>Fax: 36-1-2-337-639</td>
</tr>
<tr>
<td>Indianapolis</td>
<td></td>
<td>China - Wuhan</td>
<td>Iceland - Reykjavik</td>
</tr>
<tr>
<td>Noblesville, IN</td>
<td></td>
<td>Tel: 86-27-5980-5300</td>
<td>Tel: 35-4-58-435</td>
</tr>
<tr>
<td>Tel: 317-773-8323</td>
<td></td>
<td>Fax: 86-27-5980-5118</td>
<td>Fax: 35-4-58-435</td>
</tr>
<tr>
<td>Fax: 317-773-5453</td>
<td></td>
<td>China - Xian</td>
<td>Latvia - Riga</td>
</tr>
<tr>
<td>Tel: 317-536-2380</td>
<td></td>
<td>Tel: 86-29-8833-7252</td>
<td>Tel: 37-0-1-25-850</td>
</tr>
<tr>
<td>Los Angeles</td>
<td></td>
<td>Fax: 86-29-8833-7256</td>
<td>Fax: 37-0-1-25-850</td>
</tr>
<tr>
<td>Mission Viejo, CA</td>
<td></td>
<td></td>
<td>Lithuania - Vilnius</td>
</tr>
<tr>
<td>Tel: 949-462-9523</td>
<td></td>
<td></td>
<td>Tel: 37-0-5-84-460</td>
</tr>
<tr>
<td>Fax: 949-462-9608</td>
<td></td>
<td></td>
<td>Fax: 37-0-5-84-460</td>
</tr>
<tr>
<td>Tel: 951-273-7800</td>
<td></td>
<td></td>
<td>Luxembourg - Luxembourg</td>
</tr>
<tr>
<td>Raleigh, NC</td>
<td></td>
<td></td>
<td>Tel: 352-2606-0998</td>
</tr>
<tr>
<td>Tel: 919-844-7510</td>
<td></td>
<td></td>
<td>Fax: 352-2606-0998</td>
</tr>
<tr>
<td>New York, NY</td>
<td></td>
<td></td>
<td>Norway - Trondheim</td>
</tr>
<tr>
<td>Tel: 631-435-6000</td>
<td></td>
<td></td>
<td>Tel: 47-7289-7561</td>
</tr>
<tr>
<td>San Jose, CA</td>
<td></td>
<td></td>
<td>Poland - Warsaw</td>
</tr>
<tr>
<td>Tel: 408-735-9110</td>
<td></td>
<td></td>
<td>Tel: 48-22-3325737</td>
</tr>
<tr>
<td>Fax: 408-436-4270</td>
<td></td>
<td></td>
<td>Romania - Bucharest</td>
</tr>
<tr>
<td>Canada - Toronto</td>
<td></td>
<td></td>
<td>Tel: 40-21-407-87-50</td>
</tr>
<tr>
<td>Tel: 905-695-1980</td>
<td></td>
<td></td>
<td>Spain - Madrid</td>
</tr>
<tr>
<td>Fax: 905-695-2078</td>
<td></td>
<td></td>
<td>Tel: 34-91-708-08-90</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fax: 34-91-708-08-91</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Sweden - Gothenburg</td>
</tr>
</tbody>
</table>