Getting Started with tinyAVR® 1-series

Features

- Getting Started with tinyAVR® 1-series Microcontrollers and Tools
- Getting Started with ATtiny817 Xplained Mini and Atmel Studio 7.0

Introduction

Author: Irun Walberg, Microchip Technology Inc.

This application note outlines how to get started with the tinyAVR® 1-series devices. Refer to the data sheet for further information on the differences between the tinyAVR® 1-series devices.
Table of Contents

Features.......................................................................................................................... 1

Introduction......................................................................................................................1

1. Relevant Devices.......................................................................................................3
   1.1. tinyAVR® 1-series......................................................................................................... 3

2. Get the Device Datasheet......................................................................................... 4

3. Get the Tools............................................................................................................. 5
   3.1. Get the ATtiny416 Xplained Nano Evaluation Kit..................................................... 5
   3.2. Get the ATtiny817 Xplained Mini Evaluation Kit.................................................... 6
   3.3. Get the ATtiny817 Xplained Pro Evaluation Kit...................................................... 8
   3.4. Get the ATtiny3217 Xplained Pro Evaluation Kit................................................... 9
   3.5. Get the STK600 Starter Kit........................................................................................ 11
   3.6. Get Source Code from Atmel | START..........................................................................12
   3.7. Get Atmel Studio 7.0..................................................................................................13
   3.8. Get IAR Embedded Workbench for AVR....................................................................13

4. Get Device Support................................................................................................. 14

5. Atmel Studio Users Getting Started.........................................................................15
   5.1. Atmel Studio with ATtiny817 Xplained Mini......................................................... 15
   5.2. Atmel Studio with STK600........................................................................................20

6. What's Next............................................................................................................. 26

7. Revision History....................................................................................................... 27

The Microchip Web Site................................................................................................ 28

Customer Change Notification Service..........................................................................28

Customer Support......................................................................................................... 28

Microchip Devices Code Protection Feature................................................................. 28

Legal Notice...................................................................................................................29

Trademarks................................................................................................................... 29

Quality Management System Certified by DNV.............................................................30

Worldwide Sales and Service.........................................................................................31
1. **Relevant Devices**
This chapter lists the relevant devices for this document.

1.1 **tinyAVR® 1-series**
The figure below shows the tinyAVR® 1-series devices, laying out pin count variants and memory sizes:

- Vertical migration upwards is possible without code modification, as these devices are pin compatible and provide the same or more features. Downward migration may require code modification due to fewer available instances of some peripherals.
- Horizontal migration to the left reduces the pin count and therefore, the available features.

**Figure 1-1. tinyAVR® 1-series Overview**

Devices with different Flash memory size typically also have different SRAM and EEPROM.
2. Get the Device Datasheet

Web pages


Documents/files

- ATtiny212/412 Data Sheet (summary, complete)(.pdf)
- ATtiny214/414/814 Data Sheet (summary, complete)(.pdf)
- ATtiny416/816 Data Sheet (summary, complete)(.pdf)
- ATtiny417/817 Data Sheet (summary, complete)(.pdf)
- ATtiny416/417/816/817 Automotive Data Sheet (complete)(.pdf)
- ATtiny1614 Data Sheet (complete)(.pdf)
- ATtiny1616/3216 Data Sheet (complete)(.pdf)
- ATtiny1617/3217 Data Sheet (complete)(.pdf)
- ATtiny1616/1617 Automotive Data Sheet (complete)(.pdf)

There are two versions of the data sheet:

- Complete version (includes all peripheral descriptions and electrical characteristics)
- Summary version
3. Get the Tools
Atmel Studio 7.0, which uses GCC compiler, is the preferred IDE to get started with tinyAVR® 1-series.

3.1 Get the ATtiny416 Xplained Nano Evaluation Kit

Get the kit: https://www.microchipdirect.com/product/attiny416-xnano

Document/file:
- ATtiny416 Xplained Nano User Guide (.pdf)

Key Features
- ATtiny416 microcontroller
- One yellow user LED
- One mechanical button
- mEDBG
  - Auto-ID for board identification in Atmel Studio
One green board status LED
- Programming
- Virtual COM port (CDC)

USB powered

The ATtiny416 Xplained Nano User Guide covers how to power the kit and includes detailed information about board components, extension interface, and the hardware user guide.

3.2 Get the ATtiny817 Xplained Mini Evaluation Kit

Figure 3-2. ATtiny817 Xplained Mini Kit


Get the kit: https://www.microchipdirect.com/product/attiny817-xmini

Document/file:
- ATtiny817 Xplained Mini User Guide (.pdf)

Key Features
- ATtiny817 microcontroller
• One yellow user LED
• One mechanical button
• Two QTouch® buttons
• mEDBG
  – Auto-ID for board identification in Atmel Studio
  – One green board status LED
  – Programming and debugging
  – Virtual COM port (CDC)
• USB powered
• ATtiny817 power sources:
  – 5.0V from USB
  – 3.3V regulator
  – External voltage
• Arduino shield compatible footprints

The ATtiny817 Xplained Mini User Guide covers how to power the kit and includes detailed information about board components, extension interface, and the hardware user guide.
3.3 Get the ATtiny817 Xplained Pro Evaluation Kit

Figure 3-3. ATtiny817 Xplained Pro Kit


Get the kit: https://www.microchipdirect.com/product/attiny817-xpro

Document/file:
- ATtiny817 Xplained Pro User Guide (.pdf)

Key Features
- ATtiny817 microcontroller
- Two mechanical user buttons
- Two QTouch® buttons
- One yellow user LED
- 32.768 kHz crystal
- Two Xplained Pro extension headers
- Embedded Debugger:
  - Auto-ID for board identification in Atmel Studio
  - One yellow status LED
– One green board power LED
– Symbolic debug of complex data types including scope information
– Programming and debugging, including power measurements
– Data Gateway Interface: SPI, I2C, two GPIOs
– Virtual COM port (CDC)

• Embedded current measurement circuitry, with Microchip Data Visualizer support for data visualization
• USB powered
• Supported with application examples in Atmel | START

The ATtiny817 Xplained Pro User Guide covers how to power the kit and includes detailed information about board components, extension interface, and the hardware user guide.

3.4 Get the ATtiny3217 Xplained Pro Evaluation Kit

Figure 3-4. ATtiny3217 Xplained Pro Kit

Get the kit: https://www.microchipdirect.com/product/attiny3217-xpro
Document/file:
Key Features

- ATtiny3217 microcontroller
- Two mechanical user buttons
- Two QTouch® buttons
- One yellow user LED
- 32.768 kHz crystal
- Two Xplained Pro extension headers
- Embedded Debugger
  - Auto-ID for board identification in Atmel Studio
  - One yellow status LED
  - One green board power LED
  - Symbolic debug of complex data types including scope information
  - Programming and debugging, including power measurements
  - Data Gateway Interface: SPI, I²C, two GPIOs
  - Virtual COM port (CDC)
- Embedded current measurement circuitry (XAM)
  - Measures power consumption of the ATtiny3217 and/or peripherals
  - Measures current between 100 nA and 400 mA
  - Current measurement data are shown in Microchip Data Visualizer
- USB powered
- Supported with application examples in Atmel | START

The ATtiny3217 Xplained Pro User Guide covers how to power the kit and includes detailed information about board components, extension interface, and the hardware user guide.
3.5 Get the STK600 Starter Kit

Figure 3-5. STK600 Starter Kit

Table 3-1. STK600 Device Support for tinyAVR 1-series

<table>
<thead>
<tr>
<th>Device</th>
<th>Routing Card</th>
<th>Socket Card</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATtiny214</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny414</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny416</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny417</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
<tr>
<td>ATtiny814</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny816</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny817</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
<tr>
<td>ATtiny1614</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny1616</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny1617</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
<tr>
<td>ATtiny3216</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny3217</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
</tbody>
</table>

For device support for other devices, refer to: [http://www.microchip.com/STK600_Starter_Kit-Users_Guide](http://www.microchip.com/STK600_Starter_Kit-Users_Guide)

Web page: [http://www.microchip.com/ATSTK600](http://www.microchip.com/ATSTK600)

Get the kit: [https://www.microchipdirect.com/product/ATSTK600](https://www.microchipdirect.com/product/ATSTK600)
Key features

- AVR Studio 4/AVR32 Studio/AVR Studio 5/Atmel Studio Compatible
- USB Interface to PC for Programming and Control
- Powered from USB Bus or from an External 10-15V DC Power Supply
- Adjustable Target \( V_{CC} \) (0-5.5V)
- Two Adjustable Reference Voltages with High Accuracy (0-5.0V, 10 mV res.)
- Clock Oscillator, Adjustable On-The-Fly from Atmel Studio (0-50 MHz, 0.1% res.)
- Serial In-System Programming (ISP) of tinyAVR® and megaAVR® Devices
- PDI Programming of AVR® XMEGA® Devices
- JTAG Programming of megaAVR, AVR XMEGA, and AVR UC3 Devices
- aWire Programming of AVR UC3 Devices
- ISP and JTAG Programming of AVR Devices in External Target Systems
- Flexible Routing and Socket Card System for Easy Mounting of all Supported Devices
- Eight Push Buttons for General Use
- Eight LEDs for General Use
- All AVR I/O Ports are Easily Accessible through Pin Header Connectors
- Expansion Connectors for Plug-In Modules and Prototyping Area
- On-Board 4 Mb DataFlash for Non-volatile Data
- USB mini-AB (On-The-Go) Connector for AVR Devices with USB
- PHY and DSUB-9 Connector for RS-232 Interface
- PHY and DSUB-9 Connector for CAN Bus
- PHY and Header for LIN Bus
- Device Board with an ATmega2560 AVR Microcontroller Included

The STK600 User Guide describes how to power the kit and includes detailed information about board components, extension interface, and the hardware description.

3.6 Get Source Code from Atmel | START

The example code is available through Atmel | START, which is a web-based tool that enables configuration of application code through a Graphical User Interface (GUI). The code can be downloaded for both Atmel Studio and IAR Embedded Workbench® via the direct example code-link(s) below or the BROWSE EXAMPLES button on the Atmel | START front page.

Atmel | START web page: http://microchip.com/start

Example Code

Finding example code for devices in the tinyAVR 1-series can be done by searching for the device name, e.g. ATtiny817, in the Atmel | START example browser.

Press User guide in Atmel | START for details and information about example projects. The User guide button can be found in the example browser, and by clicking the project name in the dashboard view within the Atmel | START project configurator.

Atmel Studio
Download the code as an .atzip file for Atmel Studio from the example browser in Atmel | START, by clicking **DOWNLOAD SELECTED EXAMPLE**. To download the file from within Atmel | START, click **EXPORT PROJECT** followed by **DOWNLOAD PACK**.

Double-click the downloaded .atzip file and the project will be imported to Atmel Studio 7.0.

**IAR Embedded Workbench**

For information on how to import the project in IAR Embedded Workbench, open the Atmel | START user guide, select **Using Atmel Start Output in External Tools**, and **IAR Embedded Workbench**. A link to the Atmel | START user guide can be found by clicking **About** from the Atmel | START front page or **Help And Support** within the project configurator, both located in the upper right corner of the page.

### 3.7 Get Atmel Studio 7.0


**Document/file:**
- Atmel Studio 7.0 (build 1645) Installer (.exe)

Atmel Studio 7.0 or later is the preferred IDE for developing and debugging firmware for the tinyAVR® 1-series.

For device support, refer to **4. Get Device Support**.

### 3.8 Get IAR Embedded Workbench for AVR

**Web page:** [https://www.iar.com/iar-embedded-workbench/#?architecture=AVR](https://www.iar.com/iar-embedded-workbench/#?architecture=AVR)

**Document/file:** IAR Embedded Workbench® installer for AVR.
4. Get Device Support

**Atmel Studio:** Support for new devices in Atmel Studio can be added by using the *Device Pack Manager*, which is found under *Tools->Device Pack Manager*.

For tinyAVR® 1-series, update to the latest version by performing the following steps:

1. Click *Check for Updates*.
2. For tinyAVR® 1-series, select the latest available version of *ATtiny_DFP*.
3. Click *Install*.

For offline installers, go to [http://packs.download.atmel.com/](http://packs.download.atmel.com/). To install a package, double click on the installer file and follow the instructions. Any open Atmel Studio windows will have to be closed for the installation to take effect.

**IAR:** Support for new devices in IAR Embedded Workbench can be added by installing the latest service package. The service package is available from *My Pages* on [https:// iar.com](https://iar.com).
5. **Atmel Studio Users Getting Started**

5.1 **Atmel Studio with ATtiny817 Xplained Mini**

**Prerequisites**

- Atmel Studio 7.0 1645 or above installed
- The ATtiny817 Xplained Mini board connected to Atmel Studio 7.0 via the on-board USB connector, which is connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will enable debugging and programming via the USB.

**Workflow**

1. Launch Atmel Studio 7.0.
2. The page shown in the figure below will appear when ATtiny817 Xplained Mini is connected to Atmel Studio 7.0.
3. Start creating a new project by clicking **New → Project...** or by using the shortcut **Ctrl+Shift+N**, as shown in the figure below.
4. Select the **GCC C Executable Project** template from the new project wizard shown in the figure below, type in the name of the solution and project (e.g. **GETTING_STARTED** and **LED_TOGGLE**), and click **OK**.

**Figure 5-3. New Project Wizard**

5. Select ATtiny817 from the device selection wizard as shown in the figure below, and click **OK**.
A new project with a `main.c` file associated with it will be generated in Atmel Studio.

6. Replace the main loop in the `main.c` file with the following code snippet:

```c
int main (void)
{
    /* Configure SW0 as input */
    PORTC.DIRCLR = PIN5_bm;

    /* Configure LED0 pin as output */
    PORTC.DIRSET = PIN0_bm;

    while (1)
    {
        /* Check the status of SW0 */
        /* 0: Pressed */
        if (!(PORTC.IN & (PIN5_bm)))
        {
            /* LED0 on */
            PORTC.OUTSET = PIN0_bm;
        }
        /* 1: Released */
        else
        {
            /* LED0 off */
            PORTC.OUTCLR = PIN0_bm;
        }
    }
}
```

In the code editor, the code should appear as shown in the figure below.
7. Open project properties by clicking *Project → Properties* or by using the shortcut *ALT+F7*.

8. In the *Tool* view (see the figure below) set *Selected debugger/programmer* to mEDBG and *Interface* to UPDI.
Figure 5-6. Debugger and Interface for ATtiny817

9. Build the project by clicking Build → Build Solution or by using the shortcut F7.
10. Program ATtiny817 with the project code and start debugging by clicking Debug → Start debugging and break or by using the shortcut ALT+F5. The application is programmed onto the device and program execution should break in main.
11. Run the code by clicking Debug → Continue or by using the shortcut F5).
12. Verify that LED0 is lit when SW0 is pushed on the ATtiny817 Xplained Mini.

5.2 Atmel Studio with STK600

Prerequisites
- Atmel Studio 7.0 1645 or above installed
- The STK600 board connected to Atmel Studio 7.0 via the on-board USB connector.

Workflow
1. Launch Atmel Studio 7.0.
2. Start creating a new project by clicking New → Project... or by using the shortcut Ctrl+Shift+N, as shown in the figure below.
3. Select the GCC C Executable Project template from the new project wizard shown in the figure below, type in the name of the solution and project (e.g. GETTING_STARTED and LED_TOGGLE), and click OK.

Figure 5-8. New Project Wizard

4. Select ATtiny817 from the device selection wizard as shown in the figure below, and click OK.
A new project with a `main.c` file associated with it will be generated in Atmel Studio.

5. Replace the `main` function in the `main.c` file with the following code snippet:

```c
int main (void)
{
    /* STK600 have eight User Buttons and eight User LEDs which can be connected to any IO pin using cables */
    /* Configure PB0 as input (remember to connect SW0 to PB0 using a cable */
    PORTB.DIRCLR = PIN0_bm;
    /* Configure PB1 as output (remember to connect LED0 to PB1 using a cable*/
    PORTB.DIRSET = PIN1_bm;

    while (1)
    {
        /* Check the status of SW0 */
        /* 0: Pressed */
        if (!(PORTB.IN & (PIN0_bm)))
        {
            /* LED0 on */
            PORTB.OUTCLR = PIN1_bm;
        }
        /* 1: Released */
        else
        {
            /* LED0 off */
            PORTB.OUTSET = PIN1_bm;
        }
    }
}
```

In the code editor, the code should appear as shown in the figure below.
6. Open project properties by clicking **Project → Properties** or by using the shortcut **ALT+F7**.

7. In the **Tool** view (see the figure below) set **Selected debugger/programmer** to STK600 and **Interface** to UPDI.
8. Build the project by clicking `Build → Build Solution` or using the shortcut F7.

9. Connect the embedded debugger on STK600 to ATtiny817 by connecting a cable between the ISP/PDI headers, as shown in the figure below.

**Figure 5-12. UPDI Connection on STK600**

10. Connect PC5 to SW0, and PC0 to LED0 by using cables.
11. Load the code onto the STK600 and start debugging by clicking Debug → Start debugging and break or by using the shortcut ALT+F5. The application is programmed onto the device and the program execution should break in main.

12. Run the code by clicking Debug → Continue or by using the shortcut F5.

13. Verify that LED0 is lit when SW0 is pushed on STK600.
6. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
- Atmel Studio: http://www.microchip.com/avr-support/atmel-studio-7
- Atmel Studio help: "Help → View Help" (shortcut "CTRL+F1")
- Atmel Gallery: https://gallery.microchip.com/

Firmware:
- Atmel START examples: http://microchip.com/start/#examples

Hardware:
- AVR042: AVR Hardware Design Considerations: http://www.microchip.com/AVR042:AVR_Hardware_Design_Considerations

Recommended programming/debugging tools:
- Atmel-ICE:
- Power debugger:

Other:
- AVR Freaks®: http://www.avrfreaks.net/
- Application notes: http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047, find the preferred device and go to the product page. All relevant application notes can be found under the documentation tab.
- More technical documentation concerning various products: https://www.microchip.com/webdoc
7. Revision History

<table>
<thead>
<tr>
<th>Doc. Rev.</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
</table>
| B         | 06/2018 | • Added device support for ATtiny3216 and ATtiny3217.  
            |         | • Added kit support for ATtiny416 Xplained Nano and ATtiny3217 Xplained Pro  
            |         | • Fixed bug in ATtiny817 Xplained Mini example. |
| A         | 08/2017 | • Microchip DS00002503 Rev. A. replaces Atmel AVR42781 Rev. A.  
            |         | • Renamed from AVR42781: Getting Started With ATtiny417/814/816/817 to Getting Started with tinyAVR 1-series, and restructured the document in order to cover more devices.  
            |         | • Added device support for ATtiny1614, ATtiny1616, and ATtiny1617. |
| 42781A    | 09/2016 | Initial document release. |
The Microchip Web Site

Microchip provides online support via our web site at http://www.microchip.com/. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQ), technical support requests, online discussion groups, Microchip consultant program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Customer Change Notification Service

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.


Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Field Application Engineer (FAE)
- Technical Support

Customers should contact their distributor, representative or Field Application Engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, AnyRate, AVR, AVR logo, AVR Freaks, BeaconThings, BitCloud, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, Heldo, JukeBlox, KeeLoq, KeeLoq logo, Kleer, LANCheck, LINK MD, maXSylus, maXTouch, MediaLB, megaAVR, MOST, MOST logo, MPLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, Prochip Designer, QTouch, RightTouch, SAM-BA, SpyNIC, SST, SST Logo, SuperFlash, tinyAVR, UNI/O, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

ClockWorks, The Embedded Control Solutions Company, EtherSynch, Hyper Speed Control, HyperLight Load, IntelliMOS, mTouch, Precision Edge, and Quiet-Wire are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

Silicon Storage Technology is a registered trademark of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
ISO/TS 16949
Microchip received ISO/TS-16949:2009 certification for its worldwide headquarters, design and wafer fabrication facilities in Chandler and Tempe, Arizona; Gresham, Oregon and design centers in California and India. The Company’s quality system processes and procedures are for its PIC® MCUs and dsPIC® DSCs, KEELQ® code hopping devices, Serial EEPROMs, microperipherals, nonvolatile memory and analog products. In addition, Microchip’s quality system for the design and manufacture of development systems is ISO 9001:2000 certified.
<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
</table>
| Corporate Office  
2355 West Chandler Blvd.  
Chandler, AZ 85224-6199  
Tel: 480-792-7200  
Fax: 480-792-7277  
Technical Support:  
http://www.microchip.com/support | Australia - Sydney  
Tel: 61-2-9868-6733  
China - Beijing  
Tel: 86-10-8569-7000  
China - Chengdu  
Tel: 86-28-8665-5511  
China - Changqing  
Tel: 86-23-8980-9588  
China - Dongguan  
Tel: 86-769-8702-9880  
China - Guangzhou  
Tel: 86-20-8755-8029  
China - Hong Kong SAR  
Tel: 852-2943-5100 | India - Bangalore  
Tel: 91-80-3090-4444  
India - New Delhi  
Tel: 91-11-4160-8631  
India - Pune  
Tel: 91-20-4121-0141  
Japan - Osaka  
Tel: 81-6-6152-7160  
Japan - Tokyo  
Tel: 81-3-6880-3770  
Korea - Daegu  
Tel: 82-53-744-4301  
Korea - Seoul  
Tel: 82-2-554-7200  
Malaysia - Kuala Lumpur  
Tel: 60-3-7651-7906  
Malaysia - Penang  
Tel: 60-4-227-8870  
Philippines - Manila  
Tel: 63-2-634-9065  
Singapore  
Tel: 65-6334-8870  
Taiwan - Hsin Chu  
Tel: 886-3-577-8366  
Taiwan - Kaohsiung  
Tel: 886-7-213-7830  
Taiwan - Taipei  
Tel: 886-2-2508-8600  
Thailand - Bangkok  
Tel: 66-2-694-1351  
Vietnam - Ho Chi Minh  
Tel: 84-28-5448-2100 | Austria - Wels  
Tel: 43-7242-2244-39  
Fax: 43-7242-2244-393  
Denmark - Copenhagen  
Tel: 45-4450-2828  
Fax: 45-4485-2829  
Finland - Espoo  
Tel: 358-9-4520-820  
France - Paris  
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-30-90-79 |