Introduction

Author: Per Andreas Gulbrandsen, Microchip Technology Inc.

This application note outlines how to get started with the tinyAVR® 0-series devices. Refer to the data sheet for further information on the differences between the tinyAVR® 0-series devices.

Features

• Getting Started with tinyAVR® 0-series Microcontrollers and Tools
• Getting Started with STK600 and Atmel Studio 7.0
Table of Contents

Introduction......................................................................................................................1
Features.......................................................................................................................... 1

1. Relevant Devices.......................................................................................................3
   1.1. tinyAVR 0-series...........................................................................................................................3

2. Get the Device Data Sheet........................................................................................4

3. Get the Tools............................................................................................................. 5
   3.1. Get the STK600 Starter Kit...........................................................................................................5
   3.2. Get Source Code from Atmel | START.........................................................................................6
   3.3. Get Atmel Studio 7.0.................................................................................................................... 7
   3.4. Get IAR Embedded Workbench for AVR......................................................................................7
   3.5. Get Device Support......................................................................................................................7

4. Atmel Studio Users Getting Started...........................................................................8
   4.1. Atmel Studio with STK600............................................................................................................8

5. What's Next............................................................................................................. 13

6. Revision History.......................................................................................................14

The Microchip Web Site................................................................................................ 15
Customer Change Notification Service........................................................................15
Customer Support......................................................................................................... 15
Microchip Devices Code Protection Feature................................................................. 15
Legal Notice...................................................................................................................16
Trademarks................................................................................................................... 16
Quality Management System Certified by DNV................................................................17
Worldwide Sales and Service........................................................................................18
1. Relevant Devices
This chapter lists the relevant devices for this document.

1.1 tinyAVR 0-series
The figure below shows the tinyAVR 0-series, laying out pin count variants and memory sizes:

- Vertical migration is possible without code modification, as these devices are fully pin- and feature compatible.
- Horizontal migration to the left reduces the pin count and, therefore, the available features.

Figure 1-1. tinyAVR® 0-series Overview

Devices with different Flash memory size typically also have different SRAM and EEPROM.
2. Get the Device Data Sheet

Web pages

• http://www.microchip.com/wwwproducts/en/ATtiny202
• http://www.microchip.com/wwwproducts/en/ATtiny204
• http://www.microchip.com/wwwproducts/en/ATtiny402
• http://www.microchip.com/wwwproducts/en/ATtiny404
• http://www.microchip.com/wwwproducts/en/ATtiny804
• http://www.microchip.com/wwwproducts/en/ATtiny806
• http://www.microchip.com/wwwproducts/en/ATtiny807
• http://www.microchip.com/wwwproducts/en/ATtiny804
• http://www.microchip.com/wwwproducts/en/ATtiny1604
• http://www.microchip.com/wwwproducts/en/ATtiny1606
• http://www.microchip.com/wwwproducts/en/ATtiny1607

Documents/files

• ATtiny202/402 Data Sheet (summary, complete) (.pdf)
• ATtiny204/404 Data Sheet (summary, complete) (.pdf)
• ATtiny406 Data Sheet (summary, complete) (.pdf)
• ATtiny804/1604 Data Sheet (summary, complete) (.pdf)
• ATtiny806/1606 Data Sheet (summary, complete) (.pdf)
• ATtiny807/1607 Data Sheet (summary, complete) (.pdf)

The documentation for the tinyAVR® 0-series is split into three document types:

• Manual (includes all device independent descriptions of the device)
• Data sheet¹ (includes all device dependent descriptions of the device, number of peripherals, pinout and electrical characteristics)
• Errata (includes all known erratas for the device)

¹ For devices that are future products, the product brief is available instead of the data sheet.
3. **Get the Tools**

Atmel Studio 7.0, which uses GCC compiler, is the preferred IDE to get started with tinyAVR® 0-series.

3.1 **Get the STK600 Starter Kit**

![STK600 Starter Kit](image)

Table 3-1. STK600 Device Support for tinyAVR® 0-series

<table>
<thead>
<tr>
<th>Device</th>
<th>Routing Card</th>
<th>Socket Card</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATtiny204</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny404</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny406</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny804</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny806</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny807</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
<tr>
<td>ATtiny1604</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny1606</td>
<td>STK600-RC020T-104</td>
<td>STK600-SOIC</td>
</tr>
<tr>
<td>ATtiny1607</td>
<td>STK600-RC024T-103</td>
<td>STK600-QFN24</td>
</tr>
</tbody>
</table>

For device support for other devices, refer to: [http://www.microchip.com/STK600_Starter_Kit-Users_Guide](http://www.microchip.com/STK600_Starter_Kit-Users_Guide)

**Web page**: [http://www.microchip.com/ATSTK600](http://www.microchip.com/ATSTK600)

**Get the kit**: [https://www.microchipdirect.com/product/ATSTK600](https://www.microchipdirect.com/product/ATSTK600)
Document/file:
• STK600 User Guide (.pdf)

Key features
• AVR® Studio 4/AVR32 Studio/AVR Studio 5/Atmel Studio Compatible
• USB Interface to PC for Programming and Control
• Powered from USB Bus or from an External 10-15V DC Power Supply
• Adjustable Target V$_{CC}$ (0-5.5V)
• Two Adjustable Reference Voltages with High Accuracy (0-5.0V, 10 mV res.)
• Clock Oscillator, Adjustable On-The-Fly from Atmel Studio (0-50 MHz, 0.1% res.)
• Serial In-System Programming (ISP) of tinyAVR and megaAVR® Devices
• PDI Programming of AVR XMEGA® Devices
• JTAG Programming of megaAVR, AVR XMEGA, and AVR UC3 Devices
• aWire Programming of AVR UC3 Devices
• ISP and JTAG Programming of AVR Devices in External Target Systems
• Flexible Routing and Socket Card System for Easy Mounting of all Supported Devices
• Eight Push Buttons for General Use
• Eight LEDs for General Use
• All AVR I/O Ports are Easily Accessible through Pin Header Connectors
• Expansion Connectors for Plug-In Modules and Prototyping Area
• On-Board 4 Mb DataFlash for Nonvolatile Data
• USB mini-AB (On-The-Go) Connector for AVR Devices with USB
• PHY and DSUB-9 Connector for RS-232 Interface
• PHY and DSUB-9 Connector for CAN Bus
• PHY and Header for LIN Bus
• Device Board with an ATmega2560 AVR Microcontroller Included

The STK600 User Guide describes how to power the kit and includes detailed information about board components, extension interface, and the hardware description.

3.2 Get Source Code from Atmel | START
The example code is available through Atmel | START, which is a web-based tool that enables configuration of application code through a Graphical User Interface (GUI). The code can be downloaded for both Atmel Studio and IAR Embedded Workbench® via the direct example code-link below or the Browse examples button on the Atmel | START front page.

Atmel | START web page: http://microchip.com/start

Example Code
Finding example code for devices in the tinyAVR 0-series can be done by searching for the device name, e.g. ATtiny406, in the Atmel | START example browser.

Click User guide in Atmel | START for details and information about example projects. The User guide button can be found in the example browser, and by clicking the project name in the dashboard view within the Atmel | START project configurator.

Atmel Studio
Download the code as an .atzip file for Atmel Studio from the example browser in Atmel | START, by clicking Download selected example. To download the file from within Atmel | START, click Export project followed by Download pack.

Double click the downloaded .atzip file and the project will be imported to Atmel Studio 7.0.

**IAR Embedded Workbench**

For information on how to import the project in IAR Embedded Workbench, open the Atmel | START User Guide, select Using Atmel Start Output in External Tools, and IAR Embedded Workbench. A link to the Atmel | START User Guide can be found by clicking Help from the Atmel | START front page or Help And Support within the project configurator, both located in the upper right corner of the page.

### 3.3 Get Atmel Studio 7.0


**Document/file:**
- Atmel Studio 7.0 (build 1645) Installer (.exe)

Atmel Studio 7.0 or later is the preferred IDE for developing and debugging firmware for the tinyAVR® 0-series.

For device support, refer to **3.5 Get Device Support.**

### 3.4 Get IAR Embedded Workbench for AVR

**Web page:** [https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR](https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR)

**Document/file:** IAR Embedded Workbench installer for AVR.

### 3.5 Get Device Support

**Atmel Studio:** Support for new devices in Atmel Studio can be added by using the Device Pack Manager, which is found under Tools → Device Pack Manager.

For tinyAVR® 0-series, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For tinyAVR® 0-series, select the latest available version of ATtiny_DFP.
3. Click Install.

For offline installers, go to [http://packs.download.atmel.com/](http://packs.download.atmel.com/). To install a package, double click on the installer file and follow the instructions. Any open Atmel Studio windows will have to be closed for the installation to take effect.

**IAR:** Support for new devices in IAR Embedded Workbench can be added by installing the latest service package. The service package is available at My Pages on [https://iar.com](https://iar.com).
4. Atmel Studio Users Getting Started

4.1 Atmel Studio with STK600

Prerequisites

- Atmel Studio 7.0 1645 or above installed
- The STK600 board connected to Atmel Studio 7.0 via the on-board USB connector.

Workflow

1. Launch Atmel Studio 7.0.
2. Start creating a new project by clicking *New → Project...* or by using the shortcut *Ctrl+Shift+N*, as shown in the figure below.

![Create New Project in Atmel Studio](image)

Figure 4-1. Create New Project in Atmel Studio

3. Select the *GCC C Executable Project* template from the new project wizard shown in the following figure, type in the name of the solution and project (e.g. *GETTING_STARTED* and *LED_TOGGLE*), and click **OK**.
4. Select ATtiny406 from the device selection wizard as shown in the figure below, and click **OK**.

**Figure 4-3. Device Selection Wizard**

A new project with a `main.c` file associated with it will be generated in Atmel Studio.
5. Replace the 'main' function in the main.c file with the following code snippet:

```c
int main (void)
{
    /* STK600 have eight User Buttons and eight User LEDs which can be connected to any IO pin using cables */
    /* Configure PB0 as input (remember to connect SW0 to PB0 using a cable */
    PORTB.DIRCLR = PIN0_bm;

    /* Configure PB1 as output (remember to connect LED0 to PB1 using a cable */
    PORTB.DIRSET = PIN1_bm;

    while (1)
    {
        /* Check the status of SW0 */
        /* 0: Pressed */
        if (!(PORTB.IN & (PIN0_bm)))
        {
            /* LED0 on */
            PORTB.OUTCLR = PIN1_bm;
        }
        /* 1: Released */
        else
        {
            /* LED0 off */
            PORTB.OUTSET = PIN1_bm;
        }
    }
}
```

In the code editor, the code may appear as shown in the figure below.

**Figure 4-4. Code Editor Window**

6. Open project properties by clicking *Project → Properties* or by using the shortcut *ALT+F7*. 
7. In Tool view (figure below), set Selected debugger/programmer to STK600 and Interface to UPDI.

Figure 4-5. Debugger and Interface for ATtiny406

8. Build the project by clicking Build → Build Solution or using the shortcut F7.

9. Connect the embedded debugger on STK600 to ATtiny406 by connecting a cable between the ISP/PDI headers, as shown in the figure below.

Figure 4-6. UPDI Connection on STK600
10. Connect PB0 to SW0, and PB1 to LED0 by using cables.
11. Load the code onto the STK600 and start debugging by clicking Debug → Start debugging and break or by using the shortcut ALT+F5. The application is programmed onto the device and the program execution should break in main.
12. Run the code by clicking Debug → Continue or by using the shortcut F5.
13. Verify that LED0 is lit when SW0 is pushed on STK600.
5. **What's Next**

For further information on related AVR products and IDE, refer to the links below:

**Software:**
- Atmel Studio help: *Help → View Help* (shortcut *CTRL+F1*)
- Atmel Gallery: [https://gallery.microchip.com/](https://gallery.microchip.com/)

**Firmware:**
- Atmel START documentation: [http://start.atmel.com/](http://start.atmel.com/)
- Atmel START examples: [http://microchip.com/start/#examples](http://microchip.com/start/#examples)

**Hardware:**
- AVR042: AVR Hardware Design Considerations: [http://www.microchip.com/AVR042:AVR_Hardware_Design_Considerations](http://www.microchip.com/AVR042:AVR_Hardware_Design_Considerations)

**Recommended programming/debugging tools:**
- Atmel-ICE:
- Power debugger:

**Other:**
- Application notes: [http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047](http://www.microchip.com/paramChartSearch/chart.aspx?branchID=30047), find the preferred device and go to the product page. All relevant application notes can be found under the documentation tab.
- More technical documentation concerning various products: [https://www.microchip.com/webdoc](https://www.microchip.com/webdoc)
6. **Revision History**

<table>
<thead>
<tr>
<th>Doc Rev.</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>10/2018</td>
<td>Fixed grammar and punctuation.</td>
</tr>
<tr>
<td>A</td>
<td>05/2018</td>
<td>Initial document release.</td>
</tr>
</tbody>
</table>
The Microchip Web Site

Microchip provides online support via our web site at http://www.microchip.com/. This web site is used as a means to make files and information easily available to customers. Accessible by using your favorite Internet browser, the web site contains the following information:

- **Product Support** – Data sheets and errata, application notes and sample programs, design resources, user’s guides and hardware support documents, latest software releases and archived software
- **General Technical Support** – Frequently Asked Questions (FAQ), technical support requests, online discussion groups, Microchip consultant program member listing
- **Business of Microchip** – Product selector and ordering guides, latest Microchip press releases, listing of seminars and events, listings of Microchip sales offices, distributors and factory representatives

Customer Change Notification Service

Microchip’s customer notification service helps keep customers current on Microchip products. Subscribers will receive e-mail notification whenever there are changes, updates, revisions or errata related to a specified product family or development tool of interest.


Customer Support

Users of Microchip products can receive assistance through several channels:

- Distributor or Representative
- Local Sales Office
- Field Application Engineer (FAE)
- Technical Support

Customers should contact their distributor, representative or Field Application Engineer (FAE) for support. Local sales offices are also available to help customers. A listing of sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

- Microchip products meet the specification contained in their particular Microchip Data Sheet.
- Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the intended manner and under normal conditions.
- There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data Sheets. Most likely, the person doing so is engaged in theft of intellectual property.
- Microchip is willing to work with the customer who is concerned about the integrity of their code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Legal Notice

Information contained in this publication regarding device applications and the like is provided only for your convenience and may be superseded by updates. It is your responsibility to ensure that your application meets with your specifications. MICROCHIP MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY OR OTHERWISE, RELATED TO THE INFORMATION, INCLUDING BUT NOT LIMITED TO ITS CONDITION, QUALITY, PERFORMANCE, MERCHANTABILITY OR FITNESS FOR PURPOSE. Microchip disclaims all liability arising from this information and its use. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk, and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, AnyRate, AVR, AVR logo, AVR Freaks, BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, Heldo, JukeBlox, KeeLoq, Kleer, LANCheck, LINK MD, maXSylus, maXTouch, MediaLB, megaAVR, MOST, MOST logo, MPLAB, OptoLyzer, PIC, picoPower, PICSTART, PIC32 logo, Prochip Designer, QTouch, SAM-BA, SpyNIC, SST, SST Logo, SuperFlash, tinyAVR, UNI/O, and XMEGA are registered trademarks of Microchip Technology Incorporated in the U.S.A. and other countries.

ClockWorks, The Embedded Control Solutions Company, EtherSynch, Hyper Speed Control, HyperLight Load, IntelliMOS, mTouch, Precision Edge, and Quiet-Wire are registered trademarks of Microchip Technology Incorporated in the U.S.A.


SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

Silicon Storage Technology is a registered trademark of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
Quality Management System Certified by DNV

ISO/TS 16949
Microchip received ISO/TS-16949:2009 certification for its worldwide headquarters, design and wafer fabrication facilities in Chandler and Tempe, Arizona; Gresham, Oregon and design centers in California and India. The Company’s quality system processes and procedures are for its PIC® MCUs and dsPIC® DSCs, KEELQ® code hopping devices, Serial EEPROMs, microperipherals, nonvolatile memory and analog products. In addition, Microchip’s quality system for the design and manufacture of development systems is ISO 9001:2000 certified.
<table>
<thead>
<tr>
<th>AMERICAS</th>
<th>ASIA/PACIFIC</th>
<th>ASIA/PACIFIC</th>
<th>EUROPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Office</td>
<td>Australia - Sydney</td>
<td>India - Bangalore</td>
<td>Austria - Wels</td>
</tr>
<tr>
<td></td>
<td>Tel: 61-2-9868-6733</td>
<td>Tel: 91-60-3090-4444</td>
<td>Tel: 43-7242-2244-39</td>
</tr>
<tr>
<td></td>
<td>China - Beijing</td>
<td>India - New Delhi</td>
<td>Denmark - Copenhagen</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-10-8569-7000</td>
<td>Tel: 91-11-4160-8631</td>
<td>Tel: 45-4450-2828</td>
</tr>
<tr>
<td></td>
<td>China - Chengdu</td>
<td>India - Pune</td>
<td>Finland - Espoo</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-28-8665-5511</td>
<td>Tel: 91-20-4121-0141</td>
<td>Tel: 358-9-4520-820</td>
</tr>
<tr>
<td></td>
<td>China - Chongqing</td>
<td>Japan - Osaka</td>
<td>France - Paris</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-23-8980-9588</td>
<td>Tel: 81-6-6152-7160</td>
<td>Tel: 33-1-69-53-63-20</td>
</tr>
<tr>
<td></td>
<td>China - Dongguan</td>
<td>Japan - Tokyo</td>
<td>Germany - Garching</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-769-8702-9880</td>
<td>Tel: 81-3-6880-3770</td>
<td>Tel: 49-8831-9700</td>
</tr>
<tr>
<td></td>
<td>China - Guangzhou</td>
<td>Korea - Daegu</td>
<td>Germany - Haan</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-20-8755-8029</td>
<td>Tel: 82-53-744-4301</td>
<td>Tel: 49-2129-3766400</td>
</tr>
<tr>
<td></td>
<td>China - Hangzhou</td>
<td>Korea - Seoul</td>
<td>Germany - Heilbronn</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-571-8792-8115</td>
<td>Tel: 82-2-554-7200</td>
<td>Tel: 49-7131-67-3636</td>
</tr>
<tr>
<td></td>
<td>China - Hong Kong SAR</td>
<td>Malaysia - Kuala Lumpur</td>
<td>Tel: 49-721-625370</td>
</tr>
<tr>
<td></td>
<td>Tel: 852-2943-5100</td>
<td>Malaysia - Penang</td>
<td>Germany - Karlsruhe</td>
</tr>
<tr>
<td></td>
<td>China - Nanjing</td>
<td>Malaysia - Penang</td>
<td>Tel: 49-69-627-144-00</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-25-8473-2460</td>
<td>Tel: 60-4-227-8870</td>
<td>Fax: 49-69-627-144-44</td>
</tr>
<tr>
<td></td>
<td>China - Qingdao</td>
<td>Philippines - Manila</td>
<td>Germany - Rosenberg</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-632-8502-7355</td>
<td>Tel: 63-2-634-9065</td>
<td>Tel: 49-8031-354-560</td>
</tr>
<tr>
<td></td>
<td>China - Shanghai</td>
<td>Singapore</td>
<td>Israel - Ra'anana</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-21-3326-8000</td>
<td>Tel: 65-6334-8870</td>
<td>Tel: 972-9-744-7705</td>
</tr>
<tr>
<td></td>
<td>China - Shenyang</td>
<td>Taiwan - Hsin Chu</td>
<td>Italy - Milan</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-24-2334-2829</td>
<td>Tel: 886-3-577-8366</td>
<td>Tel: 39-0331-742611</td>
</tr>
<tr>
<td></td>
<td>China - Shenzhen</td>
<td>Taiwan - Kaohsiung</td>
<td>Fax: 39-0331-46871</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-755-8864-2200</td>
<td>Tel: 886-7-213-7830</td>
<td>Italy - Padova</td>
</tr>
<tr>
<td></td>
<td>China - Suzhou</td>
<td>Taiwan - Taipei</td>
<td>Tel: 39-049-7625286</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-186-6233-1526</td>
<td>Tel: 886-2-2506-8600</td>
<td>Netherlands - Drunen</td>
</tr>
<tr>
<td></td>
<td>China - Wuhan</td>
<td>Thailand - Bangkok</td>
<td>Tel: 31-416-690399</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-27-5980-5300</td>
<td>Tel: 66-2-694-1351</td>
<td>Fax: 31-416-690340</td>
</tr>
<tr>
<td></td>
<td>China - Xian</td>
<td>Vietnam - Ho Chi Minh</td>
<td>Norway - Trondheim</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-29-8833-7252</td>
<td>Tel: 84-28-5448-2100</td>
<td>Tel: 47-72884388</td>
</tr>
<tr>
<td></td>
<td>China - Xiamen</td>
<td></td>
<td>Poland - Warsaw</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-992-2388138</td>
<td></td>
<td>Tel: 48-22-3325737</td>
</tr>
<tr>
<td></td>
<td>China - Zuhai</td>
<td></td>
<td>Romania - Bucharest</td>
</tr>
<tr>
<td></td>
<td>Tel: 86-756-3210040</td>
<td></td>
<td>Tel: 40-21-407-87-60</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Spain - Madrid</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 34-91-708-08-90</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fax: 34-91-708-08-91</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Sweden - Gothenberg</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 46-31-704-60-40</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Sweden - Stockholm</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 46-8-5090-4654</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>UK - Wokingham</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tel: 44-118-921-5800</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fax: 44-118-921-5820</td>
</tr>
</tbody>
</table>

© 2018 Microchip Technology Inc.