Description

This application note is for getting started with the Atmel® ATtiny102/104 AVR® based microcontroller.

The Atmel ATtiny102/104 is a low-power CMOS 8-bit microcontroller based on the AVR enhanced RISC architecture. By executing powerful instructions in a single clock cycle, ATtiny102/104 achieves throughputs close to 1 MIPS per MHz. This empowers the system designer to optimize the device for power consumption versus processing speed.

Features

- Getting started with the ATtiny102/104 microcontroller and tools.
- Getting started with Atmel ATtiny104 Xplained Nano Kit and Atmel Studio 7.

This application note contains a list of all tools required to start using ATtiny102/104 and provides references for additional information.
# Table of Contents

Description.......................................................................................................................1

Features..................................................................................................................................1

1. Getting Started with Atmel ATtiny102 and ATtiny104 ...............................................3
   1.1. Key Features..................................................................................................................3
   1.2. Device Related Website Links........................................................................................3
   1.3. ATtiny104 Xplained Nano Kit......................................................................................5
   1.4. Atmel Studio..................................................................................................................7
       1.4.1. Atmel Studio Webpage .......................................................................................7
       1.4.2. Atmel Studio Microsite.......................................................................................7
   1.5. Connecting the ATtiny104 Xplained Nano Kit..........................................................7
       1.5.1. Auto Board Identification of Xplained Nano Kit ..................................................8
       1.5.2. Connect the ATtiny104 Xplained Nano UART to the mEDBG COM Port..........9

2. Creating an Example Application in Atmel Studio......................................................10

3. What’s Next?................................................................................................................14

4. Revision History............................................................................................................15
1. Getting Started with Atmel ATtiny102 and ATtiny104

1.1. Key Features

- AVR (Harvard) Architecture
- Single Level Pipelining
- In-system Reprogrammable Flash Memory
- 12 MIPS throughput at 12MHz
- Most Single Clock Cycle Execution
- High Code Density (Advanced RISC Instruction Set)
- Programmable Supply Voltage Level Monitor with Interrupt and Reset
- Low Power MCU with various Sleep Modes
- Accurate Internal Calibrated Oscillator
- Fast and Normal Start-up Time Options
- Security with Fuses and Lock Bits
- Compatibility between devices (portability)

Note: For more information about ATtiny102 and ATtiny104, refer to the device datasheet.

1.2. Device Related Website Links

The ATtiny102/104 product webpages are available at the following links:

Figure 1-1. Device Webpage

The ATtiny102 product webpage is available at the following link: http://www.atmel.com/devices/ATTINY102.aspx

The product webpage has five tabs to provide specific information related to the device.

- The **Overview** tab provides the basic information related to the device such as Key Parameters, Datasheet, link to buy the device, etc.
  


---

The high-performance Atmel® tinyAVR® microcontroller combines 1kB in-system programmable flash memory, 32 bytes SRAM, 12 general-purpose I/O lines, 16 general-purpose working registers, one 16-bit timer/counters with two PWM channels, internal and external interrupts, an 8-channel 10-bit A/D converter, on-chip analog comparator, one full duplex UART, or programmable watchdog timer with internal oscillator, internal calibrated oscillator, 10-bits unique ID (serial number), three calibrated internal voltage references (1.1V, 2.2V and 4.3V), and four software selectable power saving modes. A version with faster startup time is available under a dedicated part number. The device operates between 1.8-5.5 volts.

By executing powerful instructions in a single clock cycle, the device achieves throughputs approaching 1 MIPS per MHz, balancing power consumption and processing speed.

The ATtiny104 device is a small, very versatile, low-cost, easy-to-use microcontroller suited to almost any application. It can be used for system monitoring, battery measurement, battery charging, voltage measurement, current measurement, interface to buttons, switches, drive of small motors, drive of one or more LEDs, and more. The integrated UART provides means for wired or wireless interface, making it possible to make a powerful, yet small and low-cost solution for any Internet of Things (IoT) end-nodes.

### Key Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash (kBytes):</td>
<td>1 kBytes</td>
</tr>
<tr>
<td>Pin Count:</td>
<td>14</td>
</tr>
<tr>
<td>Max. Operating Freq. (MHz):</td>
<td>12 MHz</td>
</tr>
<tr>
<td>CPU:</td>
<td>8-bit AVR</td>
</tr>
<tr>
<td># of Touch Channels:</td>
<td>0</td>
</tr>
<tr>
<td>Hardware QTouch Acquisition:</td>
<td>No</td>
</tr>
<tr>
<td>Max I/O Pins:</td>
<td>12</td>
</tr>
<tr>
<td>Ext Interrupts:</td>
<td>12</td>
</tr>
<tr>
<td>USB Speed:</td>
<td>No</td>
</tr>
<tr>
<td>USB Interface:</td>
<td>No</td>
</tr>
</tbody>
</table>

---

Related Items

- Third Party Support
- University Program
- AVR Knowledge Base
- Technical Support
- What's Changed
- Mature Devices
- The **Parameters** tab provides the details of various configuration parameters for the device.

- The **Tools** tab - all the related tools such as IDE, Programmer, Debugger, Evaluation Kits, and BSDL files are listed. This tab features the link to ATtiny104 Xplained Nano kit's webpage.

- The **Documents** tab provides all the related documents such as datasheet and application notes.
  - The **Datasheet** section contains two types of datasheets:
    - Preliminary/Complete version includes all peripheral descriptions and electrical characteristics.
    - Preliminary Summary/Summary version includes ordering information, pin out, and packaging information.
  - The **Application Notes** section has the device related Application Notes such as Peripheral Usage, Getting Started, Hardware design considerations, etc., and its associated firmware (if available).

- The **Applications** tab provides the recommended application areas (not limited to) for this device.

### 1.3. ATtiny104 Xplained Nano Kit

The details about ATtiny104 Xplained Nano Kit is available in the following link.

Device **Ordering Information** is available in the bottom section of the page.
Documents tab displays the kit related documents such as schematics and user guides.
Note: For detailed information about the kit such as headers and connections, refer to ATtiny104 Xplained Nano User Guide.

1.4. **Atmel Studio**

1.4.1. **Atmel Studio Webpage**

The Atmel Studio (free IDE) installer is available at:

http://www.atmel.com/tools/ATMELSTUDIO.aspx

1.4.2. **Atmel Studio Microsite**

To learn more about Atmel Studio, refer to the following microsite:

http://www.atmel.com/microsite/atmel-studio/

![Atmel Studio Microsite Webpage](http://www.atmel.com/Microsite/atmel-studio/videos.aspx)

In the **Videos** tab the getting started videos such as creating a new C (GCC) project, debugging AVR applications, debugging ARM® applications, etc. are available.


1.5. **Connecting the ATtiny104 Xplained Nano Kit**

This section helps the user to connect the ATtiny104 Xplained Nano with the Atmel Studio 7.

1. Download and install **Atmel Studio 7** or later versions.
2. Launch the Atmel Studio application.
3. Connect the ATtiny104 Xplained Nano to the USB port and it will be visible in the Atmel Studio.
1.5.1. **Auto Board Identification of Xplained Nano Kit**

- When the ATtiny104 Xplained Nano kit is connected to the PC, the Windows® Task bar will pop-up a message, as displayed in the following screenshot.

  **Figure 1-4. ATtiny104 Xplained Nano Driver Installation**

- If the driver installation is successful, mEDBG will be listed in the Device Manager, as displayed in the following screenshot.

  **Figure 1-5. Successful mEDBG Driver Installation**

- Launch Atmel Studio.
- Go to **View > Available Atmel Tools**. The mEDBG should get listed in the tools as mEDBG and the tool status should display as **Connected**. This indicates that the tool is communicating as expected with the Atmel Studio.
1.5.2. Connect the ATtiny104 Xplained Nano UART to the mEDBG COM Port

1. Connect the mEDBG USB to the PC.
2. Use the Device Manager to find the COM port number.
3. Default COM port settings are 9600 baud N 8 1. The COM port settings can be changed by using the Device Manager.
2. Creating an Example Application in Atmel Studio

To create a new project in Atmel Studio after connecting the ATtiny104 Xplained Nano:

1. Go to File > New > Project (Ctrl+Shift+N).

   **Figure 2-1. Creating New Project in Atmel Studio**

2. In the **New Project wizard** displayed, select the **GCC C executable Project** template, name the project, and click **OK** to get the device selection wizard.

   **Figure 2-2. New Project Wizard**

3. The **Device Selection wizard** appears as follows. Select the **ATtiny104** device from the drop-down list and click **OK**.

   **Figure 2-3. Device Selection Wizard**

4. The new project and the **main.c** file will be created.

5. Add the following code snippet (LED control using push button) in the **main.c** file.

   ```c
   int main(void)
   {
       /* enable the pull-up function */
       PUEB |= 1<<PORTB1;
   }
   ```
/* enable pull-up for button */
PORTB |= 1<<PORTB1;

/* configure LED pin as output */
DDRA |= 1<<DDRA5;
while(1)
{
    /* check the button status (press - 0, release - 1) */
    if(!(PINB & (1<<PINB1)))
    {
        /* switch on the LED until button is pressed */
        PORTA &= ~(1<<PORTA5);
    }
    else
    {
        /* switch off the LED if button is released */
        PORTA |= 1<<PORTA5;
    }
}

6. The project and the main.c file with the code snippet appears as shown.

Figure 2-4. Project Window

7. Code explanation:
   - The application uses the mechanical button and yellow LED of ATtiny104 Xplained Nano kit. They are connected to Port Pin PB1 and PA5, respectively.
   - Each PORT has three registers; DDRx, PORTx, and PINx.
   - The DDRx register is used to configure the port pin direction.
     * 1 - Output
     * 0 - Input
   - The kit does not have pull-up resistors onboard and hence internal pull-up has to be enabled for the button.
   - Configure the PUEx register to enable internal pull-up of the corresponding port pin.
When a pin is configured as input and the respective bit in PORTx is written logic one, the respective pin is internally pulled up.

The PINx register is used to return the logic level available on the port pin.

The button connected to pin PB1 is configured as input with pull-up enabled. LED connected to Pin PA5 is configured as output.

The LED is controlled based on the button status. When the button is not pressed the LED will not glow. When pressing the button the LED will glow.

8. Go to **Build > Build Solution (F7)** to compile the project.

9. When the code is compiled successfully, go to **Tools > Device Programming (Ctrl+Shift+P)**.

10. Select the **Tool** (as mEDBG), **Device** (as ATtiny104), and **Interface** (as TPI). Click **Apply**.

Figure 2-5. Tool and Interface Settings

11. **Read** the **Device Signature** and **Target Voltage** to ensure proper connection.

12. In the **Device Programming** window, go to **Memories** Tab. Click **Erase now** to erase the device.

13. To program the device with the hex file, browse the *.hex/elf file location and click **Program**.
14. The working of the application can be tested manually. The LED shall turn ON when the button is pressed and turns OFF when the button is released.
3. **What’s Next?**

- Atmel Studio videos
- Atmel Studio online help
  http://www.atmel.com/webdoc/atmelstudio/
- Atmel Studio offline help (after installing Atmel Studio)
  Open Atmel Studio, Help > View Help (Ctrl+F1) > Atmel Studio
- ASF (Atmel Software framework) Getting Started and ASF Reference manual
- ASF online documentation
  http://asf.atmel.com/docs/latest/
- Technical documentation for various products
  http://www.atmel.com/webdoc/
- Atmel Gallery
  https://gallery.atmel.com/
- Production Selection Guide
  Atmel MCU Selector on http://www.atmel.com/
- Ordering samples and buying evaluation board and kits:
  http://www.atmel.com/. Go to **Buy > Atmel store**
- Technical documentation
  http://www.atmel.com/design-support/documentation/default.aspx
- Knowledge base and technical support/design support
  http://www.atmel.com/design-support/
- Collaborative workspace
  http://spaces.atmel.com
- AVR Freaks® community
  http://www.avrfreaks.net/
4. Revision History

<table>
<thead>
<tr>
<th>Doc. Rev.</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>42678A</td>
<td>02/2016</td>
<td>Initial document release</td>
</tr>
</tbody>
</table>
Atmel Corporation

1600 Technology Drive, San Jose, CA 95110 USA

T: (+1)(408) 441.0311
F: (+1)(408) 436.4200

www.atmel.com


Atmel®, Atmel logo and combinations thereof, Enabling Unlimited Possibilities®, AVR® and others are registered trademarks or trademarks of Atmel Corporation in U.S. and other countries. Windows® is a registered trademark of Microsoft Corporation in U.S. and or other countries. Other terms and product names may be trademarks of others.

DISCLAIMER: The information in this document is provided in connection with Atmel products. No license, express or implied, by estoppel or otherwise, to any intellectual property right is granted by this document or in connection with the sale of Atmel products. EXCEPT AS SET FORTH IN THE ATMEL TERMS AND CONDITIONS OF SALES LOCATED ON THE ATMEL WEBSITE, ATMEL ASSUMES NO LIABILITY WHATSOEVER AND DISCLAIMS ANY EXPRESS, IMPLIED OR STATUTORY WARRANTY RELATING TO ITS PRODUCTS INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT SHALL ATMEL BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL, PUNITIVE, SPECIAL OR INCIDENTAL DAMAGES (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS AND PROFITS, BUSINESS INTERRUPTION, OR LOSS OF INFORMATION) ARISING OUT OF THE USE OR INABILITY TO USE THIS DOCUMENT, EVEN IF ATMEL HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Atmel makes no representations or warranties with respect to the accuracy or completeness of the contents of this document and reserves the right to make changes to specifications and products descriptions at any time without notice. Atmel does not make any commitment to update the information contained herein. Unless specifically provided otherwise, Atmel products are not suitable for, and shall not be used in, automotive applications. Atmel products are not intended, authorized, or warranted for use as components in applications intended to support or sustain life.

SAFETY-CRITICAL, MILITARY, AND AUTOMOTIVE APPLICATIONS DISCLAIMER: Atmel products are not designed for and will not be used in connection with any applications where the failure of such products would reasonably be expected to result in significant personal injury or death ("Safety-Critical Applications") without an Atmel officer's specific written consent. Safety-Critical Applications include, without limitation, life support devices and systems, equipment or systems for the operation of nuclear facilities and weapons systems. Atmel products are not designed nor intended for use in military or aerospace applications or environments unless specifically designated by Atmel as military-grade. Atmel products are not designed nor intended for use in automotive applications unless specifically designated by Atmel as automotive-grade.