Introduction

This application note aims at helping the reader to get started with the Atmel® SAM L22 ARM® Cortex®-M0+ based Ultra low-power segment LCD microcontroller.

Atmel | SMART SAM L22 is a series of Ultra low-power segment LCD microcontrollers using the 32-bit ARM Cortex-M0+ processor, ranging from 48- to 100-pins with up to 256KB Flash and 32KB of SRAM and to drive up to 320 LCD segments. The SAM L22 devices operate at a maximum frequency of 32MHz and reach 2.14 Coremark/ MHz. With sophisticated power management technologies the SAM L22 devices run below 50μA/MHz in active mode and below 600nA in ultra-low-power backup mode with RTC.

SAM L22 is targeted for segment LCD and/or Battery powered applications, like sport watches, personal healthcare devices, thermostat with user interface, access control panels and metering (gas, water, energy metering, and basic smart meter) applications.

Features

- Getting started with Atmel SAM L22 microcontrollers
- Getting started with Atmel SAM L22 tools (Atmel SAM L22 Xplained PRO, Atmel Software Framework 3.26.10 or later, and Atmel Studio 6.2 or later)
# Table of Contents

Introduction......................................................................................................................1

Features.......................................................................................................................... 1

1. Configuration Summary.............................................................................................3

2. Getting the Device Datasheet....................................................................................4

3. Get the SAM L22 Xplained Pro Evaluation Kit...........................................................5

4. Get the Tools..............................................................................................................7
   4.1. Get Atmel Studio 6........................................................................................................ 7
   4.2. Get IAR Embedded Workbench for ARM.................................................................7
   4.3. Get SAM L22 Xplained Pro Embedded Debugger Software (Segger J-Link).........7
   4.4. Get Atmel Software Framework (ASF).................................................................7
   4.5. Atmel Studio 6.2 Users Getting Started...............................................................7

5. What’s Next?............................................................................................................11

6. Revision History.......................................................................................................12
### Configuration Summary

Table 1-1 Comparison Between SAM L22, SAM L21, and SAM D21 on page 3 shows the difference between SAM L22, SAM L21, and SAM D21 features. For more details, refer to the datasheet of the respective products.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Pins</td>
<td>100</td>
<td>64</td>
<td>48</td>
<td>64</td>
<td>48</td>
<td>32</td>
<td>64</td>
<td>48</td>
<td>32</td>
</tr>
<tr>
<td>GPIO(s)</td>
<td>82</td>
<td>50</td>
<td>36</td>
<td>51</td>
<td>37</td>
<td>25</td>
<td>52</td>
<td>26</td>
<td>26</td>
</tr>
<tr>
<td>Flash</td>
<td>256/128/64KB</td>
<td>256/128/64KB</td>
<td>256/128/64KB</td>
<td>256/128/64KB</td>
<td>256/128/64KB</td>
<td>256/128/64/32KB</td>
<td>256/128/64/32KB</td>
<td>256/128/64/32KB</td>
<td>256/128/64/32KB</td>
</tr>
<tr>
<td>Flash RWW section</td>
<td>8/4/2KB</td>
<td>8/4/2KB</td>
<td>8/4/2KB</td>
<td>8/4/2KB</td>
<td>8/4/2KB</td>
<td>8/4/2KB</td>
<td>2KB/1KB in 32KB and 64KB Flash variants</td>
<td>2KB/1KB in 32KB and 64KB Flash variants</td>
<td>2KB/1KB in 32KB and 64KB Flash variants</td>
</tr>
<tr>
<td>System SRAM</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
<td>32/16/8KB</td>
</tr>
<tr>
<td>Low Power SRAM</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>8/8/4KB</td>
<td>8/8/4KB</td>
<td>8/8/4KB</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Segment LCD (SLCD) Pins</td>
<td>48</td>
<td>31</td>
<td>23</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Timer Counter (TC)</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>5</td>
<td>3</td>
<td>3</td>
<td>5</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Timer Counter for Control (TCC)</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>DMA channels</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>USB interface</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>AES engine</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Configurable Custom Logic (CCL) (LUTs)</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>True Random Generator (TRNG)</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>SERCOM</td>
<td>6</td>
<td>4</td>
<td>3</td>
<td>6</td>
<td>6</td>
<td>4</td>
<td>6</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>ADC channels</td>
<td>20</td>
<td>16</td>
<td>10</td>
<td>20</td>
<td>14</td>
<td>10</td>
<td>20</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>Analog Comparators</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>DAC Channels</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Op-Amp</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>Tamper Input Pins</td>
<td>5</td>
<td>3</td>
<td>2</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>RTC</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>RTC alarms</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>External Interrupt lines</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>PTC channels for mutual capacitance</td>
<td>256 (16x16)</td>
<td>182 (13x14)</td>
<td>110 (10x11)</td>
<td>12x16 16x12</td>
<td>8x12 12x8</td>
<td>6x10 10x6</td>
<td>16x16 12x10</td>
<td>10x6</td>
<td></td>
</tr>
<tr>
<td>PTC channels for self capacitance</td>
<td>24</td>
<td>19</td>
<td>13</td>
<td>16</td>
<td>12</td>
<td>10</td>
<td>16</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum CPU frequency</td>
<td>32MHz</td>
<td>32MHz</td>
<td>32MHz</td>
<td>48MHz</td>
<td>48MHz</td>
<td>48MHz</td>
<td>48MHz</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Packages</td>
<td>TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td>QFN TQFP</td>
<td></td>
</tr>
<tr>
<td>Event System channels</td>
<td>8</td>
<td>8</td>
<td>8</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>SW Debug Interface</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>WDT</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>
2. **Getting the Device Datasheet**


Document: Atmel SAM L22 Datasheet (summary, complete) (.pdf)

Select the latest datasheet (.pdf file). There are two versions:

- Complete version (includes all peripheral descriptions and electrical characteristics)
- Summary version (includes Ordering Information, pinout and Packaging Information)
3. **Get the SAM L22 Xplained Pro Evaluation Kit**


*Get the kit:* http://store.atmel.com

**Figure 3-1 SAM L22 Xplained Pro Picture**

---

**Document:**
Key features:

- ATSAML22N18A microcontroller
- One mechanical reset button
- One user button (wake-up, bootloader entry or general purpose)
- One Yellow user LED (LED0)
- USB Device interface function
- One QTouch® Button
- Segment LCD connector with additional lines for touch
- ATAES132 Crypto Authentication
- 32.768kHz crystal
- Standard Cortex Debug connector
- 3 Xplained Pro extension headers (EXT1, EXT2, and EXT3)
- USB powered
- Supported with application examples in Atmel Software Framework
- Embedded Debugger
  - Auto ID for board identification in Atmel Studio 6.2
  - Programming/debugging of target via SWD
  - Data gateway interface to target (SPI & TWI)
  - Four GPIOs connected to target
  - One yellow EDBG status LED
  - One green board power LED (controlled by EDBG)
  - Virtual COM-port interface via UART
- Embedded current measurement circuitry, with Atmel Data Visualizer support for data visualization
- Arduino extension footprint

The SAM L22 Xplained Pro User Guide application note covers how to power the kit, the detailed information of the on board components, extension interface and the hardware guide.
4. **Get the Tools**

Atmel Studio 6.2 is the preferred IDE to get started with the SAM L22 device and GCC compiler. Atmel Software Framework (ASF) provides SAM L22 peripheral drivers and example projects. IAR™ compiler is supported as well.

4.1. **Get Atmel Studio 6**

**Web page:** [www.atmel.com/atmelstudio](http://www.atmel.com/atmelstudio)

**Document/file:**
- Atmel Studio 6.2 installer (.exe)

Atmel Studio 6.2 is the IDE for developing and debugging firmware for the SAM L22 microcontroller.

4.2. **Get IAR Embedded Workbench for ARM**


**Document/file:**
- IAR installer for ARM

4.3. **Get SAM L22 Xplained Pro Embedded Debugger Software (Segger J-Link)**

**Web page:** [http://www.segger.com/jlink-software.html](http://www.segger.com/jlink-software.html)

**Document/file:**
- J-Link software

This software is required to program/debug the SAM L22 Xplained Pro embedded debugger with IAR IDE.

4.4. **Get Atmel Software Framework (ASF)**

**Web page:** [www.atmel.com/asf](http://www.atmel.com/asf)

**Document/file:**
- ASF update for Atmel Studio (.vsix) from ASF web page
- ASF update through Tools>Extension Manager from Atmel Studio
- ASF standalone package for GCC makefile and IAR users
- ASF: Getting started (.pdf)
- ASF: Reference Manual (.pdf)
- ASF online documentation for available API and examples can be found at [http://asf.atmel.com](http://asf.atmel.com)

4.5. **Atmel Studio 6.2 Users Getting Started**

**Prerequisites:**
• Atmel Studio 6.2 SP2 or above installed
• ASF version 3.26.10 or above installed
• SAM L22 Xplained Pro board connected to PC through embedded debugger USB connector. The kit is powered through USB.

Getting started with Atmel Studio 6.2, ASF, and SAM L22 Xplained Pro:

• Launch Atmel Studio 6.2
• Connect the SAM L22 Xplained Pro board to the PC using a USB cable
• A page on SAM L22 Xplained Pro description will open in Atmel Studio
• This page contains external link to Device Technical Documentation, Datasheet, Kit user guide, and Kit specific details like serial number and target name. Also, there will be an option to open ASF example projects.
• To open ASF examples, click File-> New -> then Example Project.

**Figure 4-1 Creating New Example Project in Atmel Studio**

- Select ‘Getting started application-SAM L22 Xplained Pro’ as shown in **Figure 4-2 SAML22 Getting started Project Selection** on page 9, press OK and accept the license agreement. Then the project will be created and opened
Open project properties (Project -> Properties or shortcut Alt+f7)

In Tool view, set ‘Select debugger/programmer’ to XPRO-EDBG and interface to SWD as shown in Figure 4-3  SAML22 Atmel Studio – Tools Configuration on page 9

Build the project: Build -> Build solution or shortcut F7
To load the code in the SAM L22 Xplained Pro and debug, select Debug -> Start debugging and break (shortcut Alt + F5)

The application is programmed and the debugger breaks in main

To run the code, select Debug -> Continue (shortcut F5)

On the computer, open and configure a terminal application (e.g. HyperTerminal on Microsoft® Windows® or Terminal application is available as an addon to Atmel Studio) with these settings:

- 38400 bauds
- 8 bits of data
- No parity
- 1 stop bit
- No flow control

Start the application

The LED should start blinking on the board. In the terminal window, the following text should appear (values depend on the board and chip used):

```plaintext
Getting Started Example xxx --
xxxxxx-xx
Compiled: xxx xx xxxx xx:xx:xx --
```

Pressing and release button SW0 should make LED0 on and off blinking.
5. **What’s Next?**

- Atmel Studio videos: [www.atmel.com/atmelstudio](http://www.atmel.com/atmelstudio)
- Atmel Studio help: Help -> View Help (Ctrl+F1)
- ASF Getting Started: [www.atmel.com/asf](http://www.atmel.com/asf)
- ASF online documentation: [http://ASF.atmel.com/docs/latest/](http://ASF.atmel.com/docs/latest/)
- Technical Documentation for various products: [www.atmel.no/webdoc](http://www.atmel.no/webdoc)
- Technical Support: [http://www.atmel.com/design-support/](http://www.atmel.com/design-support/)
6. **Revision History**

<table>
<thead>
<tr>
<th>Doc Rev.</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>42494A</td>
<td>08/2015</td>
<td>Initial document release.</td>
</tr>
</tbody>
</table>